This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Laura 7 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
February 8, 2019 at 10:48 am #3174662

henrikB-10

Currently my SEO title and metadescription (yoast) on the danish site are duplicated to the english and german version of the site. I want them either translated or not duplicating at all. Can you please help with this?

February 9, 2019 at 6:35 pm #3178662

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

I see from your debug information that yoast custom fields like yoast_wpseo_title etc are set to Copy, this explains why you can't translate them.

Please go to WPML -> Settings -> Custom field translation and search for yoast related fields and set them to "Translate" or "Do not translate" following your preferences, then you should be able to see them in the translation editor.

For other doubts you can check our documentation: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/#%22translate-page-seo-attributes

Let me know if this helps you or if you need further assistance.

February 12, 2019 at 7:28 am #3186895

henrikB-10

Hi Laura

I'm not able to find yoast related fields under custom field translation in WPML settings. What do I do then?

February 13, 2019 at 10:42 am #3193349

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

it would be really strange if those fields do not appear.

If you may provide temporary credentials I'll check myself. I'll enable a private reply.

February 13, 2019 at 3:43 pm #3195083

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the Yoast settings are among the system fields (see screenshot). Click on "show system fields" and you'll find them.
As you can see, the yoast_wpseo_title and yoast_wpseo_metadesc are locked to translate by default but you should be able to unlock them and set them to "not translate" or "copy".

February 14, 2019 at 8:32 am #3198162

henrikB-10

Hi Laura

Now I've found the fields, thanks.

I have tried to unlock them, as you said, but with no success. Do you how to unlock the yoast fields?

February 14, 2019 at 1:30 pm #3200023

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

try searching for wpml-config.xml inside Yoast plugin folder, you should be able to change the setting from "translate" to "do not translate" from there.

February 15, 2019 at 12:34 pm #3204810

henrikB-10

Hi Laura

We have a folder in plugins called wordpresss SEO Premium, and in here we are able to change the settings for SEO titles and metas to "Do not translate", but when we do that nothing happens, they are still locked in the CMS.

February 15, 2019 at 12:55 pm #3204936

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

changing the option doesn't remove the lock. Can you check if the custom field appears in the Translation Editor or not? If they don't appear the edit worked.

February 26, 2019 at 1:13 pm #3244996

henrikB-10

Where do we find the translation editor?

February 27, 2019 at 11:27 am #3249802

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the translation editor is what you get when clicking on the "+" icon next to a page to translate, please see here: https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/#translating-using-wpmls-translation-editor

February 28, 2019 at 8:26 am #3254071

henrikB-10

Hi,

The yoast fields doesn't appear in the translation editor. But what if we want to translate the SEO titles and descriptions instead. Now i see we are able to change something on the dansih site without it also appearing on the english and german sites. But what if we want to translate the fields?

March 1, 2019 at 8:34 am #3258933

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

if you set the Yoast field to "copy" or "don't translate" you can never translate them.

You may set them to "copy once" so they will be copied the first time you create the translation but you can also edit them after it. In that case you need to open the WordPress editor and not the translation editor because the fields won't appear in the Translation Editor.
You can read more about it here: https://wpml.org/documentation/support/language-configuration-files/#custom-fields

Let me know if this helps you or if you need further assistance.

March 1, 2019 at 9:11 am #3259141

henrikB-10

I would like to manage the translation in the CMS. But I am still not able to remove the lock on the yoast custom fields in WPML. How do I do that?

Need I add more code to wpml-config to make it work, like the page you are referring to: https://wpml.org/documentation/support/language-configuration-files/#custom-fields?

March 1, 2019 at 10:17 am #3259589

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

please try to add

<custom-field action="translate">_yoast_wpseo_title</custom-field>

in WPML -> Settings -> Custom XML configuration because if it's set to translate is should be unlocked, but maybe there is some other xml-config file overriding it.
If it works, you can add the other fields you need to translate as well.