This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 10.09 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 2 voices.

Last updated by martaS-10 6 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 3, 2019 at 6:34 am #3522801

martaS-10

Tell us what you are trying to do?
Translate these two sentences:
"YOUR SHOPPING CART IS EMPTY
We invite you to get acquainted with an assortment of our shop.Surely you can find something for yourself!"
Is there any documentation that you are following?
no
Is there a similar example that we can see?
no
What is the link to your site?
hidden link

April 3, 2019 at 7:29 am #3523059

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum.

Please clarify from where you have added the text? Is it from the theme options?

Did you try searching the string in WPML > String translation table, Were you able to find the string there?

Please check the translation steps mentioned in the xstore documentation
hidden link

Does it help?

Let me know the results. If you are still stuck please share temporary access to the site. I have enabled the private reply for you to securely share the details.

Kind regards
Raja

April 3, 2019 at 6:30 pm #3529773

martaS-10

The text is automatically generated. The 'cart' page only has "[woocommerce_cart]" in it.

I've scanned the theme/plugin files, found the strings in the 'String Translation' part and translated them, and marked the translation as complete.

It has worked for literally all the other strings I've found and translated but not for these two... Is there like a 'cache' for translated strings and it hasn't been updated or something?

April 4, 2019 at 6:58 am #3532681

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the information, If you can see the string in ST tables then it should be a cache issu.

Try clearing the String Translation cache. from WPML > Support > Troubleshooting (check screenshot)

In the troubleshooting page,
- Click "Clear the Cache in WPML"
- Scroll down, click "Recreate ST DB cache tables"

Please increase the PHP Memory Limit (your current setting is 40M).

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Let me know the results

Kind regards
Raja

April 5, 2019 at 6:48 am #3540977

martaS-10

Did "Clear the Cache in WPML", got alert pop-up saying 'Done',
Did "Recreate ST DB cache tables", got alert pop-up saying 'Done'.
Also increased the PHP Memory Limit.

The strings still are not appearing translated.

April 5, 2019 at 2:04 pm #3544759

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for trying all the steps. Please share temporary login details, Let me check this for you, I have enabled the private fields for you to securely share the details.

Kind regards
Raja

April 9, 2019 at 9:20 am #3564807

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

the string is coming from the theme option. I have added the text to string translation by adding the below config to WPML > Settings > Custom xml Configuration

<wpml-config>
    <admin-texts>
        <key name="et_options">
            <key name="empty_cart_content"></key>
        </key>
    </admin-texts>
</wpml-config>

Please go to WPML > String translation, Select the domain admin_texts_et_option You can see the cart text available for trasnaltion.

I hope this solves your issue.

Kind regards
Raja

April 9, 2019 at 2:33 pm #3568073

martaS-10

My issue is resolved now. Thank you!