Hi, Amit here, I am the WPML Support Manager, our current ticket queue is quite calm and I'd like to encourage you to use our new chat support option

We are working hard to debug and look at every single report

All of the known issues are documented in https://wpml.org/known-issues/ you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

We are also adding once a week a tutorial to our YouTube channel - https://www.youtube.com/c/WPML-multilingual - check out if we already covered what you need and leave us a comment if you want us to produce anything there

If you do need to open a ticket please make sure to provide us with all the needed information as described here https://wpml.org/faq/checklist-before-opening-a-ticket-in-wpml-support/

We are very proud at our level of support, we are one team from all over the world and we are all experienced WordPress developers, you can read more about us here - https://wpml.org/forums/supporters/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bruno 1 year, 2 months ago.

Assigned support staff: Bruno.

Author Posts
October 23, 2017 at 3:40 am #1408202

davidS-138

I am trying to: translate the WooCommerce new order email that gets sent to the admin

Link to a page where the issue can be seen:

I want to see: the email in the translated language

Instead, I got: the email in English

October 24, 2017 at 1:42 pm #1410127

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-02:00)

Hi,

Thank you for contacting us.

This seems to be the expected behavior. The email is sent to the administrator according to the default language of the WordPress dashboard.

If your site's default language is English, then the email sent to the admin will be in English. The email to the customer, however, is sent in the language in which the purchase is made.

Is your site's default language different from English?

Thank you.

October 24, 2017 at 6:37 pm #1410499

davidS-138

My site's default language is English. Is there any way for the administrator to select which language the email is in? Or is the only to change the default language?

October 24, 2017 at 7:53 pm #1410567

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-02:00)

No. You can choose the default language and administration panel (in which the email will be sent).

But after choosing to change the admin panel, besides the email, the dashboard itself will be in another language.

If you want to do this, click on the Users > Your Profile. On the "Language", select the desired language. Click on the "Update Profile" button to save the changes. Note that this will also change the language of the dashboard.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

October 24, 2017 at 9:05 pm #1410636

davidS-138

Is there a reason I don't see the dropdown? I looked at the documentation and the dropdown should be under "Toolbar", but I don't see it. Screenshot attached.

Also, it looks like each user can select their own language for the admin. Does this mean emails will be sent to the user in that language? Or is it the same email language for all users?

October 25, 2017 at 11:33 am #1411207

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-02:00)

The list of languages is only displayed when you have the translations of the available languages. To download other translations, please follow the steps below:

- Click on the Dashboard > Updates
- Scroll down and look for "Translations"
- Click on the "Update Translations" button

If the translations of the plugins are already downloaded, then this option will not be displayed. You can follow the next steps.

- Click on the Settings > General
- On the "Site Language" option, select the secondary language of your site
- Click on the "Save Changes" button

Note that after following these steps, the language selected in this option will still be the default language, configured in WPML. These steps will download translations of your website backend.

On its second question, each user can select their own language, but WooCommerce emails will be sent in the language defined by the site's main administrator.

Thank you.