Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Christopher Amirian 1 month ago.

Assigned support staff: Christopher Amirian.

Author Posts
January 12, 2021 at 12:02 am #7820453

stephenG-6

Tell us what you are trying to do?
Translate the form in the page contact
hidden link

hidden link

I translated the form using WPMl as you can see in the images of the link below

hidden link
hidden link

I also used string translation and the translated string is there...but not showing on the page

hidden link

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
hidden link

January 12, 2021 at 2:16 pm #7826181

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Would you please make sure that you scan the theme using this method:

https://wpml.org/documentation/getting-started-guide/string-translation/finding-strings-that-dont-appear-on-the-string-translation-page/#scanning-the-theme-and-plugins

Then please follow the steps below:

https://wpml.org/documentation/getting-started-guide/string-translation/finding-strings-that-dont-appear-on-the-string-translation-page/#strings-arent-selected-for-translation

Finally, Would you please kindly follow the steps below to provide the debug information?

- Go to "WordPress Dashboard > WPML > Support > Debug Information (Link)".
- Copy the Debug Information from there.
- Find the "Additional Data" section below this chat. (Check the screenshot below)
- Click on the "Debug Info" item to expand it.
- Paste the debug information into the text area.
- Click the "Send Debug Info" button.

Screenshot:
https://wpml.org/wp-content/uploads/tmp/debug_info_20.png

January 12, 2021 at 3:46 pm #7827189

stephenG-6

Christopher,

Thank you for your help.

Before I placed the ticket, I followed the instructions give on the first link of your answer
https://wpml.org/documentation/getting-started-guide/string-translation/finding-strings-that-dont-appear-on-the-string-translation-page/#scanning-the-theme-and-plugins

I found the string and translated it as shown on the link below
hidden link

But it does not show as translated on the page

hidden link

Not sure why.

The same is happening with the Copywrite area in the footer, as the image uploaded indicated, and I translated that in the string translation too.

The debug info was pasted.

I can give access to the website if it helps process....

Thanks for the help.

I need to translate this website into 5 other languages so we need to solve this to move forward.

I really appreciate the great support by WPML.

January 13, 2021 at 8:26 am #7831911

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you for the information. I checked the details of the debug info and the setup seems to be ok. I have three suggestions that I'd appreciate if you can follow up:

Update the Avada Theme

You are using version 7.1 of the Avada theme. I'd appreciate it if you could update it to version 7.2.1 as it has some improvements regarding the WPML compatibility.

Check the Parent Theme

- Go to "Appearance > Themes" and change the theme from the Child-Theme to the Parent-Theme and test if it fixes the issue.

Check for Possible Plugin Conflict

- Create a backup of your website. You can use backup tools from WordPress: https://wordpress.org/plugins/tags/backup/
- Go to "WordPress Dashboard > Plugins" and deactivate all plugins except WPML and its add-ons.
- Check if you can still recreate the issue.
- If not, re-activate your plugins one by one and check the issue each time to find out the plugin that causes the problem.

If you still experience the issue after following the steps above, I'd appreciate it if you could give me the URL/User/Pass of your WordPress dashboard after you make sure that you have a backup of your website, just in case something happens, you will have a point of restore.

The next reply will be private for sharing the login information.

January 13, 2021 at 7:58 pm #7838719

stephenG-6

I hope the access information is not public!

We tried all the 3 recommendations the same issue
Below you can see the form translated

hidden link

But it does not show.

Please give me your IP to white list you.

January 18, 2021 at 5:53 pm #7872307

stephenG-6

Hi Christopher,

We still need assistance. I am waiting for the client to update Avada to see if that fixes the problem.

But the ticket is not closed or resolved. Sorry for the waiting I am waiting too..

Thanks for the patience and help. Can I have your IP to have that whitelisted?

January 19, 2021 at 12:32 pm #7877775

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

It seems that you missed my last message, Would you please expand the private message right above your last message so you can see both my IP address and also the clean installation of Avada with the latest version so you can check and test to replicate the issue there?

Thank you.

January 22, 2021 at 12:17 am #7901671

stephenG-6

Christopher,

Sorry I missed the message. Your IP was whitelisted. You can access the site with the credentials given.

We are on a waiting pattern since we had issues with AVADA, AVADA IS given support since the Theme update is not working...as soon as we pass that hurdle we can continue to work on the issues.

Pleas edo not clos ethe ticket until I get back to you, with appreciation ...

January 24, 2021 at 9:08 am #7914775

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you for getting back to us. Sure thing.

Just to let you know it will be a great way to test the contact info problem by trying to see if it is possible to replicate the issue that you are experiencing in the clean installation.

That is why I created a clean WordPress, Avada (latest version), and WPML installation.

You can log into that installation using the link below (auto-login):

hidden link

Would you please kindly try to add the contact info and try to translate it to see if you are encountering the same issue there or not?

That is a very important step. If it is possible to replicate the issue in a clean install it will show that it is a compatibility issue and I will need to report this to the compatibility team.

If not, then it happens only on your installation and we will need to check your installation for the possible causes of the issue.

As this will decide the next course of action, I'd appreciate it if you could check and see if you can replicate the issue on a clean installation or not.

The topic ‘[Closed] Translating the Avada form in the contact page’ is closed to new replies.