This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Translate CharityFoundation theme setting which sets a specific page as the footer via theme customization.

Solution:

Copy this code snippet to WPML > Settings > Custom XML Configuration tab.

<wpml-config>
  <admin-texts>
    <key name="nd_options_customizer_footer_5_content_page"/>
  </admin-texts>
</wpml-config>

Relevant Documentation:

https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

This topic contains 8 replies, has 2 voices.

Last updated by frankB-34 5 months, 1 week ago.

Assigned support staff: Dennis.

Author Posts
May 13, 2019 at 1:18 am #3794101

frankB-34

The Theme CharityFoundation allows me to set a specific page as the footer through WP customization. This is helpful because it gives me much more control over what the footer contains. However, I have not been able to figure out how to display the correct language in the footer given the page a viewer is on. I have translated the page used as the footer (hidden link) and have also tried using string translation. But I'm never able to match pages in one language with the correct footer.

What am I missing?

May 13, 2019 at 4:49 am #3795169

Dennis

Hi,

Welcome to WPML Support forum.

It could be that these strings are stored in the admin texts. Please go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the the string. If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

Please check our documentation about this:
https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

Kind regards,
Dennis

May 13, 2019 at 2:41 pm #3799505

frankB-34

Thank you, Dennis. I believe I found the correct string (attached), but after checking it and clicking on "Apply" several times, the string still doesn't show up anywhere on the string translations page. Is there something wrong with my installation?

May 14, 2019 at 2:33 am #3802745

Dennis

Hi,

Thank you for your reply and providing us with the debug information.

Could you please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.
Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Try to add the string again through WPML > String Translation > Translate texts in admin screens ». Does the string appears to string translation table now?

Please let me know how it goes.

Kind regards,
Dennis

May 14, 2019 at 5:58 am #3803841

frankB-34

I was able to make the changes you suggested, and I was even able to get a success notice when trying to add the advanced string to the string translation (see photo). However, I cannot find the sting anywhere in the string translation screen. I'm afraid I'm still not sure what to do, though it seems we're getting closer!

May 14, 2019 at 8:30 am #3804719

Dennis

Hi,

Thank you for your reply.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

May 15, 2019 at 1:30 am #3811275

Dennis

Hi,

Thank you for providing us with the access details.

However, when I tried to access your site the access credentials does not seem to work on my end. Could you please check? Are you able to get in using the access credentials provided?

Thank you.

Kind regards,
Dennis

May 15, 2019 at 2:53 am #3811729

Dennis

Hi,

Thank you for your reply.

Could you please try to copy this code snippet to WPML > Settings > Custom XML Configuration tab.

<wpml-config>
  <admin-texts>
    <key name="nd_options_customizer_footer_5_content_page"/>
  </admin-texts>
</wpml-config>

Then go to WPML > String Translation and translate the strings completely and save.

Does it help?

Kind regards,
Dennis

May 15, 2019 at 3:43 am #3811979

frankB-34

My issue is resolved now. Thank you!