Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by Bigul 6 months ago.

Assigned support staff: Bigul.

Author Posts
February 10, 2020 at 12:19 pm #5461675
andresG-29

When I go to in back end in WordPress to the pages section and I press the + button to translate my front page from Norwegian to English first thing that happens is that it loads only a few elements, but not all the front page.

Then, if I proceed and do the translation manually, once I've finished I go to the page and on the English link all goes to a blank

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/duplication-for-most-of-his-images-in-the-default-language/

February 10, 2020 at 4:57 pm #5463585

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I have reproduced the Themify Builder translation issue on the sandbox site and escalated the ticket to our compatibility team for further debugging. We will get back to you as early as possible. Please wait.

Please check the following URL for more details.

Log in URL:- hidden link

Test Page Norweigan:- hidden link

Translated Page to English:- hidden link

--
Thanks!

Bigul

February 11, 2020 at 5:46 am #5466257

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We have a request. Most probably the Themify Builder translation issue happening because of the older version of the Themify Ultra theme. Because the latest version of the theme has compatibility fix for WPML. So please upgrade to the latest version of the theme after a full site backup and make sure the issue is existing or not. You can try the following steps for upgrading the theme and translating the Page to a secondary language(English).

1) Visit Themify Ultra>>Themify Settings>>Update tab
2) Click on *Update* button
3) Enter your Themify user name and password to validate the subscription
4) Visit WPML>>Settings after the theme update to refresh the WPML configurations
5) Open the Homepage for edit in Norweigan - hidden link
6) Make a minor change in the Themify Builder settings of the page to refresh the translation settings
7) Update the Page
8) Click on *pencil* icon of the language widget of Norweigan Homepage to translate the page of English
9) Make sure the Themify Builder elements text of Homepage is showing for translation in WPML Classic Editor and translate it to English

Please check the attached images for more details and let me know your feedback.

Please note, I have shared the Media Duplication issue with our second-tier team for the expert opinion and waiting for their feedback now.

--
Thanks!

Bigul

February 11, 2020 at 12:35 pm #5469349

andresG-29

4) Visit WPML>>Settings after the theme update to refresh the WPML configurations
How do I REFRESH THE WPML CONFIGURATIONS?

February 11, 2020 at 1:05 pm #5469553

andresG-29

Hello There,

For the first time when I have translated the page in English, it seems that is working the texts...the problem is that the carrousel with all the images on the English version, and the blog will not show.
Please help me with that. Is it possible to chat?

February 11, 2020 at 1:06 pm #5469555

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please just visit the WPML>>Settings page after completing the theme upgrade. It will refresh the settings related to your theme configuration automatically. Sorry for the confusion.

--
Thanks!

Bigul

February 11, 2020 at 1:08 pm #5469563

andresG-29

Also all the images inside of the projects section have being displaced. Before they were centered...now they are towards the left...
Oh god!
hidden link
note: it happens with every project

February 11, 2020 at 1:28 pm #5469693

andresG-29

Also it happens the same mess in the Spanish version of it....
I can translate, but the edition gets lost on the way...

February 11, 2020 at 1:45 pm #5469747

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please note, there is no option to chat from the normal ticket. I am checking about the Blog element issue with my compatibility team now.

Please share more about the following for a better understanding of the issue. Because I am not able to reproduce it exactly. It will be great if you can share a couple of screenshots for a better understanding.

the problem is that the carrousel with all the images on the English version

May you are having the design issue in the following page because of the style settings improvement in the latest version of the theme. So to make sure it, please deactivate WPML for the moment and check is there any difference in the result.

hidden link

--
Thanks!

Bigul

February 11, 2020 at 5:22 pm #5471601

andresG-29

Helo Bigul,

You have access to my backend, so you can see what is going on. Anyhow, the carousel images do not show in the front page. I attach you the images in the Norwegian version and the English version. It should be like in the Norwegian version.
Please help me with that.

About your suggestions deactivate the WPML plugin in order to check the problem on the "projects page" it does not make sense, since when the WPML is deactivated the language option disappears, and there is no problem to solve. Why the new version changes the design parameters and the styling on the pages? Is this really happening?

thanks for your support anyhow,

Andrés

February 11, 2020 at 5:26 pm #5471661

andresG-29

Hello again Bigul,

When I deactivate the WMPL plugins the result is the same for
hidden link
Also for all the projects. It seems that by the upgrade something has happened for worst, at least for me.
What can I do about that?
Andres

February 12, 2020 at 7:35 am #5474497

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Andrés,

Thank you for the updates. But I have one more doubt about carousel images of the homepage. How you are handling it? Because I am not able to find it in Themify Builder settings of the homepage. So please share more details about carousel image settings.

The Gallery images of Project Pages were showing the wrong alignment because of a change in the Themify Builder settings. Now theme offers row settings for the Gallery. The row width of the Gallery was set as *Fullwidth* and it will work as expected if we choose the *Default* option for it. Please check the following pages to see the correct result.

hidden link

hidden link

hidden link

The Blog element of the Homepage was not showing the Posts in the English and Spanish Homepages, because now there are no translate posts. It is showing the expected result for now after I choose *Translatable - use translation if available or fallback to default language* option in WPML>>Settings>>Post Types Translation instead of *Translatable - only show translated items*. This option will allow us to list the default language posts in the secondary language without Post Duplication.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

February 12, 2020 at 10:34 am #5476043

andresG-29

HELLO BIGUL,

What I have done to do a Slider( I called it carrousel before, but it is a slider) in the front page in Spanish and English versions is to redo it and to upload the images again in both cases, since they were not showing in the gallery. Now it seems that is solved.

Also I have been going project to project and setting the rows as default as you told me and that works now. Super!
Did you change the settings on the blog? Now it seems that they show in Spanish and English version, which is what I wanted. Thank you very much for that.
Istill have some issues, but I will start with the full translations and comeback to you in this thread if that is ok with you. Is it?
we talk soon

thanks

Andres

February 12, 2020 at 12:27 pm #5476865

andresG-29

Hello Bigul,

1st issue:
As I am translating I have found a problem when I try to do the Finish version of the from page.( See images below) When I click on edit the finish translation I get redirected to a page that says:
NO TRANSLATION LANGUAGES CONFIGURED FOR THIS USER (see image attached)
And I can not continue.
This issue has not happened to me when I did the translation into English, Swedish or Spanish...can you please help me out to configure it right? I would like to have my front page in Finish also.

2nd issue:When I do translate the Kontakt form into all the languages it is fine, but when I go to the contact form in each language there is some text in the comment section. Please, see images 3 and 4. The image 5 is how it is supposed to be...
Please help me fix that, since it is the place where clients contact me...

Please tell me something about these 2 issues asap.

Andres

February 12, 2020 at 1:11 pm #5477303

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Andres,

I have made changes in the translation preference of Blog Posts. Now it will show in secondary languages without translation or post duplication. It is showing the expected result for now after I choose *Translatable - use translation if available or fallback to default language* option in WPML>>Settings>>Post Types Translation instead of *Translatable - only show translated items*. Please check the following links for more details.

https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

https://wpml.org/wp-content/uploads/2020/02/5474497-2020_02_12_1205.png

Now I have set yourself has a Translation Manager. So you can translate to all the languages. Please check the attached image or WPML>>Translation Management>>Translation Roles for more details. You can see all your translation status in WPML>>Translations now.

I will check about the Contact form and get back to you soon. Please wait.

--
Thanks!

Bigul

The topic ‘[Closed] Translating the page created using Themify Builder elements’ is closed to new replies.