This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 16 replies, has 2 voices.

Last updated by jesseM-9 1 month, 1 week ago.

Assigned support staff: Marcel.

Author Posts
August 27, 2019 at 1:10 pm #4467009

jesseM-9

I am trying to: Translate all important pages on triggre.com. I have used the Advanced Translation Editor and all pages, media and forms are finished. When I checked the Dutch version (only for myself), something went wrong. It shows the content from our English pages translated to Dutch, but not in the right theme. Note: we use two home pages in ENG. We have triggre.com (which is just a page) and triggre.com/en/ (which is the Frontpage in WP). We think that something went wrong with either our theme settings or our two home pages that ruin the page connections. Please let me know how to fix this!

Link to a page where the issue can be seen: See screenshots.

I expected to see: The exact same website layout and theme, but with our Dutch translated text instead of English.

Instead, I got: The Dutch content but in the wrong theme with the wrong layout.

August 27, 2019 at 3:41 pm #4468227

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jesse,

Thank you for contacting WPML Support.

I tried to open all URLs and I can't detect this problem. All pages from the screens redirect for me to the main page.

As you write it happens only for you could you please try to clear your Cache or try to switch your browser? If this doesn't help can you please provide me with site access and a user with the identical settings?

Best Marcel

August 28, 2019 at 7:35 am #4471601

jesseM-9

Hi Marcel,

Thanks for getting back to us. My bad, I explained it wrongly. I have not published the Dutch language to every user of the website yet, because I wanted to check it how it looked first. So in my settings I chose 'display hidden languages' so I could check what it looked like. That's when I saw the issue. We use the Enfold theme but the people who set up our WordPress website have created a Triggre child theme from Enfold.

How can I best grant you access to our WP?

Thank you.

August 28, 2019 at 7:59 am #4471665

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jesse,

thanks for the info.

I will activate a private message to grant access:

I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add the Links to the […] Edit Screen, the Page/Post where you insert the […] and the corresponding Front End Page/Screen

Best Marcel

August 29, 2019 at 12:21 pm #4480813

jesseM-9

Hello Marcel,

Thank you for your reply. We're working on a back-up and granting you access to the WP-admin and FTP. Do you have an email adress that I can use to create a WP-admin user account for you?

Thank you.

August 30, 2019 at 6:34 am #4484931

jesseM-9

Can I sent a private message?

August 30, 2019 at 7:20 am #4485025

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Sure, I activated the field again, if you need to add something additional. I have already access to your backend, as I got a PW reset link on my mail. I will check this issue now.

Best Marcel

September 2, 2019 at 6:34 am #4494803

jesseM-9

Hi Marcel,

Thank you so much! I have followed your instructions and the migration has started. I will let you know once it's finished.

September 2, 2019 at 6:50 am #4494841

jesseM-9

The migration is finished! Is there anything else I can do for you?

September 2, 2019 at 1:18 pm #4497303

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jesse,

The problem was that the Child Theme settings were different for each language. The easiest way to solve it is the following way:

#1 Open the Enfold Theme settings in English and use the "Export" function under "Import/Export".
#2 Switch on the top bar to Dutch and import the config file you exported before.

Working Example (with Logo $ Styling): hidden link

Best Marcel

September 3, 2019 at 8:03 am #4501817

jesseM-9

Hi Marcel,

Thank you for figuring this out.

Can you elaborate on that? Where in the wp-admin backend can I find these settings? If I want to open theme settings, all I can find are the Triggre Child (EN) theme options and settings and not the Enfold one.

And what config file exactly do you mean? The back-up?

Thanks.

September 3, 2019 at 8:54 am #4502311

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jesse,

Sure. I added you a step-by-step guide:

#1 Please open on your WP Backend "TRIGGLE Child (EN)" (URL endpoint is wp-admin/admin.php?page=avia)
#2 Scroll down to Import/Export and click on "Export Theme Settings File"
#3 Click on the Top Bar of WordPress Backend on the Flag and switch to "Dutch"
#4 Go again to "Import/Export and choose now "Upload Theme Settings File"

Enfold will generate a .txt File with all settings which you can import.

Best Marcel

September 4, 2019 at 8:16 am #4509053

jesseM-9

Hi Marcel,

Thank you - I've followed your steps and uploaded the file. You're talking to Julia, another administrator of Triggre. I've checked the website in Dutch again (only visible for my account, I don't want users to see this yet) but it doesn't look like it should. Am I missing someting?

Thanks.

Julia

September 4, 2019 at 1:16 pm #4511319

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Julia,

Could you please try it again? Now it looks good:

hidden link
hidden link

I finished now an open translation and re-assigned "Home" to Dutch in the Enfold settings.

Best Marcel

September 5, 2019 at 7:43 am #4516321
jesseM-9

Hi Marcel,

Thank you so much! It actually works now and looks very good. I'm happy! Although you're not done with me yet, haha. I have a few questions left:

1. We would like to have the 'triggre.com' link to exist without being a destination, but the link should automatically refer to either triggre.com/en/ or triggre.com/nl/. How do I make this work in the settings at 'Language URL format' in WPML?

2. If you're on a Dutch page, is it possible to have a Dutch top and footer menu as well? And if so, where can I change that?

3. If I'd like to only change the pictures, forms or ARPrice templates in the Dutch version, is there an option to do that? For example, on the Tour page the images should have Dutch text on the Dutch page or on the Pricing page, the pricing template should be in Dutch in the Dutch version.

4. On the Home page and Solutions page there is a block with 'Customer success'. On the Dutch versions, the images dissappear. Do you know why?

Thanks again for the great support!

Julia

New threads created by Marcel and linked to this one are listed below:

https://wpml.org/forums/topic/page-translation-with-enfold-theme/