Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by shaneB-8 5 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 6, 2021 at 2:01 pm #8705529

shaneB-8

I am trying to:

Translate an existing product person label. They appear just fine in the translation management screen, but unfortunately they after adding the translation it is never saved.

As well I tried the following solutions but none of them seemed to work
+ https://wpml.org/forums/topic/woocommerce-bookings-person-type-not-translated/
+ https://wpml.org/documentation/woocommerce-extensions-compatibility/translating-woocommerce-bookings-woocommerce-multilingual/

Link to a page where the issue can be seen:

+ hidden link (original that works)
+ hidden link (translation not working)

I expected to see:

The translation of the labels and it not showing the product as free 😛

Instead, I got:

The labels not translated and appear blank each time that I translate them. Then the product also appears as free b/c I have set pricing based on the person. My guess is that it isn't copying something properly.

May 6, 2021 at 2:03 pm #8705543

shaneB-8

Also, I should note that I noticed there is no checkbox under each field that indicates that the translation is completed. But perhaps this is just for products.

May 7, 2021 at 1:15 am #8709451

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting our support service. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 7, 2021 at 1:43 am #8709463

shaneB-8

Hey there,

I don't mind giving you access but could I ask if there aren't suggestion you might have first before we go through setting up an account?

May 7, 2021 at 5:47 pm #8716157

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. For this particular case, I am not able to suggest something as I am not familiar with the plugin into question or the theme used, this way I can't determine how the fields are being set if it is being used as custom fields and the reason why this custom field is not copied to the secondary languages. This is why a detailed look at your WordPress Dashboard is needed in order to review your settings and understand the cause of this issue.

I am marking the next reply as private again, so, you can share some access with us. It will help me to proceeding in the issue investigation. Thank you for your collaboration and understanding, have a nice day.

May 11, 2021 at 12:47 pm #8740069

shaneB-8

Just wondering if you had a chance to check this out. I'd love to get this resolved if we can. Thanks so much for your help and stay safe out there.

May 12, 2021 at 2:04 am #8744167

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried the troubleshooting steps below and it seems to have fixed the issue:

1 - I ran the WPML troubleshooting from WordPress Dashboard > WPML > Support > Troubleshooting and performed these steps:

- Variations and Type the persone post types synchronization.
- Cleared WPML cache.
- Set language information.

2 - From WordPress Dashboard > WooCommerce > WooCommerce Multingual > Status > Troubleshooting I also ran some steps to synchronize attributes.

3 - From WordPress Dashboard > WPML > WPML > Settings > Custom Fields Translation I set the 'wc_booking_resource_label' as 'copy'

4 - I deleted the english translation of the problematic product and re-added it.

You can confirm the fix at: hidden link

Hope it helps to fix any related issue. Have a nice day.

May 12, 2021 at 4:43 pm #8750971

shaneB-8

Thanks so much! I had tried the booking resource also but didn't see that working so probably set it back.

I think that I completely forgot to test out the synchronization of attributes in teh troubleshooting. Thanks for the reminder.

Have a great day I appreciate the fast help!

May 12, 2021 at 4:43 pm #8750973

shaneB-8

My issue is resolved now. Thank you!