This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
June 6, 2019 at 7:04 am #3966193

Dmitry

I am trying to: translate products to two languages - English & French.

Link to a page where the issue can be seen: hidden link

I expected to see: translated pages with product

Instead, I got: still not translated pages and when I try to translate then I can see 100% complete translation in Advanced Translation Editor.

Please help to finish translation.

June 6, 2019 at 1:37 pm #3969547

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting options pointed out in the attached image.
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix any error that might appear.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all the products.
- Update one of the translations of one of the products.

Could you tell me if the issue persists?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos