This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 10 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
July 15, 2019 at 5:46 pm #4213867


I am trying to: view translated content

Link to a page where the issue can be seen:
hidden link (Correct design and original content)
hidden link (Incorrect design, incorrect language displayed.)

I expected to see: Design and correct language displayed

Instead, I got: Some original language content, without correct form & design

EDITED to add - That the header and footer were created in the elementor library, but same issue.

July 15, 2019 at 7:10 pm #4214305

Andreas W.

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)


Thank you for contacting the WPML Support.

The page hidden link ends in an 404 error , which means that this page seems not to exist.

Can you please verifz the following:

1) Go to WPML -> Languages -> Site URL Structure. Verify if Language in directory us set and if there are any errors displazed. Also make sure to enable one of the WPML language switchers.

2) Go to pages and verify of the homepage is translated.

3) If so, go to settings permalinks and simply click the save option.

4) I see you are displaying posts on your homepage. In order for posts to show up in a different language those posts will need to be translated.

5) Elementor Libraries will need to be translated seperately. More information here:

I hope this answered your questions. Let me know if you need further assistance.

Kind regards

The topic ‘[Closed] Translation and design (elementor) is not appearing on translated pages’ is closed to new replies.