Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Diego Pereira 3 years ago.

Assigned support staff: Diego Pereira.

Author Posts
July 5, 2018 at 8:22 am #2466115

benjaminL-25

Tell us what you are trying to do?
Trying to translate the authors bio on the blog. We have WPML Starter account. I was wondering if string translation could help us on this. The idea is really to translate the part in user description, as shown in screenshots. What is the solution and steps to follow please?
Is there any documentation that you are following?
No
Is there a similar example that we can see?

What is the link to your site?

Capture d’écran 2018-07-05 à 10.17.08.png
Capture d’écran 2018-07-05 à 10.16.14.png
July 6, 2018 at 2:46 pm #2471166

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @benjaminl-25, welcome to the WPML support Forum!

Yes, you need the String Translator extension to translate the author infos. You can follow the steps below:
- Go to WPML -> String Translation
- Scroll down to the bottom and get the section "More options"
- Edit the "Translating users of types". Select the user roles you want to translate and click on apply.
- Now the strings will be displayed on the String Translator table.

There is a similar ticket here: https://wpml.org/forums/topic/translating-authors-bio/

If you need more help just let me know.

All the best,
Diego

July 9, 2018 at 2:29 pm #2476689

benjaminL-25

Hello Diego, thank you for your help. I have tested string translation on our company's blog. You can see the screenshot where I have translated the English version to French. But when I go to the French version of the blog I can still see the English bio, when I delete the info in the user field in WordPress - the info disappears. Am I missing something?

Capture d’écran 2018-07-09 à 16.24.10.png
July 9, 2018 at 7:39 pm #2477684

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

This is probably caused by a cache issue or by the way the theme code get and display the bio information. Please clear all caches (server, WordPress and browser) and test again.

If the issue persist, please send us access to your WordPress dashboard (website URL, login and password) I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT We always recommend to backup a working copy of site files and database before.

Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” or "All-in-one WP Migration" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please let me know if this is ok for you.

Regards,
Diego

July 10, 2018 at 12:20 pm #2480987

benjaminL-25

Hello, can I please have a secure form link again, so I can give you confidential information? It's urgent. Thank you.

July 10, 2018 at 12:31 pm #2481096

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, i enabled the private field now.

Please take a look at this link about privacy and security: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

If you can not send us the credentials, it is also possible to generate a copy of your website using the duplicator plugin: https://wpml.org/faq/provide-supporters-copy-site/

Regards,
Diego

July 10, 2018 at 6:48 pm #2483640

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

The issue was related to the code of your theme to display the description of the Author. It need to follow the WordPress standards:https://developer.wordpress.org/reference/functions/get_the_author_meta/

On the single.php file of your theme, i changed the line 131:

<?php echo get_userdata($author_id)->description; ?>

To this:

<?php $authorDesc = the_author_meta('description'); echo $authorDesc; ?>

Now the translation is displayed on each language. You can check it here:
- hidden link
- hidden link

If you need more help just let me know.

Regards,
Diego

s6.PNG
July 11, 2018 at 7:17 am #2485278

benjaminL-25

Thank you Diego, I actually opted for an upgrade from basic WPML plug to multilingual CMS where i could download string translation for one of my clients. Now the little issue is that I was not able to find a string translation additional plug in on WordPress plug in side and I needed to upload it manually through WordPress. I can still not see string translation under WPML plug in, thought it is uploaded and activated. I think I need to activate a key, but I cannot find any information about it. How can I proceed?

Capture d’écran 2018-07-11 à 09.16.19.png
Capture d’écran 2018-07-11 à 09.16.06.png
July 11, 2018 at 11:36 am #2486465

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, I'm glad to hear that the issue is solved ?

As the original issue is resolved may I kindly ask you please to open a new ticket for your additional question?

This will help other users with similar problems to find solutions when searching the forum.

Cheers,
Diego