This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.11 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 2 voices.

Last updated by Raja Mohammed 3 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
June 13, 2019 at 6:29 pm #4016271

javierO-6

I am trying to:
I tried to send an item in the translation basket but im getting this:

Sending batch MBCP|WPML|en|4 to translation.
Rollback jobs...

Batch rolled back

100%

After sending the item(Contact Page) for translation, the item is listing in the translation basket. However, if I check the Translations Jobs I can see the item on that section. If that item is in the translation jobs section, why in the translation basket tab, there is a number 1 and the tab is blinking.

When I go to the Translation queue I can see the job id but whenever I want to translate that item (Contact page), it opens the standard translation editor instead of the Advanced translation editor. I want to use the machine translation option. Before I started sending items for translation, I use the WPML's Advanced Translation Editor.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

June 14, 2019 at 3:09 am #4017975

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue,

Please provide me a few information regarding the issue.
1) Try to use Google Chrome built-in console to see if there are any errors displayed when you try to it. You can access the console from your Settings > Tools > JavaScript Console

Here you have more information about this:
hidden link
hidden link

2) Does it happen for a particular page?

3) In a test environment or after securing a backup of your site, Disable all the non-wpml plugins check if the error still persists, If not enable the plugin one by one to figure out the conflicting plugin

Please let me know the results

Kind regards
Raja

June 14, 2019 at 5:10 pm #4023173

javierO-6

Hello,
1) Try to use Google Chrome built-in console to see if there are any errors displayed when you try to it. You can access the console from your Settings > Tools > JavaScript Console

Current Site - hidden link
This is what I’m getting on the Javascript Console (see attachment)

2) Does it happen for a particular page?
Current Site - hidden link
I checked 3 pages and Im getting the same problem.
Rollback jobs...
Batch rolled back
100%

3) In a test environment or after securing a backup of your site, Disable all the non-wpml plugins check if the error still persists, If not enable the plugin one by one to figure out the conflicting plugin
Dev environment - hidden link
We are using this dev link and now the pages we sent to the translate basket on the production environment have the following warnings (see attachment)

These pages, Contact Page, About Us Page, Accomplishments Page, still have the Standard Translation Editor. How can I change the Standard Editor? I would like to use the Advanced Editor for all pages.
If I add new content to the translation basket and then send that item for translation, the Advanced Editor opens without any issues.
On the Pages section, Im getting those warnings but The advanced Editor opens without any issues.

June 17, 2019 at 4:12 am #4032015

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for sharing the additional information, Since I can see from your console error that the Ajax request is failing, please share with us the WordPress logs and the server error logs.

It seems you have already enabled the WordPress logs, if not, to enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:


define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

Please also request your hosting provider about the server error logs,

If you can paste your debug.log and server error logs to a separate pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

I have enabled private reply for you to securely share the requested details.

Kind regards
Raja

June 17, 2019 at 3:41 pm #4036777

javierO-6

Hello,

Please check the following information

Server error log: https://pastebin.com/VtwkgwvX

Debug log: https://pastebin.com/6zmxzLUb

Thank you

June 18, 2019 at 7:00 am #4040853

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the information,

- Please update WPML plugins to the latest version check if the issue still persists,

- Please increase the PHP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:


/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

if the above didn't help please share with us a snapshot (copy) of your site, You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/ I have enabled private fields to securely share the details.

Kind regards
Raja

June 19, 2019 at 5:11 am #4047971

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have checked your site in detail, You site is missing "Multibyte String extension" in your PHP installation which is the minimum requirement for WPML to function properly.

If you can handle this by yourself please follow the instruction to install the missing PHP extension
hidden link

If this is something out of your reach please request your hosting provider to enable the Multibyte String extension for your site.

I hope this solves your issue.

Kind regards
Raja

June 24, 2019 at 10:02 pm #4079983

javierO-6

Hello,

We noticed that the following warnings still show up even though we enabled the Multibyte String extension. Also, we checked that custom fields (Post - post type) work fine with the Machine Translation but custom fields (Forms - Options page) doesn't work with the advanced translation editor. Is there a way to translate custom fields (Forms - Options page) with the machine translation option because so far we haven't found an option to do that? Could the menus be translated with the Advanced translation editor? it only gives us the translations option on the string translation option.

Warning: mysqli_real_escape_string(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 1172
Warning: mysqli_free_result(): Couldn't fetch mysqli_result in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 1550
Warning: mysqli_more_results(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 1559
Warning: mysqli_query(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 2007
Warning: mysqli_errno(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 1902
Warning: mysqli_error(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 1929
Warning: mysqli_real_escape_string(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 1172
Warning: mysqli_query(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 2007
Warning: mysqli_errno(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 1902
Warning: mysqli_error(): Couldn't fetch mysqli in /home/mbcommunitypower/public_html/wp-includes/wp-db.php on line 1929

Thank you,

June 25, 2019 at 2:49 pm #4085641

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI,

This seems like a different issue, the warning message doesn't give much information about the error.

Can you please confirm whether the issue related to translation basket is resolved? if so I would request you to create a new ticket for other issues.

For support rules, we are able to handle only one issue at the time. This helps us to bring you a better service and also help other users to find all the information here exposed.

Kind regards
Raja