This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I can no longer translate V1 Elements with WPML's Translation Editor after the update to WPML 4.2.7.1

Solution: Downgrade WordPress 5.1.1. and use the following versions: WPML CMS Nav 1.5.0 WPML Media 2.5.1 WPML Multilingual CMS 4.2.5 WPML String Translation 2.10.3 WPML Translation Management 2.8.4

This topic contains 10 replies, has 2 voices.

Last updated by jeroenV-43 3 weeks, 4 days ago.

Assigned support staff: Alejandro.

Author Posts
July 5, 2019 at 11:50 am #4151025

jeroenV-43

Hello, again I have some issues. We work in Cornerstone.
This issue is on the HOME page:
First of all I have canceled the translations (FR and ENG).
So I could start over again from scratch. Then I click the edit-tool (pencil), then I translate each text block to English. While translating the text blocks we discovered that a blocks is MISSING. For example the home page: here the text block (Dutch: "U kiest voor Cars&Cargo omdat…") is missing completely on the translation page. It is available in Cornerstone so I do not understand why this block is missing. please you can have a look because you are still an ADMIN on the site (see above).

July 5, 2019 at 4:25 pm #4152901

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm escalating this to one of our developers. I'll let you know as soon as i have more information.

Regards.

July 10, 2019 at 7:51 am #4177009

jeroenV-43

Hello, I have not heard from you since Friday. My client is waiting for the translation. When I started this Support-chat 1 or 2 fields were missing in the translation. Now ALL the fields are missing in translations. So it is becoming urgent now to solve it.

July 19, 2019 at 5:04 pm #4247593

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

Our developers told us the problem is indeed because of a bug. the only workaround we have right now is to go back to both WPML version (try 4.2.0 and if it doesn't work 4.1.4).

The solution for this bug will have to be implemented after talking with themeco and with their help, probably.

We're deeply sorry for this problem and we are doing our best to fix it as soon as possible.

August 20, 2019 at 6:58 am #4420937

jeroenV-43

hello,

Is there still no solution? My client is not waiting for more than 6 weeks for a translation for his website. This taks much too long.

August 20, 2019 at 7:04 am #4420963

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,
I asked updates to our developers about this because this problem requires a communication with the theme's author and that's probably why it's taking so long to be fixed.

I'll let you know once i have an answer from our compatibility team.

Regards.

August 20, 2019 at 11:20 am #4423141

jeroenV-43

Alejandro,

I don't have the WMPL version 4.2.0 or 4.1.4 anymore. Can you send me the versions?

Regards,

Jeroen

August 20, 2019 at 1:28 pm #4423931

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, you can find them in here: https://wpml.org/account/downloads/

Click on the blu circled "i" icon so you access the archive of the plugins (it should take you to: https://wpml.org/download/wpml-multilingual-cms/?section=changelog ) and download the version 4.1.4 or 4.2.0 and then i recommend you also download the version from the same date of the add-on plugins (String Translation, Translation Management) because otherwise you could get errors.

Regards.

August 23, 2019 at 8:53 am #4445493

jeroenV-43

Hello Alejandro,

I have installed 4.2.o and also the media, string and management plugins from that date (august 6 2019) but still have the problem that I cannot see the cornerstone translation fields.

August 23, 2019 at 9:14 am #4445633

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Try to edit the title of the page and then save it, check if that helps, because sometimes. You just need to update the page so the translation gets updated as well.

If possible also revert to a previous version of the page l, from before the wpml update through a WordPress revision.

August 23, 2019 at 9:46 am #4445741

jeroenV-43

My issue is resolved now. Thank you!