Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by martineG-3 4 years, 6 months ago.

Assigned support staff: Itamar.

Author Posts
June 16, 2017 at 10:33 am #1299747

martineG-3

I am trying to: translate button link of the projects by using WPML.
However you can't change the link.
It always redirects to one language.

URL of (my) website where problem appears:
For instance
hidden link
when selecting button PORTFOLIO within the project sheet it redirects to hidden link while it should be
hidden link

I expected to see:
hidden link

Instead, I got:
hidden link

Why is this happening. (Does it has something o do with the global item (DIVI)?

Hope to hear from you?
TOny

June 18, 2017 at 8:27 am #1300378

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Tony.

Thank you for contacting the WPML support forum.

If you are setting this button through a Divi global item, so indeed this might be the reason for this problem.
Divi's global modules currently are not supported by WPML.
https://wpml.org/documentation/theme-compatibility/divi-builder/#list-of-the-divi-modules-translatable-with-wpml
Global modules need to be translated separately for each page.

Thanks,
Itamar.

June 19, 2017 at 12:11 pm #1300988

martineG-3

Thanks for your reply Itamar,

Could this problem also count for the header titles?

When translation a title with an & symbol. In dutch it shows OK, but in english and french translated version it changes to &

See images.
Tony

translation header frontend.jpg
translation header backend.jpg
June 20, 2017 at 1:18 pm #1302010

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Tony.

So if I understand, correctly you are using a global module, and in it, there is the & (ampersand) character. Then when you are translating this global module, the outcome of & is `&` Edit: AMP;
Is this correct?
When I tried it on my local server with the Divi theme, I did not get this issue.
How can I replicate this problem?

Thanks,
Itamar.

June 20, 2017 at 1:58 pm #1302048

martineG-3

That is correct Itamar.
I don't know why it won't display correctly.
I'm using the WPML translation module.

I'll try some things out and see what happens.
Tony

June 21, 2017 at 3:43 pm #1302939

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

In the test that I did, I also used WPML of course.
I'm sorry if I forgot to mention it.
I can see now on your website that in another place the ampersand sign is showing OK.
Please see attached screenshot ampersand-ok.jpg
Is it a Divi global module as well or have you fixed the problem?

I look forward to your reply!

Thanks,
Itamar.

ampersand-ok.jpg
June 22, 2017 at 10:33 am #1303510

martineG-3

Thanks for the reply Itamar,

The Logistics & industry page wasn't translated yet with WPML, but we have three different pages for that at the moment. We started out wiuth three different versions.

At the moment we are translating projects and pages with WPML. The ones translated with WPML are showing the ampersand symbol incorrectly.

Does that make any sense?
Thanks for your feedback.
Tony

June 22, 2017 at 9:37 pm #1304027

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

It might be an issue with mixed collation.
Could you, please check your DB to see if you have there a mixed collation.
That means different collation for different tables.
Please pay attention to the icl_ tables (WPML's tables) collation.
Is it different from the other tables?

June 23, 2017 at 12:21 pm #1304422

martineG-3

Thanks for the feedback Itamar, but I'm not sure what you mean. I checked the DB, but can't seem to find de icl tables.

June 26, 2017 at 7:49 pm #1306003

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

There might be a prefix before the icl tables like so wp_icl_translations.
The wp_ part can be different on you DB.
It depends on the prefix that you established while setting up this site or it was predefined by your hosting company.
Can you see those tables?

June 27, 2017 at 1:39 pm #1306628

martineG-3

I'm sorry Itamar. I can't seem to locate those icl_translation (using ftp).
Tony

June 27, 2017 at 9:15 pm #1307055

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Tony, you can't locate it anything from the Data Base with FTP connection.
I'll try to help with this.
I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.
For this, I'll need to install the Duplicator plugin on your site.
https://wordpress.org/plugins/duplicator/
I'll also install the ARI Adminer plugin (https://wordpress.org/plugins/ari-adminer/) to check the DB of your site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Thanks,
Itamar.

June 30, 2017 at 6:55 pm #1309751

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Tony and thanks, for the access details.

I've installed the ARI Adminer plugin on your site to check the DataBase.
But then before I started to examine this issue I looked again on the page where the problem existed there.
hidden link
Now in this page's translation, I can't see the ampersand problem anymore.
Please see attached screenshot amp-ok.jpg
Have you fixed this problem already?
Does it still exist on other projects?
If so then, please share with me the links to those projects.

Regards,
Itamar.

amp-ok.jpg
July 3, 2017 at 12:16 pm #1310622

martineG-3

Hello Itamar,

This is very strange. Problem seems to be solved. But I don't know what solved the problem.
Thanks for the help anyway.
Tony