Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Some strings from WooCommerce in chinese are not translated

Solution: Please make sure you have the latest version of WordPress and WooCommerce installed and then scan WooCommerce and WordPress by going to WPML > Theme and plugins localization > Select WooCommerce and press the "scan" button

This topic contains 16 replies, has 2 voices.

Last updated by supit-ones 1 month ago.

Assigned support staff: Alejandro.

Author Posts
December 1, 2019 at 9:48 am #5048871

supit-ones

I found a problem when I was doing the translation, which is in the checkout page.
It is only happened in language Chinese (Traditional). Most of countries in the dropdown list are not translated yet. (But there is no problem in language Chinese (Simplified).) May I know if I have to translate them one by one? Or, may I have another way to do it easier and faster?

December 3, 2019 at 9:42 am #5058999

supit-ones

May I have your help, please?

December 3, 2019 at 12:31 pm #5060455

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

That information should be coming from WooCommerce and not from WPML, but i just checked for the string "Zimbabwe" and i can correctly see it: hidden link

Before we start, though, Let's start by meeting WPML's and WooCommerce's minimum requirements:

Please add the following code in your wp-config.php file, right after the database information lines of code:

define('WP_MEMORY_LIMIT','256M');

Then, please update the translation of WooCommerce by downloading it here: hidden link

(documentation on how to achieve this: https://docs.woocommerce.com/document/woocommerce-localization/# )

Then upload it in WPML > String Translation > import .mo files.

That should do it.

December 4, 2019 at 9:05 am #5066273

supit-ones

Thanks a lot for your reply.

The code, " define('WP_MEMORY_LIMIT','256M'); ", is in my wp-config.php file.

And, I tried to put the translation.mo file to String Translation. I am confusing if I put it into the wrong place.
May I confirm if I choose the String "WPML" or "Woocommerce", please?
I put into those actually, but the problem is still here.

December 4, 2019 at 3:31 pm #5070199

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

It should go to WooCommerce, not in WPML.

However if the problem remains, then maybe i could take a closer look if you give me access to the site.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

December 5, 2019 at 11:16 am #5075793

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok, i think that the update will fix the problem. but it looks this is a production site. if you want i can provide a staging site where you can migrate this site and then we can test if everything goes alright with the updates.

The problem here seems to also be related to the ajax plugin you have, i'm not entirely sure but i can't do much on a production site without risking to remove functionalities on the front-end.

If you can provide a staging site, that would be even better, because then i'd also be able to test your server.

Please let me know how you'd like to proceed.

December 6, 2019 at 7:05 am #5081467

supit-ones

Yes, I created a new user on a staging site.
The website address: please change "www" to "dev". The account is with the same name and password.

Could you provide the steps that we can handle ourselves at our production site after the testing ok at dev site, please?

December 6, 2019 at 1:13 pm #5084005

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I tried to access the site but it didn't work, it seems "hidden link" is not accessible, coudl you please check?

Thanks.

December 7, 2019 at 4:51 am #5086483

supit-ones

I meant to change www to dev.
dev.more 🙂 not hidden link

December 7, 2019 at 12:26 pm #5087351

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I believe you have a server-side cache because as soon as i disabled the plugins, all teh site "lost" its styling and the Jivochat was still active even though i had disabled the plugin.
hidden link

Please disable the serverside cache and if you're working using cloudflare please flush the cache and active development mode so i can continue with the tests.

Regards.

December 8, 2019 at 3:01 pm #5088889

supit-ones

I just tested it. I disable some other plugins, they could be disable successfully.
We do not have cache problem.
Could you continue to fix, please?

December 9, 2019 at 2:25 pm #5093391

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Yes, they can be disabled successfully but this is what happens when i disable them all except WooCommerce and WPML plugins: hidden link

If you can see the same thing, then it means there's something going on, something that is important that i know in order to consider when troubleshooting your problem.

Please let me know because this is actually important since part of the problem you are having is with some strings not showing translated.

December 11, 2019 at 6:48 am #5104047

supit-ones

I deactivated the plugins one by one and then we found out that it should be because of a plugin: "Really Simple SSL".
Could you keep the "Really Simple SSL" be activated when you work it, please?
Thank you very much 🙂

December 12, 2019 at 1:31 pm #5115521

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi, i'm still working on this issue. i'll keep you updated with the results.

December 12, 2019 at 6:37 pm #5118237

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi, i asked one of our developers to check the site because i couldn't find the cause. i'll keep checking however and wait for him to let me know.