This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by chissyB 11 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
October 1, 2018 at 11:30 pm #2779628

chissyB

I am trying to: translate the homepage in spanish

Link to a page where the issue can be seen:
hidden link

I expected to see:hidden link

Instead, I got:When I return to the finished translation, there is always a case that stays in "not completed" even if I checked the case.
Can you help me please ?

October 3, 2018 at 5:47 pm #2785427

chissyB

Can somebody help me please, thank you

October 3, 2018 at 9:14 pm #2785752

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

1. When you go to the translation and check the box then save it are you able to see any errors within the console ? (right click ==> inspect ==> console tab)

2. Please make sure to flash your cache
- are you using any drop-in cache plugins ?

3. if possible I would need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

October 5, 2018 at 8:03 pm #2791612

chissyB

Hello,
Thank you for you answer.
1. There is no errors in the console tab
2. I flush the cash but I still have the error on the homepage
3. I edited the wp-config file but I found no (‘WP_DEBUG’, false) So I added it,
there's the error-log

[05-Oct-2018 19:59:54 UTC] PHP Notice: Constant WP_MEMORY_LIMIT already defined in /home4/bloomay1/public_html/paraiso/wp-config.php on line 179
[05-Oct-2018 19:59:56 UTC] PHP Notice: Constant WP_MEMORY_LIMIT already defined in /home4/bloomay1/public_html/paraiso/wp-config.php on line 179
[05-Oct-2018 19:59:56 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home4/bloomay1/public_html/paraiso/wp-config.php:179) in /home4/bloomay1/public_html/paraiso/wp-admin/includes/misc.php on line 1126
[05-Oct-2018 19:59:58 UTC] PHP Notice: Constant WP_MEMORY_LIMIT already defined in /home4/bloomay1/public_html/paraiso/wp-config.php on line 179
[05-Oct-2018 19:59:58 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home4/bloomay1/public_html/paraiso/wp-config.php:179) in /home4/bloomay1/public_html/paraiso/wp-admin/includes/misc.php on line 1126
[05-Oct-2018 20:00:08 UTC] PHP Notice: Constant WP_MEMORY_LIMIT already defined in /home4/bloomay1/public_html/paraiso/wp-config.php on line 179

October 8, 2018 at 6:10 pm #2797083

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

is your WP Memory set twice within your wp-config.php ?

if possible i would like to take a closer look

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

October 16, 2018 at 5:40 pm #2822006

chissyB

Hello,
I don't know how but I tried to update the homepage in spanish today and by magic it worked!
Did you do something ? Can you explain to me what was the problem ?
Thank You

October 16, 2018 at 7:59 pm #2822293

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

We have seen similar issues in the past resolved due to cache, maybe this was the case here as well.

i personally did not make any changes to your site...is the issue still resolved if yes i believe this might have been a case of caching.

October 23, 2018 at 10:46 pm #2844158

chissyB

My issue is resolved now. Thank you!