This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by seaghanm 2 weeks, 5 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 29, 2020 at 11:45 am #6249077

seaghanm

On hidden link
(hidden link)

I searched for the string: "Enter book name or author"
I entered the translation - it now says "Translation Complete"
But the text does not display on the page (hidden link)

How can I publish / go-live with my new text?

May 29, 2020 at 9:04 pm #6252941

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

June 2, 2020 at 12:43 pm #6274185

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I checked your WordPress Dashboard and noticed the correct string didn't seem to be properly registered, I tried these steps in order to fix it:

1 - In your WordPress Dashboard > WPML > String Translation settings I enabled the option 'Auto register strings for translation' (see attached screenshot);

2 - Then, I reloaded the page at hidden link, then I translated the registered string back in the String Translation under the 'default' text domain;

3 - You can confirm the results at: hidden link

Reference: https://wpml.org/documentation/getting-started-guide/string-translation/#auto-register-strings-for-translation

Please, let me know if you need any other detail and clarification, have a nice day.

June 15, 2020 at 7:28 am #6370585

seaghanm

thank you so much!
I think it worked 100% 🙂