Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 43 replies, has 4 voices.

Last updated by Sumit 1 day, 19 hours ago.

Assigned support staff: Alejandro.

Author Posts
October 2, 2019 at 11:23 pm #4683435

bayaH

I am translating a Gravity Form. The form has hundreds of entries, and probably 1,000 items to translate. I think this large load is slowing down the WMPL process. The result is the translation is never completed.

I am trying to: finalize a translation. I have input all the translation entries. I click Finalize. WMPL takes me to the screen where I should see either the Visual View or HTML View. Neither view ever loads. I press "Complete," and the WMPL site just loads forever. The translation is never actually finalized, so my site will not display the translation.

Link to a page where the issue can be seen: hidden link

I expected to see: A message saying my translation is complete.

Instead, I got: The WMPL page loads forever.

October 3, 2019 at 4:17 pm #4689781

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

1. System Resources
1.1 PHP Memory
I see that you have 3072M if availavle memory but that you have only allocated 256M to WordPress.

Please try setting your limit to be the same as your phsyical limit in case the problem is a lack of resources. This can be done by modifying your wp-config.php file.

1.2 . Max input Vars
You also might try increasing the max input vars to something more than what is currently defined.

2. WP Debug Mode
Please activate the wordpress debug mode by adding/changing the following line in your wp-config.php

define('WP_DEBUG', true);

After having increased your system resources, try saving the translation again and then see if any system messages are reported. Please include any messages in your next response.

Thanks

October 5, 2019 at 7:25 pm #4700993

bayaH

I complied with 1.1 and 1.2.
If I turn debug on, my site displays errors and does not work.
More importantly, the page that is slow is: hidden link.
This is your site. Does it require resources from my site?

October 6, 2019 at 7:30 pm #4703213

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

1. Debug log
You can prevent the messages from displaying on the frontend by adding the following lines to your wp-config.php file. This way we can capture the messages in the /wp-content/debug.log

define('WP_DEBUG', true);

// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);

// Disable display of errors and warnings 
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);

2. ATE server
Coud you tell me which gravity form is causing this issue?

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

October 8, 2019 at 1:27 pm #4715805

bayaH

To make sure I understand - my site sends the info to hidden link, which then loads slowly, probably because there are too many translations. Why do I need to debug my site if the problem is on wpml.org?

October 9, 2019 at 7:24 am #4720147

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi

You asked: "Why do I need to debug my site if the problem is on wpml.org?"

The debug mode will just capture any other system messages that might contradict/support your observations. e.g. communications problems, database problems

It´s simply to get as much information as possible.

Is this happening with all translations or just this one document?

October 13, 2019 at 6:38 am #4744087

bayaH

I added that code. No debug log is created. Two forms experience this issue. They are both huge forms. One is slightly smaller; it eventually loads. This form is bigger, and it never finalizes the translation. Can you send the FTP and admin password request again? I do not see a secure way to input them.

October 14, 2019 at 7:23 am #4747545

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I don´t think I need access to your site as you say you are experiencing this problem with very large forms and the problem is actually with the ATE server.

I think the next step is to either have you provide me with a copy of your site or a copy of the forms that are causing the issue so that the ATE team can use it as a border-case to tune the server.

So, I am opening the private area for you to provide either a copy of your site or an export of the forms (if that is even possible)
Here are instructions for providing the copy of the site:
https://wpml.org/faq/provide-supporters-copy-site/

October 15, 2019 at 8:24 am #4755353

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

I´m sorry to pester you again.

2nd tier is asking if there is anyway you could get an XLIFF export of the form?

Normally you can do this by defining a local translator, and then sending the form to the local translator via Translation Management system. The translator can then choose to download the XLIFF format.

Thank you for advising.

October 15, 2019 at 12:21 pm #4757151

bayaH

I have uploaded it to the shared folder given in the last reply.

October 16, 2019 at 9:54 am #4764365

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Thanks so much for your collaboration in providing the test cases. Our 2nd tier support group will be working with the ATE team to see what can be done.

October 20, 2019 at 4:01 pm #4789881

bayaH

Any update?

October 21, 2019 at 10:28 am #4793369

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Just checked.

They are choosing to use your json backup. From here, they ask which of the many forms is the one that is causing the issue. They tested with some but could not see the issue....I think they picked the wrong ones.

I will point out to them that the XLIFF has the problematic form but maybe you can also tell me?
THanks

October 21, 2019 at 12:15 pm #4794403

bayaH

It is form ID 12. The name of the form is "1 Step".

October 21, 2019 at 1:58 pm #4795079

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

As always, thanks.