This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

This topic contains 4 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 year, 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 1, 2018 at 10:46 pm #1918467

carolineS-11

We are using FooGallery for our image galleries (similar to NextGen but easier and less of a memory hog). FooGallery pulls the images directly from the WordPress media library. We need to get the string for the descriptions into a translation file to send to our translation service but cannot see anyway to do this. I have read everything I can find related to this and there is nothing except that tells how to manually add the language after it has been translated.

hidden link - See descriptions under each photo such as "Loaded with class leading features..." etc.

SEPARATE ISSUE - when clicking any other language besides English, cannot get the link to the News page to work: hidden link as it comes up with Page Not Found. Not sure where to fix that. It returns with "Sorry, no content matched your criteria."

WordPress 4.9.5 running Outreach Pro theme.

May 3, 2018 at 9:19 am #1951861

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

For your second issue, may I kindly ask you please to open a new ticket for your additional question? This will help other users with similar problems to find solutions when searching the forum.

Regarding the translation description translation, could you please use the steps provided here to send to content to translation https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/#sending-content-for-translation

While sending the content, make sure to select media on content types, could you please let me know if this helps?

For helping further on this issue it's very important to know your site related information such as themes used, plugins used, PHP versions etc. You can easily send this using Debug information settings from WPML. So could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Look forward to your reply.

Thanks

May 11, 2018 at 3:11 pm #2090443

carolineS-11

I have no idea what you are asking us to do. I went to the link https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/#sending-content-for-translation and the section regarding media says:

Translating fields with images and other media types
The Translation Editor does not allow adding media to the contents during translation.
Use the following steps to translate fields that feature media:
Copy the field from the original. You will see the media appear in the translation.
Translate the texts.
Click on the checkbox to indicate that translation is complete.

Here are my questions for each step:
1. Copy the field... Is field referring to "Caption" or "Description" and where do we copy it to?
2. Translate the texts...How do we translate the text, manually?
3. Click on checkbox that translation is complete - I guess if we can 1 & 2 completed, we will see this.

Our main issue is we have no idea how or if we can send the image captions and descriptions to be translated. The translator cannot find any files with media captions and descriptions information so we can even get them translated.

AND, once translated, do we have to manually add back in the translations to the photo galleries by duplicating the photo gallery and copying and pasting the translations in?

I am attaching 3 images for you to see on our backend. One is our foogallery that is live and the 2nd one is showing one of the images in the gallery which also is in the WordPress Media Lilbrary. The 3rd is a screenshot from our WPML Translation Management screen.

May 11, 2018 at 4:46 pm #2092550

carolineS-11

I made a backup using duplicator and uploaded it with the other support request regarding the link to the blog. This is the link: [removed]

May 14, 2018 at 7:58 am #2112500

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Here is the step to step guide to translate media.hidden link

AND, once translated, do we have to manually add back in the translations to the photo galleries by duplicating the photo gallery and copying and pasting the translations in?

Yes, you have to add the images manually.

Let me know if this helps.

Kind Regards,
Shekhar