This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by Andreas W. 5 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
April 11, 2019 at 2:22 pm

joopv-2

I am trying to: Restore a translation that somehow got corrupted. The wrong images are displayed on the download pages in German and Spanish

Link to a page where the issue can be seen: hidden link

I expected to see: The right images of the brochures in the German and Spanish translations.

Instead, I got: Whatever I do, it keeps showing the wrong ones. And they're all the same!

April 11, 2019 at 7:02 pm #3592279

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Before you take any further steps please got to Plugins -> Add new -> Commercial and click "check for updates". Then update WPML and any additionally used add-ons.

As you mentioned that you are using different images for the German and Spanish versions of your website I would advise you to install our Media Translation Plugins.
This plugin is dedicated for replacing media images on translated pages with language specific media content.
https://wpml.org/documentation/getting-started-guide/media-translation/

Let me know if you need any further assistance.

Kind regards
Andreas

April 12, 2019 at 4:33 am #3594919

joopv-2

All plugins are up-to-date.

No, it's different. As these are JPEGs of PDF Brochures, only existing in English, I DON'T want different images for different languages.

But alas THEY ARE different and shouldn't be! Somehow things got corrupted as originally the translated pages used to be fine.

I tried repairing this but haven't succeeded.

It would be a great help, if nothing else helps, to be able to delete the translated pages and rebuild them. But it seems impossible to do this.

Please have a further look into to this.

Thank you!

April 12, 2019 at 7:23 pm #3601441

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,
I am sorry, but I think I am not really understanding the issue. You do not wish to replace the download files with German versions? If it is more easy for you you also might replay me in German, as I am native German.

As far I can see the page "Downloads" has translated flyers in English language and the translations are processed proper.

Your Media Library does not include any German Flyers as far I can see. Please take a look at the following screenshots. If you change to "text" on the Translation Editor you will be able to edit the text block and replace the file name sin case you wish to use different files.

In other case, if you wish to create the pages new, you can simply delete the page downloads from all languages and create a new one. But then you will also need to translate this page again completely.

Kind regards
Andreas

April 12, 2019 at 9:03 pm #3601981

joopv-2

Hallo Andreas,

Ich bin gebürtiger Holländer aber lebe an die Deutsch/Niederländische Grenze!

Du hast recht, im TEXT/CODE sieht alles gut aus. Und auch die richtigen Broschuren werden heruntergeladen. Aber bitte schaue dir die Bilder zu den Broschuren an. Auf die Englische Seiten sind die alle unterschiedlich. Auf die Deutsche und Spanische sind es, bis auf 1 oder 2, alle dasselbe Bild. Hier is was massiv schiefgelaufen und ich kann es nicht ändern, was ich auch tue. Ich habe die Deutsche und Spanische Seite (direkt in WP unter 'Pages') gelöscht und neu aufgebaut aber trotzdem kommen alle dieselbe Broschuren als Bild zurück, obwohl die WPML Übersetzungsmodule die richtige Anzeigte.

Verstehst du das Problem?

Danke für deine Unterstützung!

Joop van Reeken

April 12, 2019 at 10:02 pm #3602161

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für die Nachricht.

Ich habe das Problem jetzt verstanden und ich glaube es liegt daran, dass bis auf das erste Billder, alle weiteren Bilder die gleiche Attachment ID teilen. Die korrekte Attachment ID finden Sie in Ihrer Media Library, wenn Sie eine Datei öffnen und einen Blick auf die Browser-Adressleiste werfen (siehe Screenshot).

Sie könnten in der Zwischenzeit versuchen, diese ID´s auf dem Fusion Builder manuall zu ändern und erneut zu ersetzen. Ich werde versuchen dieses Problem auf einer neuen WordPress Installation nachzustellen, um festzustellen, ob es ein Kompatibilitätsproblem zwischen dem Fusion Builder und WPML gibt. Da das Problem allerdings bereit sin der Originalsprache entsteht, glaube ich, dass das Problem hier auch an einem anderen Plugin liegen könnte.

Sie könnten Sie testen, indem Sie WPML und seine add-ons deaktivieren und einen neue Seite mit Fuison Builder erstellen. Sollten wieder die gleiche Attachment ID verwendet werden, liegt das Problem möglicherweise an einem anderen Plugin.

Ich würde in diesem Fall dazu raten, den Avia Support um Rat zu bitten.

Ich melde mich bei Ihnen, sobald ich den Fusion Builder auf einer neuen Installtion getestet habe.

Mit freundlichen Grüßen
Andreas

April 15, 2019 at 4:42 pm #3615091

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Bitte teilen Sie mit in detailierten Schritten mit, wie die Bilder in der Seite Downloads integriert wurden.

Ich sehe, dass diese in einem Textblock mit dem Shortocde "captions" integriert wurden. Ich gehe davon aus, dass dabei der Person, die diese Seite erstellt hat ein Fehler unterlaufen ist. Ich würde dazu raten, die Bilder ernut einzugfügen und entweder, die Schaltfläche zum hinzufügen von Medien zu verwenden oder anstelle eines Text Blocks, das Seitenbilder-Element "Image" zu verwenden.

Mit freundlichen Grüßen
Andreas

April 15, 2019 at 5:20 pm #3615321

joopv-2

Hi Andreas,

Ich habe schon befürchtet dass das nicht einfach zu lösen ist. Ich habe die Texte über ein Textblock in AVADA eigetragen und das dazu gehörende Bild tatsächlich über die Schaltfläche zum hinzufügen von Medien eingetragen.

Ich werde die Seite neu aufbauen.

Was schiefgelaufen sein könnte, ist das ich - aus damalige Unerfahrenheit - die Übersetzungen teils in WP-Editor gemacht habe (Sprachenwechsel über die Fahne oben im Dashboard) und teilweise über die WPML-Translation Editor.

Bitte erkläre mich nur, wie ich eine Seite UND die Übersetzungen definitiv lösche. Weil ich habe das auch mal im WP-Dashboard getan und dann kam die alte Übersetzung doch wieder hoch.

April 15, 2019 at 5:59 pm #3615587

joopv-2

Ich habe soeben die Seite DOWNLOADs kopiert als DownloadNEW. Ich habe das Block mit den PDFs als Global Container definiert (in Avada) und einfach alle Inhalte auf Deutsch und Spanisch kopiert (In WPML) also keine Übersetzungen gemacht. Diese Container darf auf English bleiben in jede Sprache.

Es sieht alles in WPML-Translation super aus. Die richtige Bilder werden genannt und in Visual Mode dargestellt.

Nur nicht wenn man die Seite aufruft...

Ich werde verrückt.

April 15, 2019 at 6:38 pm #3615821

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Werfen Sie bitte einen blick auf die folgende Seite:

hidden link

Es bestand kein Problem, die Bilder in einer weiteren Sprache sichtbar zu machen. Sollten Sie diese Bilder nun mit einer anderen Sprachversion der jeweiligen Datei ersetzen wollen, so nutzen Sie bitte unser Media Translation Plugin.

Ich vermute, das Problem auf Ihrer Seite liegt daran, dass der von Ihnen verwendete Shortcode nicht korrekt ist. Wie bereits zuvor erwähnt nutzen Sie die gleiche AttachmentID für verschiedene Medien, was im Grunde die Ursache des Problems darstellen könnte.

Bitte werfen Sie einen Blick auf die von mir erstellt Seite. Ich habe alleine durch "Medien hinzugfügen" die BIlder eingefügt und übersetzt. Zum Download können Sie einen weiteren Textblock unter jedem Bild anlegen.

Lassen Sie mich wissen, ob Sie weitere Fragen haben.

Mit freundlichen Grüßen
Andreas

April 16, 2019 at 10:49 am #3621095

joopv-2

Erstmal danke für deine Mühe!

Das sieht indertat besser aus. Ich werde also die Seite total neu aufbauen und mit separaten Bilder und Textblöcke.

Ich muss dafür ein bisschen Zeit finden und melde mich dann wieder, hoffentlich dass alles dann in Ordnung ist!

Nochmals danke!

April 17, 2019 at 9:37 pm #3634819

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Ich bin vom 18.09.2019 bis zum 21.09.2019 leider nicht verfügbar. Sollte es Probleme mit den Übersetzungen geben öffnen Sie bitte ein neues Ticket in der Zwischenzeit.

Ich stehe Ihnen gerne am Montag wieder zur Verfügung und wünsche Ihnen frohe Feiertage.

Mit freundlichen Grüßen
Andreas

April 23, 2019 at 2:54 pm #3665155

joopv-2

Hallo Andreas,

Ich hoffe du hattest ein schönes Osterwochenende.

Ich wollte heute die Arbeit an test.thenex.com wieder anfangen, bin aber ziemlich ratlos.

Jetzt ist plötzlich auch die Deutsche Übersetzung von Homepage 'verschwunden'. Es wird auf English dargestellt. Die spanische ist in Ordnung.

Also bevor ich ernsthafte Arbeit anfange (reparieren der Bilderlinks) muss ich dir was fragen. Vor ein oder zwei Monate hat es angefangen mit diese 'unerklärbare' Sachen. U.a. das vorher 'verschwinden' der richtige Bilder in die Übersetzungen vom 'Download' page.

Neulich sind wir darauf gekommen das der heutige Provider ein sehr knappes Speicher zu Verfügung gestellt hat. Durch den vielen Backups ist das wahrscheinlich voll gelaufen.

Wir haben auch für einen andere Provider entschieden und werden diese Woche dahin umziehen. Teils haben wir das schon (z.b. mit diesen test.thenex.eu).

Kann es sein das der Database durch diese Speichermangel Schaden gelaufen hat?
Kann man das kontrollieren?
Wenn ja, Kan mann das wieder in Ordnung bringen? Gibt es dafür Plugins?
Oder kann ich es jemanden (wem?) bezahlt in Ordnung bringen lassen?

Oder mache ich mir unnötig Sorgen und ist es einen anderen Fehler?

Ich werde versuchen auf ein anderes Domän einen alten Backup zu installieren um heraus zu finden wann alles noch 'in Ordnung' war.

Deine Unterstützung wird sehr geschätzt.

mfrGr, Joop

April 23, 2019 at 4:10 pm #3666041

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Joop,

Könnten Sie bitte Ihre WordPress-Speichergrenze (WP Memory Limit in wp-config.php) auf mindestens 256 MB erhöhen? Für WPML ist mindestens 128M erforderlich.
Ihre aktuellen Werte sind:

MemoryLimit 768M (php.ini)
WP Memory Limit 40M (wp-config.php)
Fügen Sie diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:

/ * Speichergrenze /
define ('WP_MEMORY_LIMIT', '256M'));
</ code>
Fügen Sie es kurz vor:
[php]
/ That's all, stop editing! Happy blogging. /

Diese Einstellungen können direkt von Ihrem Hosting-Provider eingeschränkt werden. Daher empfehle ich Ihnen, sich mit ihnen in Verbindung zu setzen und sie zu bitten, sie direkt zu ändern.
Wenn Sie noch höhere Werte erhalten können, wäre das großartig. Achten Sie auch bitte darauf, dass die Speichergrenze für PHP immer etwas grüér sein sollte, als das WP Memory Limit.

Sollte das Problem weiterhin bestehen machen Sie bitte eine Sicherungskopie Ihrer Website und der Datenbank. Aktualisiseren Sie WPML und seine Add-ons. Gehen Sie auf WPML -> Support und wählen Sie "Fehlerüberprüfung". Führen Sie hier alle Optionen zum Thema Bereinigung der Datenbank durch.

Gehen Sie außerdem auf WPML -> Einstellungen -> Medien-Übersetzung und klicken Sie die Schaltfläche "Start" um alle verfügbaren Medien der Website zu Snychronisieren.

Versuchen Sie bitte, die Website mit minimalem Setup auszuführen, um festzustellen, ob das Problem weiterhin besteht.

Deaktivieren Sie alle zusätzlichen Plugins, die nicht mit WPML und ihren Add-Ons zusammenhängen. Wenn das Problem nicht mehr angezeigt wird, reaktivieren Sie alle Plugins oder aktivieren Sie sie in kleinen Gruppen. Überprüfen Sie auf diese Weise, an welchen Stellen das Problem erneut angezeigt wird, um das Plugin anzuzeigen, das das Problem verursacht.

Bitte ändern Sie auch ein Standarddesign wie TwentySeventeen, um zu sehen, ob das Problem möglicherweise themenbezogen ist.

Außerdem können Sie die Funktion wp-debug aktivieren, um festzustellen, ob aktuelle PHP-Fehler vorliegen. Geben Sie dazu folögendes in Ihrer wp-config Datei ein:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG-LOG', true );

Besuchen Sie nun das Frontend Ihrer Website. Sollten Fehler vorhanden sein, werden diese erfasst und in der debug.log Datei im Ordner wp-content Ihres Servers gespeichert.

Weitere Informationen zum Aktivieren dieser Funktion finden Sie hier:
https://wpml.org/documentation/support/debugging-wpml/

Zu Ihrer Frage bezüglich der Behebung von möglichen Fehlern in der Datenbank durch einen Programmierer lesen Sie bitte folgende Artikel:
https://wpml.org/de/purchase/support-richtlinie/
https://wpml.org/contractors/

Lassen Sie mich bitte wissen, ob Sie weitere Hilfe benötigen.

Mit freundlichen Grüßen
Andreas

April 24, 2019 at 1:30 pm #3673423

joopv-2

Ich habe die meiste Schritte durchgeführt aber zögere bei diese beide Optionen:

  • Dieser Vorgang wird die Sprachtabellen von WPML zurücksetzen und neu installieren. Alle kundenspezifischen Sprachen, die Sie hinzugefügt haben, werden entfernt.

    Zurücksetzen
    The 'Reset' action will deactivate the WPML plugin after it deletes the WPML tables (tables with the 'icl_' prefix) from the database. The action will NOT delete any content (posts, taxonomy terms etc.). It only affects translation and language information that WPML associates with each content type.
    Bitte beachten Sie, dass slle Übersetzungen, die Sie an Fernübersetzungsdienste gesendet haben, verloren gehen, wenn Sie die WPML-Daten zurücksetzen. Sie können später nicht wieder hergestellt werden.
    If you are using the Advanced Translation Editor, you will lose the translations that are in progress, as well as the existing translation memory and glossary. You will also lose access to purchases, invoices, and history related to your work with the Advanced Translation Editor.
    Ich bin im Begriff, alle Übersetzungs- und Sprachdaten zurückzusetzen.</ li>

    Verliere ich dann nicht die Übersetzungen selber?

    Mit freundlichen Grüßen,

    Joop