Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by andreaC-50 1 year, 7 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
December 31, 2018 at 4:52 pm #3045864

andreaC-50

I am trying to:
translate a page using advanced translation editor (but the same happens with standard translation editor)

This page has a long history of revisions, change of theme, change of page builder ..
but currently has only:
1) a title
2) a featured image
3) one row of text
+ an embedded form from an external application, called with a shortcode.

I deleted from the database all the postmeta data related to old plugins and theme

Link to a page where the issue can be seen:
hidden link

I expected to see:
I expected that the translation editor ask me to translate only 3 items: title, featured image, row of text, and maybe the shortcode

Instead, I got:
Many strings to translate (see attached image)

January 1, 2019 at 3:42 am #3046500

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please follow the below steps to fix the issue?
- Mark all the fields in ATE as translated.
- Save the translation
- Now update the original language
- Try to translate again, the ATE now should show only current fields.

Let me know if this helps.

Thanks

January 2, 2019 at 10:52 am #3048638

andreaC-50

The procedure didn't work for me.
After marking all fields as translated, save, update original and translate again, the extra fields where still there.
But anyway, this was just a simple case to better understand what to do when it happens with more complicated pages. This page is so simple that I solved the issue deleting the page and recreating from scratch.

Thank you
Andrea

January 2, 2019 at 10:53 am #3048639

andreaC-50

My issue is resolved now. Thank you!