Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 3 voices.

Last updated by Laura 4 months, 3 weeks ago.

Assigned support staff: Otto.

Author Posts
July 2, 2020 at 8:41 am

Kristof

Here are steps to reproduce this issue.

1. Add below HTML code:

<script src="<em><u>hidden link</u></em>"></script>
<script> 
 function timestamp() { var response = document.getElementById("g-recaptcha-response"); if (response == null || response.value.trim() == "") {var elems = JSON.parse(document.getElementsByName("captcha_settings")[0].value);elems["ts"] = JSON.stringify(new Date().getTime());document.getElementsByName("captcha_settings")[0].value = JSON.stringify(elems); } } setInterval(timestamp, 500); 
</script>

<form action="<em><u>hidden link</u></em>" method="POST">

<input type=hidden name='captcha_settings' value='{"keyname":"RecaptchaProd","fallback":"true","orgId":"00D20000000Bqjw","ts":""}'>
<input type=hidden name="orgid" value="00D20000000Bqjw">
<input type=hidden name="retURL" value="<em><u>hidden link</u></em>">

<label for="name">Name</label><input  id="name" maxlength="80" name="name" size="20" type="text" required /><br>
<br>
<label for="email">Email</label><input  id="email" maxlength="80" name="email" size="20" type="email" required /><br>
<br>
Product<select  id="00N1r00000KZxmX" name="00N1r00000KZxmX" title="Web-to-case product">
<option value="">--None--</option>
<option value="DSS">DSS</option>
<option value="eSignatures">eSignatures</option>
<option value="IDS">Identity Services</option>
<option value="Smart Documents">Smart Documents</option>
<option value="Other">Other</option>
</select><br>

<label for="subject">Subject</label><input  id="subject" maxlength="80" name="subject" size="20" type="text" required /><br>
<br>
<label for="description">Description</label><textarea name="description" required></textarea><br>

<input type=hidden id="priority" name="priority" value="P3 - Non Urgent">

<input type="hidden"  id="external" name="external" value="1" /><br>

<div class="g-recaptcha" data-sitekey="6Lcp2VIUAAAAAEbuQYtVYxBXx6XeYes0AhSmhYBU"></div><br>
<input type="submit" name="submit">

</form> 

In Elementor HTML code widget.

2. Then opens the page in Classic Translation Editor.

3. It shows part of the HTML code to translate and not complete HTML as you can see in the attached screenshot.

How can I fix this issue?

Thank you

6502849-Screenshot_11.jpg
July 2, 2020 at 10:29 am
July 4, 2020 at 10:37 am #6519493

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Kristoff,

Just to let you know that I managed to reproduce the issue and escalated the ticket to our second tier support.

I'll get back to you as soon as I have news regarding this issue.

Kind regards,

Otto

July 7, 2020 at 12:18 pm #6538611

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Just a quick update.

We are still checking the problem but we found that it works with the ATE:
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

It may help you as a workaround while we fix this.

Let me know if this helps, please.

Kind regards,

Otto

July 7, 2020 at 3:54 pm #6541193

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi again 🙂

Just FYI, the issue has been escalated to our development team.

Kind regards,

Otto

July 17, 2021 at 1:42 pm #9222179

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Fixed in WPML 4.4.0