Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Entire content is shown in one field while using Translation Editor, there should be different fields for translation, for separate elements.

Solution: I have fixed this issue by adding missing ‘wp_icl_string_packages’ table in database. Now Translation Editor and shortcodes working fine.

This topic contains 15 replies, has 2 voices.

Last updated by Noman 1 year, 3 months ago.

Assigned support staff: Noman.

Author Posts
September 7, 2018 at 7:39 am #2713500

robertoC-44

I am trying to: use the translation editor

Link to a page where the issue can be seen: it is in the backend

I expected to see: I expect to see every text field of the page in different rows

Instead, I got: all the site into a row

September 7, 2018 at 3:58 pm #2715372

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. We have another client who had the similar issue and was also able to solve it, this may help in your case:
https://wpml.org/forums/topic/using-visual-composer-when-translating-page-builder-does-not-show-only-body-htm/#post-1253539

Thank you

September 10, 2018 at 10:16 am #2719594

robertoC-44

Hi,
thank you for the answer. I don't use Visual Composer but WPBakery Page Builder. First time I installed the WPML pluging, it works fine, but when I click on save and close button, all the site crash. So I installed the plugin again and this time the editor stop working

September 10, 2018 at 12:52 pm #2719980

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

WPBakery Page Builder is same as Visual Composer, it was its old name as you can see here:
hidden link

So I would suggest to please try above solution that I shared.

Thank you

September 10, 2018 at 1:30 pm #2720055

robertoC-44

I've tryed the solution. I've created the wpml-config-xml file and I've copied it into the plugin root, ma it doesn't work

September 10, 2018 at 3:20 pm #2720530

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Please upgrade your server’s PHP version to a higher level: https://wpml.org/home/minimum-requirements/

- PHP is 5.4.45 which is good, but it's advised is to use more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

- If the issue persists, please enable error reporting at you site and examine debug.log file from wp-content folder and let me know if any error found.
To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

For more details:
https://wpml.org/documentation/support/debugging-wpml/

Thank you

September 10, 2018 at 6:24 pm #2721123

robertoC-44

Hi,
I've increased WP memory and update PHP version to the 5.6.32 but it still doesn't work...
Is there something to check in the DB?

Below the log

{"core":{"Wordpress":{"Multisite":"No","SiteURL":"http:\/\/www.studiocalabria.com","HomeURL":"http:\/\/www.studiocalabria.com","Version":"4.9.8","PermalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","PostTypes":"post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, vc4_templates, wpcf7_contact_form, vc_grid_item, the_grid, essential_grid, mpc_content_preset","PostStatus":"publish, future, draft, pending, private, trash, auto-draft, inherit, request-pending, request-confirmed, request-failed, request-completed"},"Server":{"jQueryVersion":"1.12.4","PHPVersion":"5.6.32","MySQLVersion":"5.5.61","ServerSoftware":"Apache"},"PHP":{"MemoryLimit":"256M","WP Memory Limit":"256M","UploadMax":"50M","PostMax":"55M","TimeLimit":"300","MaxInputVars":"3000","MBString":true,"libxml":true}},"plugins":{"active_plugins":{"sitepress-multilingual-cms\/sitepress.php":{"Plugin Slug":"sitepress-multilingual-cms","Name":"WPML Multilingual CMS","PluginURI":"https:\/\/wpml.org\/","Version":"4.0.6","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com\/","TextDomain":"sitepress-multilingual-cms","DomainPath":"","Network":false,"Title":"WPML Multilingual CMS","AuthorName":"OnTheGoSystems"},"redux-framework\/redux-framework.php":{"Plugin Slug":"","Name":"Redux Framework","PluginURI":"http:\/\/wordpress.org\/plugins\/redux-framework","Version":"3.6.11","Author":"Team Redux","AuthorURI":"http:\/\/reduxframework.com","TextDomain":"redux-framework","DomainPath":"ReduxCore\/languages","Network":false,"Title":"Redux Framework","AuthorName":"Team Redux"},"akismet\/akismet.php":{"Plugin Slug":"","Name":"Akismet Anti-Spam","PluginURI":"https:\/\/akismet.com\/","Version":"4.0.8","Author":"Automattic","AuthorURI":"https:\/\/automattic.com\/wordpress-plugins\/","TextDomain":"akismet","DomainPath":"","Network":false,"Title":"Akismet Anti-Spam","AuthorName":"Automattic"},"classic-editor\/classic-editor.php":{"Plugin Slug":"","Name":"Classic Editor","PluginURI":"https:\/\/wordpress.org","Version":"0.4","Author":"WordPress Contributors","AuthorURI":"","TextDomain":"classic-editor","DomainPath":"\/languages","Network":false,"Title":"Classic Editor","AuthorName":"WordPress Contributors"},"contact-form-7\/wp-contact-form-7.php":{"Plugin Slug":"","Name":"Contact Form 7","PluginURI":"https:\/\/contactform7.com\/","Version":"5.0.4","Author":"Takayuki Miyoshi","AuthorURI":"https:\/\/ideasilo.wordpress.com\/","TextDomain":"contact-form-7","DomainPath":"\/languages\/","Network":false,"Title":"Contact Form 7","AuthorName":"Takayuki Miyoshi"},"duplicate-page\/duplicatepage.php":{"Plugin Slug":"","Name":"Duplicate Page","PluginURI":"https:\/\/wordpress.org\/plugins\/duplicate-page\/","Version":"2.7","Author":"mndpsingh287","AuthorURI":"https:\/\/profiles.wordpress.org\/mndpsingh287\/","TextDomain":"duplicate-page","DomainPath":"","Network":false,"Title":"Duplicate Page","AuthorName":"mndpsingh287"},"envato-market\/envato-market.php":{"Plugin Slug":"","Name":"Envato Market","PluginURI":"https:\/\/envato.com\/market-plugin\/","Version":"2.0.1","Author":"Envato","AuthorURI":"https:\/\/envato.com","TextDomain":"envato-market","DomainPath":"\/languages\/","Network":false,"Title":"Envato Market","AuthorName":"Envato"},"essential-grid\/essential-grid.php":{"Plugin Slug":"","Name":"Essential Grid","PluginURI":"http:\/\/www.themepunch.com\/essential\/","Version":"2.1.6.2.2","Author":"ThemePunch","AuthorURI":"http:\/\/themepunch.com","TextDomain":"essential-grid","DomainPath":"\/languages","Network":false,"Title":"Essential Grid","AuthorName":"ThemePunch"},"js_composer\/js_composer.php":{"Plugin Slug":"","Name":"WPBakery Page Builder","PluginURI":"http:\/\/wpbakery.com","Version":"5.5.2","Author":"Michael M - WPBakery.com","AuthorURI":"http:\/\/wpbakery.com","TextDomain":"js_composer","DomainPath":"","Network":false,"Title":"WPBakery Page Builder","AuthorName":"Michael M - WPBakery.com"},"mpc-massive\/mpc-massive.php":{"Plugin Slug":"","Name":"Massive Addons for WPBakery Page Builder","PluginURI":"http:\/\/codecanyon.net\/item\/massive-addons-for-visual-composer\/14429839","Version":"2.3.3","Author":"MassivePixelCreation","AuthorURI":"http:\/\/codecanyon.net\/user\/mpc\/","TextDomain":"mpc","DomainPath":"\/languages\/","Network":false,"Title":"Massive Addons for WPBakery Page Builder","AuthorName":"MassivePixelCreation"},"one-click-demo-import\/one-click-demo-import.php":{"Plugin Slug":"","Name":"One Click Demo Import","PluginURI":"https:\/\/wordpress.org\/plugins\/one-click-demo-import\/","Version":"2.5.0","Author":"ProteusThemes","AuthorURI":"http:\/\/www.proteusthemes.com","TextDomain":"pt-ocdi","DomainPath":"","Network":false,"Title":"One Click Demo Import","AuthorName":"ProteusThemes"},"revslider\/revslider.php":{"Plugin Slug":"","Name":"Slider Revolution","PluginURI":"https:\/\/revolution.themepunch.com\/","Version":"5.4.8","Author":"ThemePunch","AuthorURI":"https:\/\/themepunch.com","TextDomain":"revslider","DomainPath":"","Network":false,"Title":"Slider Revolution","AuthorName":"ThemePunch"},"the-grid\/the-grid.php":{"Plugin Slug":"","Name":"The Grid","PluginURI":"http:\/\/www.theme-one.com\/the-grid\/","Version":"2.6.60","Author":"Themeone","AuthorURI":"http:\/\/www.theme-one.com\/","TextDomain":"tg-text-domain","DomainPath":"\/langs","Network":false,"Title":"The Grid","AuthorName":"Themeone"},"vc_clipboard\/vc_clipboard.php":{"Plugin Slug":"","Name":"Visual Composer Clipboard","PluginURI":"","Version":"4.1.1","Author":"bitorbit","AuthorURI":"http:\/\/codecanyon.net\/user\/bitorbit","TextDomain":"vc_clipboard","DomainPath":"","Network":false,"Title":"Visual Composer Clipboard","AuthorName":"bitorbit"},"wpml-string-translation\/plugin.php":{"Plugin Slug":"wpml-string-translation","Name":"WPML String Translation","PluginURI":"https:\/\/wpml.org\/","Version":"2.8.6","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com\/","TextDomain":"wpml-string-translation","DomainPath":"","Network":false,"Title":"WPML String Translation","AuthorName":"OnTheGoSystems"},"wpml-translation-management\/plugin.php":{"Plugin Slug":"wpml-translation-management","Name":"WPML Translation Management","PluginURI":"https:\/\/wpml.org\/","Version":"2.6.6","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com\/","TextDomain":"wpml-translation-management","DomainPath":"","Network":false,"Title":"WPML Translation Management","AuthorName":"OnTheGoSystems"}},"mu_plugins":[],"dropins":[]},"theme":{"Name":"MF","ThemeURI":false,"Author":"Mfdsgn","AuthorURI":"http:\/\/www.mfdsgn.com\/","Template":"","Version":"2.4.5","TextDomain":"mf","DomainPath":"","ParentName":""},"extra-debug":{"WMPL":{"hide_upgrade_notice":"4.0.6","icl_capabilities_verified":true,"active_languages":["en","it"],"interview_translators":1,"existing_content_language_verified":1,"language_negotiation_type":3,"theme_localization_type":"3","icl_lso_link_empty":0,"sync_page_ordering":1,"sync_page_parent":1,"sync_page_template":1,"sync_ping_status":1,"sync_comment_status":1,"sync_sticky_flag":1,"sync_password":1,"sync_private_flag":1,"sync_post_format":1,"sync_delete":0,"sync_delete_tax":0,"sync_post_taxonomies":1,"sync_post_date":0,"sync_taxonomy_parents":0,"translation_pickup_method":0,"notify_complete":1,"translated_document_status":1,"remote_management":0,"auto_adjust_ids":1,"alert_delay":0,"promote_wpml":0,"automatic_redirect":0,"remember_language":24,"icl_lang_sel_copy_parameters":"","translated_document_page_url":"auto-generate","sync_comments_on_duplicates ":0,"seo":{"head_langs":1,"canonicalization_duplicates":1,"head_langs_priority":1},"posts_slug_translation":{"on":1,"string_name_migrated":true},"urls":{"directory_for_default_language":0,"show_on_root":"","root_html_file_path":"","root_page":0,"hide_language_switchers":1},"xdomain_data":1,"custom_posts_sync_option":{"post":1,"page":1,"attachment":1,"vc_grid_item":1},"taxonomies_sync_option":{"category":1,"post_tag":1,"translation_priority":1},"tm_block_retranslating_terms":"1","admin_default_language":"_default_","taxonomy_names_checked":true,"st":{"db_ok_for_gettext_context":true,"WPML_ST_Upgrade_Migrate_Originals_has_run":true,"WPML_ST_Upgrade_Db_Cache_Command_2.4.2_1_has_run":true,"WPML_ST_Upgrade_Display_Strings_Scan_Notices_has_run":true,"WPML_ST_Upgrade_MO_Scanning_3_has_run":true,"WPML_ST_Upgrade_DB_String_Name_Index_2_has_run":true,"WPML_ST_Upgrade_DB_Longtext_String_Value_has_run":true,"strings_per_page":10,"icl_st_auto_reg":"disable","strings_language":"en","translated-users":[],"sw":[],"plugin_localization_domains":{"wpml-string-translation\/plugin.php":{"wpml-string-translation":268},"js_composer\/js_composer.php":{"js_composer":1653},"contact-form-7\/wp-contact-form-7.php":{"contact-form-7":31},"mpc-massive\/mpc-massive.php":{"mpc":278},"akismet\/akismet.php":{"akismet":21},"redux-framework\/redux-framework.php":{"redux-framework":17},"duplicate-page\/duplicatepage.php":{"duplicate-page":8},"essential-grid\/essential-grid.php":{"essential-grid":23},"sitepress-multilingual-cms\/sitepress.php":{"installer":5,"sitepress":1247},"wpml-translation-management\/plugin.php":{"wpml-translation-management":812},"wpml-media-translation\/plugin.php":{"wpml-media":123},"wpml-cms-nav\/plugin.php":{"wpml-cms-nav":63}},"use_header_text_domains_when_missing":"1","theme_localization_domains":{"mf":{"mf":658}}},"ajx_health_checked":true,"default_categories":{"it":"1","en":252},"default_language":"it","setup_wizard_step":5,"translation-management":{"custom_fields_translation":{"title":2,"description":2,"keywords":2,"_edit_last":0,"_edit_lock":0,"_wp_page_template":0,"_wp_attachment_metadata":0,"original_post_id":0,"_wpml_original_post_id":0,"_wp_old_slug":0,"_icl_translator_note":0,"_alp_processed":0,"_pingme":0,"_encloseme":0,"_icl_lang_duplicate_of":0,"_thumbnail_id":0,"_wp_attached_file":0,"_wp_attachment_image_alt":2,"_vc_post_settings":0,"_wpml_media_duplicate":1,"_wpml_media_featured":1,"_cms_nav_minihome":1,"_cms_nav_section":2,"_top_nav_excluded":1},"custom_fields_readonly_config":["title","description","keywords","_edit_last","_edit_lock","_wp_page_template","_wp_attachment_metadata","original_post_id","_wpml_original_post_id","_wp_old_slug","_icl_translator_note","_alp_processed","_pingme","_encloseme","_icl_lang_duplicate_of","_thumbnail_id","_wp_attached_file","_wp_attachment_image_alt","_vc_post_settings"],"custom_fields_translation_custom":[],"custom_fields_translation_custom_readonly":[],"doc_translation_method":"1","__custom_types_readonly_config_prev":[],"custom_types_readonly_config":[],"__custom_fields_readonly_config_prev":["_vc_post_settings"],"__custom_term_fields_readonly_config_prev":[],"custom_term_fields_readonly_config":[],"taxonomies_readonly_config":{"translation_priority":1},"custom-types_readonly_config":{"vc_grid_item":1,"attachment":1},"notification":{"new-job":1,"include_xliff":0,"completed_frequency":3,"completed":1,"resigned":1,"overdue":2,"overdue_offset":7,"dashboard":true,"purge-old":7}},"custom-types_sync_option":{"attachment":1,"vc_grid_item":1},"language_selector_initialized":1,"languages_order":["en","it"],"dont_show_help_admin_notice":true,"setup_complete":1,"site_does_not_use_icl":true,"admin_text_3_2_migration_complete_40cd750bba9870f18aada2478b24840a":true,"admin_text_3_2_migration_complete_881c5f7067ee1b3908c9403a99e212b4":true,"xliff_newlines":1,"tm_xliff_version":"12","doc_translation_method":"1","hide_how_to_translate":false,"translation_memory":"1","WPML_Translate_Link_Target_Global_State":true,"translation_service":false,"translator_choice":false,"icl_lang_status":false,"icl_html_status":false,"icl_current_session":false,"last_icl_reminder_fetch":false,"translators_management_info":false,"language_pairs":false,"icl_translation_projects":{"2e8cd43149e41bf9cea849227e6da3e0":{"id":7577,"access_key":"dd22adab79cc726e23e2e6d2fe4d0792b336905f3153421d33fec9bd1ff9fd2c","ts_id":null,"ts_access_key":null,"extra_fields":[]}},"theme_localization_load_textdomain":"0","gettext_theme_domain_name":""}}}

September 10, 2018 at 6:38 pm #2721142

robertoC-44

In the first solution on the other thread, the support suggest to copy the xml file from the hidden link but I didn't found it so I have create this xml, but I don't Know if it is correct. I put it into the js_composer folder

<wpml-config>
<shortcodes>
<shortcode>
<tag>vc_column_text</tag>
</shortcode>
<shortcode>
<tag>vc_text_separator</tag>
<attributes>
<attribute>title</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>vc_message</tag>
</shortcode>
<shortcode>
<tag>vc_toggle</tag>
<attributes>
<attribute>title</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>vc_tta_section</tag>
<attributes>
<attribute>title</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>vc_custom_heading</tag>
<attributes>
<attribute>text</attribute>
</attributes>
</shortcode>
<shortcode>
<tag encoding="base64">vc_raw_html</tag>
</shortcode>
<shortcode>
<tag>vc_progress_bar</tag>
<attributes>
<attribute>title</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>vc_pie</tag>
<attributes>
<attribute>title</attribute>
<attribute>label_value</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>vc_round_chart</tag>
<attributes>
<attribute>title</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>vc_btn</tag>
<attributes>
<attribute>title</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>vc_cta</tag>
<attributes>
<attribute>h2</attribute>
<attribute>h4</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>vc_line_chart</tag>
<attributes>
<attribute>title</attribute>
</attributes>
</shortcode>
</shortcodes>
</wpml-config>

September 11, 2018 at 7:41 am #2722726

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

For further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 12, 2018 at 6:14 am #2726151

robertoC-44

Hi,
Ok... could you mail me to the address simona.moccia86@gmail.com so I’ll Give you the credentials?
Thank you

September 12, 2018 at 11:03 am #2727224

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have sent you an email so that you can provide me credentials there. Thanks

September 12, 2018 at 11:23 am #2727240

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks I received the logins on email. FTP is not working, username or password is incorrect, please recheck.

Also please disable IP restriction for FTP so that I can login.

September 14, 2018 at 10:36 am #2735058

robertoC-44

Hi!
The credential for ftp are correct. I’ve removed the ftp restriction

Thank you

September 14, 2018 at 5:45 pm #2736345

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks FTP is working now. I have some solutions that I will try out for this issue and will update you. If nothing works at the end I will have to escalate this issue to our 2nd tier support. I will get back to you with my findings.

Thanks

September 14, 2018 at 7:15 pm #2736555

robertoC-44

Ok thank you! I hope you will fix the issue!