This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 2 voices.

Last updated by Daniel Faessler 12 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 12, 2018 at 9:45 am

Daniel Faessler

Hello!

Yesterday we migrated the develepment site to production. Hence, the URL changed from hidden link to hidden link.

But we encounter a very strange behaviour of the translation management (please see screenshots for more explications).

Furthermore I refer to my other ticket which most probably already has been resolved, but still is under investigation by our side, because of the recent site migration (we still check if everything is working fine).

1> translationeditor.jpg:
Shows translation from german to italian.
green marked (fusion_button_link): url seem correctly translated
red marked: (field fusion_text: content) left column still shows 'hidden link' in the url.
---> So it seems that there is still an url pointing to the development site.

2> fusionbuilder-german.jpg:
The very same page shows in fusion builder, that the above false url is in fact correct, showing hidden link).
---> In contrary to above, the url is correct, when page is opened in fusion builder.

3> fusionbuilder-italian.jpg:
After WP overall language change (the flag right on top of the page), the italian translated version shows the fusion_button_link as "/publikationen-2/info-flyer-epilepsie/".
---> In contrary to above (1>), the url is erroneous, when translated page is opened in fusion builder.

---> So it seems, that there is quite a confusion in WPML about what is already translated and about the overall status of translation. <---

4> translationeditor-url.jpg:
Shows the url which brings up the translationeditor from above (1>).

We managed to finalize the translation in using only fusion builder for the italian page and avoiding translation editor. But in the future, we have to have a reliable translation system.

I assume there is a 'caching'-problem in the translation queue or something like this.
The translation editor clearly does not show the content of the actual page neither in the left column (german) nor in the right column (italian).

Is there a way to 'reset' translation editor and 'flush out' the clearly outdated content?
What do you suggest?

Thank you very much and kind regards, Daniel

September 14, 2018 at 2:59 am #2733581

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Back up your site first, before making any change, this is for security reasons.
- Update all outdated plugins and Avada's Fusion Patch.
- Flush all cache memory.
- Go to WPML -> Support -> Troubleshooting link -> Click on 'Clear the cache in WPML' button.
- Go to Settings -> Permalinks -> Re-save the permalink structure.
- Edit a page -> Make a small change -> Save it -> Translate the page.

If the issue persists then I recommend you to install a plugin like etter Search Replace (https://wordpress.org/plugins/better-search-replace/) and try to replace the old URL with the new one.

Could you tell me the result of the steps above?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 14, 2018 at 9:24 am #2734765

Daniel Faessler

Hello Carlos

Thank you for your information.

That's what happened on my side:
> Memory Limit is already 1GB, so I did *not* change anything in wp-config.

> I already did use search replace from dev.epi.ch to hidden link when we migrated the website.
> I repeated search today after "dev.epi.ch" in Better Search Replace with no hits in any of the *_icl_* tables.

Then according to your recommendations:
> Updated everything to their latest release

> Flushed browser cache (we don't use caching plugin).
--> If you have recommendations how to flush cache on WP without caching plugin, please let me know.

> Clicked on 'Clear the cache in WPML'
Furthermore, clicked 'Delete Ghost-Entries from Translationtables' (or so - my installation is german...)

> Re-Saved Permalinks

> Edited the page where the screenshots from my first mail were

Those are the results:
> Content which is shown correctly on public page (italian) shows in translation editor as 'not translated' with their german original text.
--> See screenshots
wpml-public-page-translated.jpg
wpml-translationeditor-page-not-translated.jpg

> Content which is only once in german original shows twice in translation editor (once translated [but not as marked as] and once as not translated with its german original text).
--> See screenshots
wpml-redundant-fields-first-translated.jpg
wpml-redundant-fields-second-not-translated.jpg
wpml-redundant-fields-original-only-once.jpg

Since here clearly is something broken, I did not save the translation, because I did not want to risk corruption or false information on public page.

I think that something in the translation queue is stuck and should be flushed out.

Thank you very much for checking on this and kind regards, Daniel

September 14, 2018 at 6:05 pm #2736395

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Daniel,
Thank you very much for your message.

I would like to ask your authorization to make a copy of the site in order to make further tests in a local environment without affecting the live site.

Looking forward to your answer.
Best regards,
Carlos

September 14, 2018 at 7:00 pm #2736538

Daniel Faessler

Hello Carlos

Yeah, just go ahead.

I indicated credentials link and to backup-file in my initial post.
Duplicator plugin is installed. Should you need to produce another backup, just activate it and do whatever you have to do.

Highly appreciated. 🙂

Just let me know what I can do on my side to proceed in this matter.

Kind regards and thank you very much indeed, Daniel

September 14, 2018 at 7:14 pm #2736542

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Daniel,
Thank you very much for your authorizaiton.

I just downloaded the Duplicator package that was already created. I will run some tests in local and try to reproduce the issue. If needed I will create another Duplicator package.

I will get back to you as soon as I have an answer.
Best regards,
Carlos

September 17, 2018 at 4:14 pm #2741787

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Daniel,

I would like to ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Edit the page of the screenshots -> Copy the page ID from the URL (in this case it is 2966).
- Go to WPML -> Packages -> Delete the package with the same ID.
- Translate the page again.

Could you tell me if the issue persists for that page?

Regards,
Carlos

September 19, 2018 at 9:47 am #2748113

Daniel Faessler

Hello Carlos

Thank you for your message.

I followed your instructions:
> deleted the package 2966 from WPML -> Packages

Unfortunately, problem persists and I got following detailed results:
> In entering WPML translator for this page, I get some warning messages
'Warning: Invalid argument supplied for foreach() in [...]class-wp-list-util.php on line 163'
--> 01-error-msg.jpg
IMPORTANT: I get those warning messages in entering all translations (not only italian, but as well french and english...)
> WPML translator still shows not translated fields
--> 02-not-translated-again.jpg
> where the public page is showing translated content
--> 02-public-page-translated.jpg
> WPML translator shows old, not yet translated URL
--> 03-not-translated-url-in-content.jpg
> where the content in normal editor shows correct data
--> 03-content-as-is-in-editor.jpg

So in short:
I don't think deleting the package 2966 did anything to solve the situation, but it generates now 14 warning messages (probably has to do with the total 15 fields to translate, and perhaps the first field doesn't generate an error).

There must be another db table or location, where the outdated information is stored. Perhaps to delete package is not enough?

Thank you for digging deeper in this strange situation and kind regards, Daniel

September 19, 2018 at 10:05 am #2748205

Daniel Faessler

Hello Carlos

Meanwhile I restored the database to its state before the deletion of package 2966.

Following additional observations:
> No warning messages anymore in WPML translation editor

> after deletion of package 2966 WPML translation editor showed only simple textfield even for the longer inputs
--> 04-after-delete-only-textfields.jpg

> after database restore, WPML translation editor shows textareas for the longer inputs again
--> 04-after-delete-only-textfields.jpg

Thanks and kind regards, Daniel

September 19, 2018 at 5:57 pm #2749734

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Daniel,
Thank you very much for your feedback.

I would like to ask you to follow this steps:
- Export the database of the live site -> Open the sql file with a code editor -> Search and replace 'dev.epi.ch' with 'epi.ch' -> Save the the changes -> Import the sql file with this changes.

Does the issue persists?

Note: I suspect that what caused the issue was the migration process and not WPML.

Regards,
Carlos

September 19, 2018 at 8:28 pm #2749954

Daniel Faessler

Hello Carlos

Thank you for your information.

This problem did already exist in the development site (hidden link).
Or at least some kind of a problem. Because the translation editor of very same page (2966) for italian does not show all fields of the german original.

In the italian translation editor all fields after 'Crisi epilettica' are not showed, and the URL in the same textarea field is clearly wrong.

Please have a look at the provided screenshots.

So there was clearly already a messed-up situation already in the development site (outdated content in translation editor and not all german content showed for translation although it already is showing correctly in public page).

Please let me know how to private msg you - I'll send you credentials for dev.epi.ch.

Thank you very much and kind regards, Daniel

September 19, 2018 at 10:44 pm #2750158

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Daniel,
Thank you very much for your message.

If the issue exists in the dev site only in the page 2966, then I recommend you to re-create the page and see if the issue persists. Maybe some information was lost during the saving process in the database or some of the shortcodes lost part of it info and that's why the Translation Editor is having this strage behavior.

I have set your next answer private so you can provide the credentials in a secure way.

Looking forward to your answer.
Best regards,
Carlos

September 20, 2018 at 5:52 am
September 20, 2018 at 5:17 pm #2752883

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Daniel,

I applied this steps in the test site and in the page 2966 the issue seems that disappeared, however I'm not 100% sure, could you double check it?
- Deactivated WP Optimize (I suspect this 'optimizations' might be causing some issues).
- WPML -> Themes and plugins localization -> Scann the themes and plugins related to the content.
- WPML -> Support -> Troubleshooting link -> I applied this trobuleshooting options (buttons):
-- Clear the cache in WPML
-- Remove ghost entries from the translation tables
-- Fix element_type collation
-- Assign translation status to duplicated content
-- Set language information
-- Fix terms count
-- Fix post type assignment for translations
-- Recreate ST DB cache tables
- Edit the 2966 page in German (original language) -> Made a small change -> Save it -> Translated it again.

I would like to ask you to apply this steps in the live site, but before, please create a full backup of the site for security reasons.

Could you tell me if the steps above solved the issue?

Regards,
Carlos

September 22, 2018 at 10:08 am #2757258

Daniel Faessler

Dear Carlos

Thank you very much for your information and the description of the steps you took.

Before I did anything on productive site, I checked the content of the site you worked on (dev.epi.ch).

The comparison between the content of the productive site vs. development site you worked on with specific URLs:
hidden link
and
hidden link

> productive still shows correct translation on public page
20-www.site-all-correct.png
> development site shows outdated content on public page
21-dev.site-content.outdated.png

So the correct content was replaced by your steps on development site with outdated content.

To know when the correct content has been replaced, I checked the revision history of 2966 (development site).

There were two revisions since last edit from our side (Sept 3rd, 16:11:31):
The last revision only was the fusion containers from 'open' to 'closed' and had no effect on the content.

But during the second last revision, the once correct content has been replaced by the outdated content.
> 22-revision-history-first-change-by-wpml-support.png
shows that the title changed from correct 'Informazioni in albanese e portoghese' to the outdated 'Informationen auf Albanisch und Portugiesisch'.
> 23-revision-history-first-change-by-wpml-support.png
shows that in the same revision, the button labels changed from 'albanese' to 'Albanisch' and from 'portoghese' to 'Portugiesisch'.

So as a conclusion on development site after your steps, it may be that the translation editor now shows 'correct' content ready for translation.
But to achieve this, the already translated parts have been lost, and the content is now outdated in both editors (translation editor and fusion editor).

This is surely not what we have in mind.
We don't want to lose all the correct translations and taking the risk of having to check every page to look if there is bigger or smaller fallback to old content.

What do you suggest?

Thank you very much for everything and kind regards, Daniel