This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 1 year, 5 months ago.

Assigned support staff: Itamar.

Author Posts
May 1, 2018 at 5:35 pm #1916125

samuelD-3

Tell us what you are trying to do?
We could see that we cannot display new contents in the main language to the translated pages.
On freshly updated wmpl + Xpro (may 1st) we seee that it is a bug from wpml and the last updates does not fix ( maybe yes ? )

So the other option and question is. if we want do activate the manual translation on wpml settings, how we can do in order to keep all the already translated pages ?

Is there any documentation that you are following?
yes https://wpml.org/errata/translation-editor-strings-ignored-after-editing-the-translated-post-in-wordpress-native-editor/

Is there a similar example that we can see?

What is the link to your site? private

May 2, 2018 at 8:18 pm #1943081

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

As stated on the errata page this problem should be solved if your using the latest version of WPML. Are you using the latest version?
To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations.
We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

You ask: So the other option and question is. if we want do activate the manual translation on wpml settings, how we can do in order to keep all the already translated pages?

I'm not sure that I fully understand the question. In any case, to enable the manual translation, please go to WPML -> Translation Management -> Multilingual Content Setup and in the second section 'How to translate posts and page' choose 'Create translations manually'. Please see attached screenshot.

Regards,
Itamar.

May 10, 2018 at 4:10 pm #2076779

samuelD-3

We activate the automatic Editor. option2 in you screenshot, Use the translation editor. But now we want to go back to the Manual translations because of some bug in this system (some translations strings does not appear in the other languages, and this an official bug of wpml which has not be solved yet). So if we go back to the manual translations (option 1 in you screenshot) it will erase all the translated page correct ? so how to STOP the automatic translation edotir without loosing the translated page.

For evidence security of the project no debug will be provide, we need a real assistance please.

And yes we did all the updates of wmpl WPML Multilingual CMS 3.9.4 + Xpro theme

thanks for you help Itamar

May 10, 2018 at 7:40 pm #2078910

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

It is very important for me to understand the issue on your site before I answer your question because I do not want to give you the wrong answer.

In the beginning, you said that you have the problem that is described in the following errata page.
https://wpml.org/errata/translation-editor-strings-ignored-after-editing-the-translated-post-in-wordpress-native-editor/
But now you write: "...some translations strings does not appear in the other languages, and this an official bug of wpml which has not be solved yet..."
So because that you also say that you use the X pro theme, I think that maybe you are talking about this errata page.
https://wpml.org/errata/cornerstone-shortcodes-arent-rendered-in-the-translated-pages/
Is it correct?

By the way, if you share with me the debug information of your site only I (and my teammates) can see it, and it is not public.

Please note that I'll be able to continue debugging this issue on Sunday.

Thanks,
Itamar.

May 11, 2018 at 10:14 am #2085884

samuelD-3

Thanks Itamar for your details

Yes we are concern on this issue
https://wpml.org/forums/topic/translation-editor-strings-ignored-after-editing-the-traductions/

But we cannot wait the so long fix and we need to work on
My question is very simple :

What happen to all the current translated pages if we deactivate the Translation Editor and activate the manual ?
We need to go on as you may understand

Thanks in advance
Kindly

Sh. Shal. ; )

S.

May 13, 2018 at 4:05 pm #2106928

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

As a direct answer to your question, I would answer that as long that the only thing that you do is switch the option 'Use the translation editor to the option 'Create translations manually' nothing will happen your translations will be saved and shown on the front-end.

But I'm guessing that you want to continue to edit your Cornerstone pages. So if this is true, then you might have a problem to continue editing your existing pages after that you switch to the 'Create translations manually' option. I say that because I've tried it now on our Pro theme test site. I've tried it with the Pro theme version 1.1.0 and the Cornerstone Page Builder version 3.0.4. When I wanted to edit the translated page with the Cornerstone Page Builder, a message poped-up saying that editing with the content builder will replace the current content. Please see attached screenshot hold-up.jpg. If I try to continue and press the 'Yes, proceed' button then I get a message saying that there is a conflict on the front end and that prevented the preview from loading. Please see attached screenshot a-conflict.jpg. However, you might be able to continue editing your content in the regular "text' view. Please see attached screenshot shortcode-view.jpg. But I guess that this will be very hard to implement especially if you want to add new Cornerstone elements because then you will need to add their shortcodes.

I hope that the above answers your question.

Best Regards,
Itamar.

The topic ‘[Closed] translation editor strings ignored after editing the traductions’ is closed to new replies.