This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 year ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 27, 2018 at 10:58 am #2770217

adamM-30

I am trying to: translate page created with Elementor, using standard translation editor and specifically in the instance of translating content of Elementor Icon Box widget, the translation editor wraps translated content in <p><p/>(cannot chose "no tag") tags what cancels Elementor styling on the translated page.

Other widgets do not seem to have this problem, or maybe I have not used others where this is happening.
I do not know whether this is an issue that Elementor is supposed to solve or you.

You can see in the screenshot what I mean. This is the translated page. <p> tags are added for description and it changes styling. In the bottom widget, I deleted <p> tags and it jumps back to correct styling, but every time I update styling in Translation Editor, it adds the <p> tags and messes it up again.

September 28, 2018 at 12:06 pm #2773678

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please follow the below steps and let me know if this helps:

1. Backup your site

2. Open this file with a text or code editor.
/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/class-wpml-elementor-translatable-nodes.php

3. Go to line 390 and change VISUAL to AREA.

'editor_type' => 'VISUAL'

To:

'editor_type' => 'AREA'

4. Update the page and the translation and check if it is working.

Look forward to your reply.

Thanks

September 29, 2018 at 4:41 pm #2775721

adamM-30

Nope, it still wraps it in <p>.

I tried changing the settings you suggested and I think I also can achieve the same thing you suggest by turning off Visual editor in "Your Profile" in WP admin.

I think the issue is with double tagging in <p>. Elementor widgets automatically tag "Description" content areas in <p> and it is done again during translation.

Is there a way to translate pages another way than in Standard Translation Editor? So that I just duplicate them and translate what needs to be translated in the duplicated page in the Elementor editor.

October 1, 2018 at 2:42 am #2777079

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You can use the manual editor but I recommend you to use Standard translation editor itself. Could you please provide login details again so I can debug this issue further.

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

The topic ‘[Closed] Translation Editor wraps txt in and messes up Elementor styling’ is closed to new replies.