This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Earlier, the body part was shown as single modules like heading, text, ... Now, it only shows body and the entire HTML code. This makes it quite difficult for a non-technical person to do all the translations.

Solution: The cause of this issue was a mising column in a table in the database. Please follow the steps described in this link to fix the issue: https://wpml.org/forums/topic/database-error-wordpress-unknown-column-word_count-in-field-list/

Relevant Documentation:

0% of people find this useful.

This topic contains 12 replies, has 2 voices.

Last updated by Carlos Rojas 5 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 3, 2019 at 12:55 pm

florianM-19

hidden link
The translation pages do not show the theme fields / modules anymore..

Please take a look at the HOME page: hidden link

Earlier, the body part was shown as single modules like heading, text, ... Now, it only shows body and the entire HTML code. This makes it quite difficult for a non-technical person to do all the translations.

We never had any code in the translation fields of WPML before. Now, we have a lot of code in the fields: hidden link

Do you understand what I mean? The interpretation of the page builder fields in WPML translations has changed. Before, each page builder module got a separate field - without any HTML code. Now, we have fields like "body" (Home page), in which, nearly the entire page content gets shown, including all the HTML code. We also have other fields that show HTML code now. That was never the case before.

Many modules / content of the website will not be shown at all. I've created a Test page. For this Test page, it doesn't show any heading or text. It just shows the title of the page.

Conetnt of Test page: hidden link

Translation fields of Test page: hidden link

Thanks
Florian

May 3, 2019 at 7:59 pm #3737715

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I have applied some troubelshooting options in the site and added the language configuration XML in WPML -> Settings -> Custom XML Configuration tab.

Please edit one of the pages where the issue is present and make a small change -> Save the changes -> Translate the page or update the translation.

Could you tell me if the issue persists?

Kind regards,
Carlos

May 6, 2019 at 2:56 pm #3750197

florianM-19

Hi Carlos,

Thanks for your reply.
I've edited 2 pages, the pages "Test" and "Home".
After some small changes, I saved the 2 pages and checked the translations - nothing changed. Some modules are still missing completely, for others I get an HTML code in the tarnslation fields.

Please feel free to check things like that yourself to speed up the fixing process. With the page "Test" you can do whatever you want.

Cheers Florian

May 6, 2019 at 5:34 pm
May 8, 2019 at 6:13 am #3764001

florianM-19

Hi Carlos,

Thanks for your reply.
I have started the migrating process.

Cheers Florian

May 8, 2019 at 12:13 pm #3766485

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Florian,
Thank you very much for keeping me updated.

Please let me know when the migration is finished.

Regards,
Carlos

May 8, 2019 at 12:26 pm #3766555

florianM-19

Hi Carlos,

it has been finished. 🙂

Cheers Florian

May 8, 2019 at 4:55 pm #3769351

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Florian,
Thank you very much for keeping me updated.

I took a deeper look at the migrated site and I found the cause of the issue. The cause of this issue was a mising column in a table in the database. Please follow the steps described in this link to fix the issue: https://wpml.org/forums/topic/database-error-wordpress-unknown-column-word_count-in-field-list/

You can see the issue solved already in the test site.

Best regards,
Carlos

May 9, 2019 at 5:32 am #3773177

florianM-19

Hi Carlos,

Thanks for your reply.
I found the table but I don't really know how to insert that column. Can you please tell me how to do it exactly / which fields I have to fill with which values? hidden link. Otherwise, I'm also happy if you do it yourself.

Thanks a lot.

Cheers Florian

May 9, 2019 at 2:34 pm #3777159

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Florian,

After running several tests and troubleshooting the issue is solved in the live site 🙂

Could you confirm that the problem disappeared?

Regards,
Carlos

May 9, 2019 at 3:17 pm #3777635

florianM-19

Hi Carlos,

Thanks for your support.
The translations of the "Test" page look fine now. Thanks for that.

The other issue still persists. The "Home" page translation still has that body part where it shows all the html code of the page. Is it possible to only have the page builder modules there with plain text, no html code?

hidden link

Cheers Florian

May 9, 2019 at 10:48 pm #3779699

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Florian,

Now you can see all the fields in the Translation Editor. If you face this issue again, the solution is to make a few minor changes in the page in the original language -> Save the changes to refresh the entry in the database for that page -> Update the translation.

Regards,
Carlos

May 10, 2019 at 5:33 am #3781495

florianM-19

Dear Carlos,

Thanks a lot for solving this problem for us. Great support, great patience. 🙂
Have a good day!

Cheers Florian

May 10, 2019 at 10:36 am #3783343

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Florian,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos