Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.14 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 2 voices.

Last updated by julianZ-4 3 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 15, 2019 at 3:42 pm #4402269

julianZ-4

I am trying to: Translate the author description on my website. With one author, it does not work: hidden link, I can translate all the other authors on "String Translation" page without any problem.

I tried to click on save, I tried other descriptions, I made the translation partial. Nothing worked. Then I deleted this specific String. Now I can not find it again.

Can you please tell me how to get this author description string back again under "String Translation" page? I've searched your forums, but only found solutions for themes and plugins, but not for WordPress strings.

August 15, 2019 at 7:08 pm #4403141

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It all depends on where and how these author descriptions are being entered. If it is using the native WordPress author info feature, then you can go to your WordPress Dashboard > Users > User Profile and save it again in order to make it available in the String Translation. Please, let me know if it helps, have a nice day.

August 16, 2019 at 6:54 am #4404939

julianZ-4

Thanks Marcos.

I did save that user profile again (it's a translation from there, you are correct). But it did not work:

Working example: hidden link

Not working example (where I saved the user profile again): hidden link (The string translation "description_xy" is missing)

August 16, 2019 at 2:40 pm #4407003

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 16, 2019 at 2:48 pm #4407109

julianZ-4

Hi Marcos

Thank you for your reply.

Can you please allow me to make a Cloudways on your servers because I don't want to give access to my live site? That would be great.

Best regards

Julian

August 16, 2019 at 7:59 pm #4408025

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

August 17, 2019 at 8:05 am #4409571

julianZ-4

Hi Marcos

Thanks a lot - the migration is complete. I just checked: Both problems are persistent on the test-system as well.

August 20, 2019 at 1:16 am #4419607

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Julian,

Thank you for the provided details. I notice the strings are back for translations with the steps below:

1 - In your WordPress Dashboard > WPML > Strings Trabslation click the 'More Options' box and mark the 'Author' option. see attached screenshot (customer_screen_03).

2 - Now, in your WordPress Dashboard > WPML > Theme and plugin localizations click to scan your theme strings again.

3 - Back in your WordPress Dashboard > WPML > Strings Translation your should see the author description available again for translations under the 'Authors' text domain.

Unfortunately these steps are not enough to make your strings to appear translated in your website frontend, and here the reason seems to be your theme as it appears properly translated when using a default WordPress theme as you can confirm in the provided screenshots (customer_screen_01 and customer_screen_02).

You said it appears translated, can you please confirm if you see the other author descriptions appearing translated in your website frontend? Please, let me so we can proceed with a theme compatibility test.

Thank you for your collaboration and patience, have a nice day.

August 20, 2019 at 7:03 am #4420961

julianZ-4

Hi Marcos

I could resolve it by doing your 1)

I think the problem was that I put this user as "author", which was not "translatable" (instead of admin, he was before).

Best regards

Julian