This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by valerijaC 1 month ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 4, 2019 at 6:49 pm #4513647

valerijaC

The problem we solved with the translation of homepage again came up. When I edit the English Homepage using Elementor in the fronted, titles and part of the text on english page go back to the serbian language. When I again do the translation everything is ok until I make new changes on homepage. And so constantly.
Support advice me next steps
) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

i followed those steps and everything was ok until today when all encountered the same problem

September 4, 2019 at 9:13 pm #4514103

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 5, 2019 at 2:44 pm #4520243

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above, thanks.

September 5, 2019 at 3:56 pm #4520649

valerijaC

Dear Marcos,
migration is started.
Thanks,
Valerija

September 6, 2019 at 8:21 pm #4527285

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I am jumping here to let you know I will need some extra hours to fully investigate this issue and provide you with a detailed reply. Thank you for your understanding and patience, have a nice day.

September 9, 2019 at 7:46 pm #4539975

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Valerija,

Thank you for your patience while waiting for a solution. I performed some more tests in your website using the migrated copy and noticed your theme is using some custom Elementor modules, the issue only happens for the theme specific modules which seems to be due a compatibility issue between these theme speficic modules and WPML. In order to confirm it, we need to perform a compatibility test in these case, these are the procedures:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

September 9, 2019 at 8:24 pm #4540091

valerijaC

Hi! I install theme but i need access to dashboard to adjust homepage.

September 9, 2019 at 10:01 pm #4540305

valerijaC

Hi! I update wpml and some content is gone from my homepage. What is happening?

September 10, 2019 at 12:42 am #4540603

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Let's proceed one step at a time, at first you are able to login to our test sandbox environment with this one click url: hidden link please, proceed according my instructions above so we can confirm the compatibility issue and then we can investigate what's happening in your particular case. Thank you for your continued patience and collaboration, have a nice day.

September 13, 2019 at 5:44 am #4565733

valerijaC

I send my website for testing used migrated copy and i still wait for answer

September 13, 2019 at 8:44 pm #4570739

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I performed a detailed investigation using a clean sandbox installation and indeed the issue of your translations being replaced with default language content only happens for your custom Elementor modules bundled with your theme.

There's a compatibility issue between these custom modules and WPML itself, your theme is not listed as compatible at: https://wpml.org/documentation/theme-compatibility/?wpv_view_count=112654&dev%5B%5D=0&wpv-theme-category=0&wpv_post_search=Exhibz&wpv_filter_submit=Search.

I forwarded this ticket to our compatibility team so they can ask the author to collaborate and make his theme fully WPML compatibile, you can also get in touch with the theme author and ask them for any existing workaround.

He can refer to: https://wpml.org/documentation/plugins-compatibility/elementor/how-to-add-wpml-support-to-custom-elementor-widgets/ in order to learn more on how to make the theme custom Elementor modules WPML ready.

I will update you here as soon as I get some more details from our compatibility team, once again I would like to remember you the author needs to cooperate with that as is not WPML the culprit here.

As regarding your additional issue I would kindly ask you to open a new ticket for that so we can deal spefically with one ticket per issue and make our customer's efforts easier when they search for solution on a topic basis.

Thank you very much for your continued patience and understanding, have a nice day.

September 17, 2019 at 7:58 pm #4590915

valerijaC

My issue is resolved now. Thank you!