Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Mateus Getulio 1 month, 2 weeks ago.

Assigned support staff: Mateus Getulio.

Author Posts
July 12, 2021 at 9:07 pm #9180881

rokP-2

Tell us what you are trying to do?
I am trying to translate a few pages and products but translation is in progress for days.

Is there any documentation that you are following?
I checked your forum, I increased the memory limit and everything, no caching plugin, still does not work.

Is there a similar example that we can see?
Dont know...

What is the link to your site?
hidden link

tinprogress.jpg
July 12, 2021 at 9:19 pm #9180923

rokP-2

P.S. Did also the following:
Translation Management -> translation roles -> I am the user.
Log on / off does not help
WPML > Settings > How to translate posts and pages > press the button next to the Advanced Translation Editor option ("Sync translation jobs and translators")
o to one of the pages that has a stuck translation and modify the original page (maybe add a character to the title) and save it.

Didn't help.

July 13, 2021 at 4:35 pm #9188689

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Welcome to the WPML support forum. I'll be glad to help you!

When the page state is 'Translation in Progress', it means that the translation hasn't finished (don't reach a 100% status on the Translation Editor), or the page in the original language was updated. Could you tell me if one of these events happened to the mentioned pages?

Regardless, let's try a possible solution for this. Just follow these steps, please:

- Go to WPML -> Translation Management -> Translation Jobs
- In this screen, search for one of the problematic pages and cancel it
- Now please resend it to translation through the Translation Management section
- Open it through the Translation Editor, and make sure to complete all the translation, until it reaches the 100% status

If the issue remains or you have already tried that, then we might be facing an interaction issue with a third-party functionality, in this case:

- Deactivate all the plugins that are not related to WPML
- Switch for a moment to a WordPress default theme like Twenty Twenty-one
- If the issue is gone, activate one by one to see with which one there is an interaction issue

Let us know the results of this investigation. We're looking forward to your reply.

Best regards,
Mateus.

July 13, 2021 at 7:29 pm #9189875

rokP-2

Thank you for all your guidence, but it did not help.
I use a woodmart theme that should be fully compatibile.
I actually do not have any additional plugins, but nevertheless I have disabled almost everything.
The translation job cancel and restarting it by editing it and pressing done does not help..
Gonna try disabling the theme..

Does it something to do with woocommerce products?
But on the other hand, i have translated the homepage and it is also still ''in progress'' for days.
Would you care to take a look onto my site administration yourself?

woo_products.jpg
July 13, 2021 at 7:49 pm #9189915

rokP-2

UPDATE: Change of theme does not help.

July 13, 2021 at 8:47 pm #9190103

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 14, 2021 at 9:02 pm #9199337

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I checked this out but so far I couldn't find a fix for it.

I asked my colleagues to have a look at this issue in order to see if there's anything I'm missing.

I'll come back here as soon as one of my colleagues reply back to me (which it shouldn't take long).

Thanks,
Mateus.

July 15, 2021 at 1:39 pm #9210157

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Please, take a look at my previous private reply and let me know when the replication process is done. Thanks.

July 22, 2021 at 10:27 am #9251721

rokP-2

Hi, wordking on it right now....

July 22, 2021 at 10:36 am #9251841

rokP-2

I have made everything you asked from me in a previous private reply. The replication process is done... Thank you.

July 22, 2021 at 9:45 pm #9256393

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for replicating the issue, but unfortunately, we have a deadline expiration for our sandboxes, which is exactly one week.

Since we've already exceeded this time, the sandbox can't be accessed now. I'm providing you with a new one in my next private reply. Please make sure to replicate it before the expiration of one week.

Thanks for understanding,
Mateus.

July 27, 2021 at 8:45 am #9277829

rokP-2

Done with the replication process.

July 28, 2021 at 12:47 pm #9299527

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I have escalated this ticket to our 2nd tier of support where our 2nd tier specialists will take a deeper look at this issue and will try to find a solution.

I will get back to you as soon as I get an answer from them.

Best regards,
Mateus

July 30, 2021 at 1:12 pm #9316137

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your patience while we investigate the problem.

It seems a known issue, involving the Woodmart theme. The authors have been already contacted, and they fixed it in the latest version.

We have updated the theme in a copy version of your website hosted on our servers, and this solved the error with incomplete translations. Could you please try to do the same on the live website to see if this gets corrected? Just follow these steps:

**IMPORTANT** - Please make a backup of the site files and database before doing the following procedure

- Inside your wp-admin please go to Dashboard -> Updates
- Then click on the "Check again" button
- Update the Woodmart theme

It should work now. Give it a try and see if the problem persists. Let us know, please.

Thank you,
Mateus.