This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.57 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am using the "Quickcash" theme together with the "ThemeREX Addons" plugin and I am unable to translate the button in the header.

Solution: https://wpml.org/forums/topic/translation-in-the-layouts-is-not-working/#post-4209433 Relevant Documentation:

This topic contains 13 replies, has 2 voices.

Last updated by srdjanD 3 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 2, 2019 at 10:15 am

srdjanD

I am trying to:
Translate the wp layout used in the header.

Link to a page where the issue can be seen:
All pages

I expected to see:
kredi başvurusu

Instead, I got:
Demande de credit

July 2, 2019 at 10:35 am #4125751

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

The way to translate those strings really depends on how they have been implemented in the code.

1. Can you please let me know if you tried to go to WPML > String Translation and search for any of the words in those sentences?

Here is some very helpful documentation on how to use the String Translation plugin:
https://wpml.org/documentation/getting-started-guide/string-translation/

If it's not there, it could help if you scan the plugin/theme that's generating the strings and then go back to WPML > String Translation and see if the strings show up:
https://wpml.org/documentation/getting-started-guide/theme-localization/

2. If you can't find it inside the WPML > String Translation, it might be added as admin text.

This should be the normal process to translate admin texts:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

If you still can't find it, please let me know and I would be very happy to take a look, too but in order to do that, I will need you to give me Administrator access - I logged in with the credentials you provided and it seems that I don't have access to anything in the backend.

Let me know how it goes.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 2, 2019 at 11:50 am #4126497

srdjanD

Thanks Mihai,

I've just added you admin rights...

July 2, 2019 at 3:38 pm #4128485

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

From what I can see, the WPML String Translation plugin is not installed:
https://wpml.org/documentation/getting-started-guide/string-translation/

Can you please install it and then try to follow the steps I mentioned here:
https://wpml.org/forums/topic/translation-in-the-layouts-is-not-working/#post-4125751

Please let me know how that goes.

I will be waiting for your response.

Kind regards,
Mihai

July 3, 2019 at 8:59 am #4133627

srdjanD

Sorry, but I am unable to locate that string from layouts... Any help?

July 3, 2019 at 11:20 am #4135389

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the information.

From what I can see, that functionality (the Layouts one) is added by the "ThemeREX Addons" plugin.

I was not able to find this plugin as being part of our official WPML-compatible plugins list here (https://wpml.org/documentation/plugins-compatibility/) so that means there might be compatibility issues happening.

It is not a rule that if a plugin is not part of our repository, it's not compatible with WPML but the ones that have not been tested by our team yet sometimes have compatibility issues.

I created a completely new and clean sandbox environment for you here (one-click login):
hidden link

I will need you to go to that link, install the theme that you are using and the "themerex addons" plugin + any other plugin that might be needed for replicating the issue (WP Bakery for example) but our main purpose for this process is to install only the necessary plugins (not any extra plugins that are not needed for replicating the issue) and see if the issue is happening on our environment, too.

So I would simply need you to see if you can reproduce the same issue there (WPML plugins are already installed and only need to be setup the way you have them on your site).

If you are able to reproduce the issue on the sandbox, that's when I can forward this to our compatibility team and see if they can find a way to make it work.

Also, I'd suggest you contact the plugin authors and recommend them to join our 'Go Global' program (https://wpml.org/documentation/theme-compatibility/go-global-program/) where our Compatibility developers will help them make their plugin 100% compatible with WPML for free.

Please let me know how that goes.

I will be waiting for your response.

Kind regards,
Mihai

July 3, 2019 at 12:25 pm #4136193

srdjanD

Done... hidden link

I would recommend installing the demo data, where these elements are actually used in theme.

July 4, 2019 at 8:49 am #4141407

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the feedback.

What I would need you to do is this:

- set up WPML as it is set up on your site
- after you install the theme and/or plugins that need to be installed, I would need you to try to reproduce the same issue that you are experiencing on your current live site

I never worked with the theme that you are using nor with the "ThemeREX Addons" plugin so I would need you to recreate the header element and see if the issue is still happening here, on this clean install, too (again, please use just the theme and the "ThemeREX Addons" plugin + any other required plugin that ThemeREX needs to work with - if there's anything like this).

Please let me know when that is ready so that I can take a look and if the issue is still happening on our WP instance too, I will then forward this to our compatibility team.

Thank you for your understanding and I will be waiting for your response.

Kind regards,
Mihai

July 4, 2019 at 9:20 am #4141861

srdjanD

Did everything, as you've asked...

If you go to EN version of the page hidden link and look at the upper-right corner, the button has text: Loan Application (layout is here: hidden link)

For FR version of the site hidden link the text is the same as in EN, but it should be "Demande de crédit" as defined in layout (here: hidden link)

Let me know if you need more details...

July 4, 2019 at 3:38 pm #4145143

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

That's great.

I will take a look at it, too, and I will forward it to our Compatibility team if I can confirm that the same issue is happening there, too.

I will keep you updated as soon as I make a move on this.

I am also leaving the ticket assigned to myself for the moment.

Kind regards,
Mihai

July 5, 2019 at 2:15 pm #4152009

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

I can confirm the same issue is happening here from what I can see at the moment and I will forward this to our Compatibility department.

I will keep you updated as soon as I have more feedback on this (I will also leave this ticket assigned to myself for the moment).

Kind regards,
Mihai

July 8, 2019 at 7:55 am #4159651

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I escalated this issue to our Compatibility team already and I will now also set the status of the ticket here to "Escalated to Compatibility team".

I will keep you updated and will get back to you as soon as I have feedback from our team.

Kind regards,
Mihai

July 15, 2019 at 10:03 am #4209433

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you very much for your patience.

Our compatibility team found a solution for this:

1. Please add this code to WPML > Settings > XML Custom Configuration and then SAVE:

<wpml-config>
  <admin-texts>
    <key name="theme_mods_quickcash">
      <key name="header_style"/>
    </key>
  </admin-texts>
</wpml-config>

2. Now, in WPML > String Translation, you will find a string in the domain admin_texts_theme_mods_quickcash > [theme_mods_quickcash]header_style

It will be: header-custom-# (# is the number ID of the Layout in the default language)

translate it to header-custom-# (# is the number of the ID of the Layout in the secondary language)

You can find the id of the translated layout by switching the flag at the top in the backend to French, then go to Layouts > hover your mouse over the "Edit" link and at the bottom-left of the page, you will see a link that at some point contains a number (it might be formed out of 2-3-4 numbers).

To make your life easier and make everything happen faster, I've done everything for you. 🙂

What I did is I installed the "WPML Translation Management" plugin on your site (this was needed in order to be able to add the code above), then I added the code inside WPML > Parametres > Configuration XML personnalisée and after that, I followed the other steps I presented above.

I will attach some screenshots so that you can see how I solved it on your site and on the sandbox site.

Also, here you can see it working:
- hidden link (sandbox site)
- hidden link (live site)

Please let me know if that works for you, too.

Kind regards,
Mihai

July 16, 2019 at 12:11 pm #4220051

srdjanD

My issue is resolved now. Thank you!