This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 9.63 hours from now. Thank you for your understanding.

This topic contains 23 replies, has 2 voices.

Last updated by Bigul 1 week, 3 days ago.

Assigned support staff: Bigul.

Author Posts
August 20, 2019 at 3:57 am #4420443

raymondW

I am trying to: Re-edit a translated page.

Link to a page where the issue can be seen: on the backend console: "Pages" -> Edit a Page -> "Pen" icon to translate --> Check all "Translation is complete" boxes --> See translation progress is 100% --> Hit "Save and Close" -> Reloaded to original language page -> Hit the "Pen" icon again to edit the translation, again -> "Translation is complete" boxes revert back to unchecked

I expected to see: As I did not change the original language page, "Translation is complete" boxes should have remained unchanged.

Instead, I got: Only modules naming with ": content" at suffix revert back to "Translation is complete" boxes unchecked. Luckily, the original and translated content are both intact.

August 20, 2019 at 7:01 am #4420953

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be happening because of the older version of WPML(3.9.4). Please try the following steps after a full site backup and make sure the issues are existing or not.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php

2) Increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

3) Upgrade to the latest version of WPML(4.2.7 series) plugins

--
Thanks!

Bigul

August 20, 2019 at 10:08 am #4422467

raymondW

Do you have any suggestion of compatible backup plugin to make a "full site backup" of my website which is running WPML? In case the version upgrade failed, I hope that I can restore the website without hassle. Any comments welcome.

August 20, 2019 at 12:00 pm #4423351

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. You can use Duplicator - https://wordpress.org/plugins/duplicator/ or All-in-One WP Migration https://wordpress.org/plugins/all-in-one-wp-migration/ plugin for creating the site backup. Both are free plugins.

Please check and let me know your feedback.

--
Thanks!

Bigul

August 21, 2019 at 3:18 am #4427685

raymondW

Thanks for your suggestions, Bigul.
1. Backup is recreated.
2. Problem in changing the php *MaxInputVars* to *10000*.
I'm hosting multi domains on a shared hosting environment. I can modify the php.ini which is in the root document; however, the website running WPML is a parted domain, so I cannot find php.ini nor the phpinfo.php in the folder of the parted domain. I want to verify the change in WPML console. WPML is still showing the "Max Input Vars as 1000 instead of 10000 (Please see the attachment.) How can I know I have changed the "MaxInputVars" on my parted domain?

August 21, 2019 at 12:35 pm #4431449

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please create a PHP file for example info.php with the following code. Then place it in the root directory of the site. Accessing this file like hidden link will help you to get the details of the Server settings.

<?php

// Show all information, defaults to INFO_ALL
phpinfo();

?>

Please check this article hidden link for more details.

May you have to contact your hosting provider to upgrade PHP configuration values.

--
Thanks!

Bigul

August 23, 2019 at 11:31 am #4446369

raymondW

Thanks Bigul, I completed the updates.
However, the updates partially break my site.
On a page which is the original language: hidden link , you can see the language switch on the right corner does not recognize itself.
On the page which is the translation: hidden link , you can see the original language page is not recognized.
Back to the Translation Management in the back stage (see attachment), the page is marked as "Not translated" and "Missing Translator". But, the translated pages are actually created.
What can I do to "link" the translated pages with the original page?

August 23, 2019 at 4:43 pm #4448873

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am not able to reproduce the issue exactly in hidden link page. It shows the correct translation for the Chinese page.

As per the following screenshot the translation is not completed yet. So I have a couple of requests to track the issue.

https://wpml.org/wp-content/uploads/2019/08/4446369-Annotation_2019_08_23_192801.png

1) Please check you are getting any JavaScript error in browser console while saving the Page from Translation Editor. Does it happen with other browsers too?

2) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

August 23, 2019 at 6:33 pm #4449363

raymondW

I can partially reproduce the problem by the following:
Create a page in ENG (as original), then Publish
Create a translation in T. Chi by pressing the Pen icon, then "Save and Close"
Create another translation in S. Chi as above step.
I have my ENG page linking with 2 translation (see attachment #1)
Then, I carelessly use the top Language switcher to change to "All Languages (att #2), and click Publish.
So, the option "Connect with translations" is shown (att #3).

However, my problem is that I do not get the option to connect the translations on the concerned page (hidden link) which is the original language page. (att #4)

Could you please help me to connect my translations?

You can have a look at my WP back stage anytime if you need.

August 26, 2019 at 7:00 am #4456211

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

August 27, 2019 at 5:48 pm #4468769

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can log in to the site now. The following pages are not translated yet. Please check the attached images for more details.

hidden link

hidden link

Please try the following troubleshooting steps after a site backup and make sure you can connect the translations.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

August 28, 2019 at 2:56 am #4470797

raymondW

I have followed your steps of Clean up already.
By the way, the translated pages are actually existing but WPML does not allow me to connect them with the original page (English). The problem is that a ghost/dummy/incomplete partially translated page is connecting with the original, preventing the option of "manually connect translations" to show up. I'm thinking:
1) if I could REMOVE this ghost translation page, then the "reconnect" option would show up again.
2) if I could modify the Translation-Original Page relationship in the SQL-level, then we may update the table to fix it

August 28, 2019 at 5:33 pm #4476159

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 2, 2019 at 2:00 am #4493671

raymondW

Okay, thank you for help.

September 3, 2019 at 7:23 am #4501639

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of your site and debugging the issue now. Will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul