This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 2 voices.

Last updated by Bigul 1 month, 1 week ago.

Assigned support staff: Bigul.

Author Posts
September 5, 2019 at 4:56 pm #4520881

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

After the Troubleshooting steps in a minimal setup with the Enfold parent theme, I have updated the *21100908 English* page in all languages(just resave). Then it is showing connect option in Chinese Traditional and Simplified pages. Please check the attached images for more details.

Therefore do the same for *Hong Kong Remote Incorporation and Online Multi-Currency Business Account - All-Round Package Service* translation and other pages having the issue. Then make sure you can connect them or not. Sorry, I can't find those translations exactly because of the Chinese characters.

--
Thanks!

Bigul

September 6, 2019 at 2:57 am #4522921

raymondW

Thank you, Bigul. I just work on the *Hong Kong Remote Incorporation and Online Multi-Currency Business Account - All-Round Package Service* page. Here is my result:

The re-save action under "All Language" did make the option of "reconnect translation" appeared again. By using this option, I could find and reconnect ONLY one of the translation (S.Chi specifically, the T.Chi translation is still not reconnected yet).

So, I repeated the "re-save" action but no luck.

I think the culprit is another ghost translation occurs in T.Chi Translation page, under which I see a unintended and incomplete Eng translation. (see attachment)

So, please, I need further support. Thank you again.

September 6, 2019 at 5:46 pm #4526943

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Is it only happening with a single Page now - hidden link?

If so, please try the following steps after a backup and let me know your feedback. It is happening because the translation is already started for Chinese Traditional to English. Please check the attached image.

1) Complete the translation of Page from Chinese Traditional to English
2) You can copy the contents from Chinese Traditional to English in WPML Classic Translation Editor
3) Save the translation
4) Delete the English Translation permanently
5) Then try to connect the hidden link page with hidden link

--
Thanks!

Bigul

September 9, 2019 at 4:03 am #4533467

raymondW

I can't complete step. Error: After I clicked the gears icon for translating to Eng on T.Chi page (see attachment), I was redirected to "Translations queue" page where I could not find the job I need.

September 9, 2019 at 2:20 pm #4537905

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. This may be happening because the language pair is not set for Chinese Traditional to English. I have set new language pairs for Chinese Traditional and Simplified in both translator accounts.

After that, the translation job is showing for me when I visit the Translation queue(WPML>>Translations).

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

September 10, 2019 at 8:03 am #4542761

raymondW

Thanks for your help. After I clicked the "Take and translate" button (see attachment), I was redirected to the same page. You can log in to the console and click this button anytime. It's so weird.

September 10, 2019 at 4:12 pm #4547277

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have tried the following steps on your site. Then hidden link page is showing the *Connect* option now.

1) Visit WPML>>Translations
2) Export the translation file for hidden link page
3) Update the exported translation file via a native editor
4) Import the translation file. Then the translation is completed for hidden link page
5) Delete(from trash also) the English translation of hidden link page

Please check the attached image for more details and let me know your feedback.

--
Thanks!

Bigul

September 11, 2019 at 5:07 am #4550649

raymondW

Your works did solve the problem!
However, can you be more specific of how to "2) Export the translation file" and "3) 3) Update the exported translation file via a native editor". I was lost when I was trying to follow and practise. Thank you again for help.

September 11, 2019 at 9:32 am #4552105

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please check the attached images. We have to choose a translation Job at least to export the translation Job as XLIFF file. Then we have to edit it via an XLIFF editor and import the file backup.

Please check the following documentation for more details and let me know your feedback.

https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/configuring-xliff-file-options/

https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/translating-wordpress-xliff-files-in-metatexis/

--
Thanks!

Bigul