This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 3, 2019 at 8:56 pm #4507259

konstantinosC-2

I am trying to: Translate pages and so on

Link to a page where the issue can be seen: hidden link (and /kunden), also the header in the German shop page is not shown and some widget translations.

I expected to see: the German translated version

Instead, I got: still English

September 3, 2019 at 11:00 pm #4507471

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Could you describe the steps you are following in order to translate this page?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 4, 2019 at 9:05 am #4509547

konstantinosC-2

Hi, My memory limit is already 256mb.

I used the advanced translator and completed it. For all main pages it worked (home, kaffee, faq, news) but not for kontakt and kunden. Even worse is the impressum (imprint page), the translator loads the old version although deleted that site long ago.

September 4, 2019 at 9:53 am #4509861

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

September 4, 2019 at 12:05 pm #4510717

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

The cause of the issue was that the pages weren't fully translated. I finished the translation and the issue disappeared.

If you see the same issue in other pages just edit the page in the default language -> Add a minor change -> Save the changes and update the translation.

Regards,
Carlos

September 4, 2019 at 12:24 pm #4510853

konstantinosC-2

You are quite fast with solving XD thanks.

hm, strange, I did translate them fully. What about the Impressum page? the one in pages is completely different from what the advanced translator wants to translate.
Could you help me with that too, please?

September 4, 2019 at 12:27 pm #4510891

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
We try to do our best 🙂

Yes, I will be more than happy to help you with the Impressum page. I just visited the Pages section in the backend and I can see that the translation of the Impressum page needs updating. Could you update (finish) the translation and double check if the issue persists?

Regards,
Carlos

September 4, 2019 at 12:58 pm #4511233

konstantinosC-2

Hi, yes, still the same. if you have a look at the English version you see something if you look at what wpml wants to translate, it is something completely different.

September 4, 2019 at 1:23 pm #4511421

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I just updated the Impressum page. Could you tell me if the issue is solved?

Regards,
Carlos

September 4, 2019 at 2:38 pm #4512131

konstantinosC-2

Lol, now it pulls the correct one. Thx.
If you could help me with the missing header in the German shop page I would be happy^^ As far as I know I translated everything concerning the header. Templates etc.

September 4, 2019 at 2:42 pm #4512141

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I will be more than happy to keep assisting you but as this last issue is slightly different that the original one I kindly ask you to open a new ticket and assign it directly to me. This way we will be following the forum's rule of one ticket per issue. This will also help future clients to find answers to similar questions while searching in the forum.

You can assign me the ticket directly or just paste the URL of the new ticket in you next message and I will manually take it.

Thank you very much for your understanding!
Best regards,
Carlos

September 6, 2019 at 9:24 am #4524351

konstantinosC-2

My issue is resolved now. Thank you!

September 6, 2019 at 11:06 am #4524973

konstantinosC-2

https://wpml.org/forums/topic/shop-header-not-appearing-in-german-version/

September 6, 2019 at 2:21 pm #4525843

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I can see that a colleague already took your other ticket.

Regards,
Carlos