This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Marcos Vinicios Barreto 1 month, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 22, 2019 at 11:15 pm

eugenioE

So I have created many ACF Gutenberg Blocks for my custom theme, and i'm having trouble with only one of these blocks (Block: History). It's a super simple repeater block, and whenever I save the translated content from the advanced editor, the content won't be saved with the same structure of the original content, it will just get saved to a default gutenberg block instead of the one I created with ACF.

You can see the problem right here in the last section: hidden link whenever you are browsing in English. Spanish works fine.

July 23, 2019 at 8:37 am #4264053

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I see the issue - it looks like that ATE has not properly translated or rendered tags required for this to work. It looks like a compatibility issue.

Login: hidden link
Username: demo
Password: Zd313y0XuBfJ

Therefore, could you perhaps try to emulate the same behavior here, so that I could escalate to our compatibility team?

I have installed all the plugins - WPML, ACF, ACFML, etc. All I need you to do is to configure WPML (so your original language and translation) and create that repeater field and try to translate one page. Hopefully it will not take more than 5-10 minutes.

Can you assist with this? Let me know if you have any questions. Please use ATE since we want to emulate the same issue.

Regards,
Bruno Kos

July 23, 2019 at 3:10 pm #4267347

eugenioE

Hey Bruno,

No, I don't have time to set up staging sites. That's why I included a full copy of the site as requested and gave you access to the admin of my actual site. Everytime there's a support problem, you people at WPML just try to win time by making us, the users, lose more time. This is unacceptable.

As I mentioned before: I'm having trouble with only one of these blocks (Block: History). I am successfully using other ACF Blocks with complex repeaters, but this one won't work. I need to know what is the problem with this particular block so I can decide wether to use WPML, ACF , and Gutenberg Blocks in future projects / products. If this behavior repeats and just happens randomly, i'm never ever going to recommend this product and won't use it.

So, no. It's not compatibility. I hope I don't have to wait another 9 hours to get a normal response that actually helps with the problem.

July 24, 2019 at 6:09 am #4270497

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Everytime there's a support problem, you people at WPML just try to win time by making us, the users, lose more time.

The reason for this is not to waste clients time, but to speed up the whole troubleshooting process. Very often our clients are coming with sites that have 50-60 or more installed plugins, complex caching systems set in various setups so if we ( support) suspect that it might be a compatibility issue, we simply ask them to emulate settings of those products (themes, plugins) on our sandbox sites, where he basically narrow down these whole setups to the barebones, asking them only to perhaps set WooCommerce gateway, theme settings or something similar, that takes them no more than 10-15 minutes at most and without affecting their sites at all, while the same job would take people support much longer, because even a subtle difference in a setting may be a culprit and we may miss it. Hopefully you agree at least a part with this stance :).

In this case, I suspect it could be compatibility issue with advanced custom fields and our advanced custom fields multilingual plugin, even though I may be wrong about it.

As for the issue - I deployed the site of my localhost and open up your version as well. Can you tell me how did you manage to get these translations - even faulty - working in the first place? I simply opened translation in advanced translation editor ( as it is set) by opening:
hidden link

and when I opened translation in ATE and redelivered, everything seems to be gone:
hidden link

as it is not rendered at all. I have not changed anything in related to custom field translation preferences. Did you use ATE as well?

Regards,
Bruno Kos

July 24, 2019 at 4:08 pm #4276315

eugenioE

Hello Bruno, any chance someone from my same time zone (or similar) helps in this at least? I can't wait 1 full day for an answer that once again, doesn't help at all.

Every time WPML erases my content from the fields from that page (Page "Nuestra Historia" -> Block: History) I have to go once again into wordpress and delete the translation (Page "Our History"). Then I go to the original post and launch ATE and the content will appear once again in the wrong block.

I even tried deleting the original page, adding a new one, and creating a new translation (new translation is not possible because ATE has everything stored). My bet is ATE is messing things up. But I didn't develop WPML so I have no idea.

If you check my site, or the copy of the site I made with duplicator and sent to support, or check the logs I sent, there are many other block fields (some even with nested repeaters) working without a problem.

I really need to know why this happening so I can decide if i'll use blocks + wpml + acf, or just drop wpml, because they sell something that does not work how they say it works.

July 25, 2019 at 6:53 am #4279629

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Based on when you send your replies, if that is your morning, I am assuming that you are somewhere in Western American time zones? We do have few supporters in those time zones, some of whom start about 2 hours after the time of your last message and after I finish my shift.

Let me reassign this ticket to one of those supporters - Bobby. Please message him about your time zone, perhaps he can point you somebody else if that would be more convenient for you.

Regards,
Bruno Kos

July 25, 2019 at 5:13 pm #4285337

eugenioE

My timezone is GMT-4.

This must be the worst support I've ever received in my life. WPML is a joke. I've lost one week because of this plugin. There's several threads about people complaining about the horrible support team.

Should I wait another full week in order to have this thing solved? This is just disrespectful.

How on earth am I supposed to message Bobby?

[Hey stranger, if you are reading this --DON'T BUY THIS PLUGIN-- if you ever need help with it, support will just try to wear you out with nonsense]

July 25, 2019 at 7:43 pm #4285763

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for any inconvenience we have might caused here, while we do our best to provide a satisfatory support for all our customer, we do understand there's still migth have some issue out of our control.

I will take care of your ticket from now on as my timezone is closer to you. Please, give me some time to review your ticket and understand your issue and make some investigation. I will be back as soon as I have some detailed and accurate answer for you. Thank you for your continued patience and understanding, have a nice day.

July 26, 2019 at 8:01 pm #4291651

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a solution. I performed a detailed investigation in your website using the provided duplicator package and noticed some suspicious weird behaviors, here is what I noticed:

1 - The content of the page 'Nuestra Historia' in the translated page wasn't using your custom 'history' block instead it was using a default block with regular text content. I noticed it works properly when I took these steps:

1.1 - I deleted the current english translation of the 'Nuestra Historia' page.

2 - I added a new translation for this page using the WPML Classic Translation Editor set from WordPress Dashboard > WPML > Settings > How to translate pages and posts

You will notice this time the 'Nuestra Historia' (Our History) translated page will be shown properly in the website frontend under the url clientes/cym/?lang=en#history.

Unfortunately another weird behavior was noticed, when you click to edit your english translation you will notice the WPML Translation Editor will be always missing some fields, it will never show all the repeater 'description' fields. I tried several methods and indeed it fails when there's a few fields instances in a block content.

I will forward this ticket to our second level support for further analysis, we really need to confirm if we have a bug here regarding AFC Gutenberg blocks with repeater fields, or if it is something database specific.

In the meantime, I will provide you with a simple temporary workaround you can try to make your 'Nuestra History' page working in both languages, please, try the following:

1 - Copy your current english content for your 'Our History' page and paste somewhere to be used in the steps below.

2 - In your WordPress Dashboard > Pages delete your current 'Our History' translation, click to send it to the WordPress trash feature and then delete it permanently.

3 - Click to edit your 'Nuestra Historia' page.

4 - Add a duplication of this page to your secondary language. See attached screenshot (customer_screen_01).

5 - Click to edit this page using the default WordPress page/post editor. See attached screenshot (customer_screen_02)

6 - When prompted to apply the changes choose the 'Este pagina' option and click the 'Aplicar' button. See attached screenshot (customer_screen_03).

7 - Now click the pencil icon of your 'Language' box in your 'Nuestra Historia' editing screen, it should open your english page in the default WordPress page/post editor.

8 - Edit it replacing the spanish content with your english content you copied in the step 1 above.

Please, let me know it the steps above works for you. Again, it is a temporary solution, so you can avoid any further delay in the resolution of your issue. We will still run a detailed investigation with the help of our second level support in order to test more scenarions and determine the cause of the issue when using the WPML Translation Editor.

Please, accept our sincere apologies for any inconvenience we might have caused for you. Have a nice weekend.

August 28, 2019 at 2:59 pm #4475291

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Can you please confirm if the mentioned workaround worked for you? Thanks.