This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Dennis 5 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
April 28, 2019 at 8:06 pm

jimmyK-3

I am trying to: translate this certain text of this plugin. But it has no effect.

Link to a page where the issue can be seen:hidden link

hidden link

I expected to see: side button translated. contact button on the right.

Instead, I got: default language

April 29, 2019 at 9:37 am #3701639

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support theme.

It could be that you're translating the wrong string in String Translation page. To translate the 'contact' button text, please follow these steps:

-go to WPML > String Translation.
-scroll down to the bottom of the page and click on the link "Translate texts in admin screens »".
-search for 'splite_opts'.
-Under it find 'side-button-text'. Tick the checkbox and click Apply to add it to the String Translation table.
-Now you can go back to WPML > String Translation and you should see the string added there. Translate the string completely and save.

I have attached an image for your reference.

Please check our documentation about this:
https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

Does it help? Please let me know.

Kind regards,
Dennis