This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Why are my translated pages not appearing on the front-end of my site?

Solution: Please make sure you are correctly and completely translating your posts/pages/custom posts.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/#how-to-translate-pages-posts-and-custom-posts

This topic contains 6 replies, has 2 voices.

Last updated by gloriaC-7 5 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
May 7, 2019 at 10:10 am #3756241

gloriaC-7

Tell us what you are trying to do?
Can let Alejandro Sanchez keep solve my problem over previous issue.
Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

May 7, 2019 at 10:36 am #3756475

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,

If you want you can open a chat for this issue or you can tell me what's the problem and i'll gladly help you out!

Let me know.

May 7, 2019 at 10:38 am #3756501

gloriaC-7

hi,

didn't know how to open chat here.

May 7, 2019 at 10:48 am #3756643

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, well it's not a problem, please let me know what problem are you facing and how can i help you.

May 7, 2019 at 10:51 am #3756649

gloriaC-7

I read your reply and where to setting it? can you provide document? Is WPML translation managemet?

May 7, 2019 at 11:05 am #3756717

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Oh, remember when you sent me the screenshot with the gear icons in them? click on those gear icons and then, below each translation box you'll see a "translation is completed" checkbox as you can see in the screenshot below).

You can also do it through the "translation management" plugin. I suggest you Check the documentation for it if you want to learn how to do it using this method:

https://wpml.org/documentation/getting-started-guide/#how-to-translate-pages-posts-and-custom-posts

Regards.

May 7, 2019 at 11:10 am #3756847

gloriaC-7

My issue is resolved now. Thank you!