Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by jefM 1 year, 6 months ago.

Assigned support staff: Itamar.

Author Posts
January 14, 2019 at 8:35 am #3086316

jefM

Hi

I want to translate a Layout on a website. I made Layouts translatable in the settings, and followed the steps in this article: https://toolset.com/documentation/translating-sites-built-with-toolset/translating-layouts/

However, Translation Management is unable to find my Layouts, while it does find my custom post types and anything else that I made translateable.

I was able to translate my Layouts on another site using Translation Management, so I hope you can help me to solve this issue.

Thanks in advance.

January 14, 2019 at 10:10 am #3086627

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

If I understand correctly when you go to WPML -> Translation Management -> Translation Dashboard you cannot find 'Layout' when try to filter items for translations. Please see the attached screenshot layout-in-tm.jpg.
Is this correct?

Could you please tell me what is set for 'Layouts (dd_layouts)' in WPML -> Settings -> Post Type Translation?
Please see the attached screenshot layouts-settings.jpg.
Which one of the options are there on your site?

Thanks,
Itamar.

January 14, 2019 at 1:57 pm #3087838

jefM

Thanks for your reply.

The 'Layout' option is available in the dropdown menu. The problem is that the Layouts are not displayed in the list. If I try to filter for Layouts, I get a message saying 'No documents found' (as shown in the screenshot).

I've tried both 'Translatable - only show translated items' and 'Translatable - use translation if available or fallback to default language', but that didn't make a difference. I'm currently using the 'Translatable - use translation if available or fallback to default language' option.

January 14, 2019 at 10:01 pm #3089827

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

There is a padlock icon next to the 'Layouts (dd_layouts)' in WPML -> Settings -> Post Type Translation. That means that the settings are determined by a wpml-config.xml file that is inside the plugin's folder and it should stay like this. The 'Layouts' are set to 'Not translatable' as you can see in my screenshot. It should stay like that. It was supposed to be like on your site as well. Wasn't it?
Could you please set it to 'Not translatable' and see if it fixes the problem?

Thanks,
Itamar.

January 15, 2019 at 10:11 am #3092011

jefM

Thanks again for your reply.

By default, it was indeed on 'Not translatable', but I already had this issue before I changed this setting to 'translatable'. In fact, that's why I changed it in the first place.
I've changed it back to 'Not translatable' now, but nothing has changed yet.

January 16, 2019 at 1:42 pm #3097994

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I would like to continue debugging this issue with a copy of your site on our test server.
For this, please read the next private message.

Thanks,
Itamar.

January 17, 2019 at 2:22 pm #3102412

jefM

Hi

Thanks for your reply.

I wanted to test it again before I was going to install the Cloudways WordPress Migrator plugin, and it seems like the issue is gone now. My Layouts are being displayed in the list, and it looks like everything works the way it should right now. Thanks again for your support and time.