This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Shekhar Bhandari 2 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 1, 2019 at 11:05 am

erikS-26

Hi WPML,

I'm updated the translateable fields under 'Multilingual content setup'. When I try to translate the page it doesn't show the freshly added translateable fields. Also, it shows different fields when I try to translate to different languages.

August 1, 2019 at 12:39 pm
August 2, 2019 at 12:05 am
August 2, 2019 at 10:39 am #4329011

erikS-26

The website is migrated. Please let me know what causes the issue so it can be prevented next time.

August 3, 2019 at 12:08 am #4332859

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I did some test but with no avail. However, I noticed that ACF is not updated. Can you update it as well as ACF Multilingual and see if you notice any difference?

August 3, 2019 at 10:02 am #4334305

erikS-26

Hi Laura,

I updated the plugins on the webobmaakt.nl/ domain. It doesn't resolve the issue.

August 3, 2019 at 11:35 am #4334415

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I'm asking a second opinion on the matter, but in the meantime could you update ACF in the CW copy too? The credentials are the same you provided.

August 6, 2019 at 9:04 am #4345591

erikS-26

'The site is experiencing technical difficulties.' the website says. If it's right you can update the plugins aswell right?

August 6, 2019 at 2:20 pm #4348301

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I'm not sure why there is that problem in the frontend (probably because I deactivated all plugins), but the backend is working fine.

I can't update ACF because you're using the Pro version and a license is needed, otherwise I would have already done that.

August 6, 2019 at 2:40 pm #4348673

erikS-26

Hi Laura,

I updated the ACF plugin, it seems like the Multilingual ACF can't be updated right now due to an error. I guess you can install it, right?

Looking forward hearing,

August 7, 2019 at 10:19 am #4353581

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I escalated the issue to the second tier, I'll let you have news as soon as possible.

August 8, 2019 at 8:16 am #4360831

erikS-26

Hi Laura,

Any indication on when it will be fixed?

August 8, 2019 at 11:51 am #4362321

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I just got a message from the 2nd tier. Apparently, when you try to save the page this throws an error.

He suggested this fix:
- Go to Custom Fields > Field Groups > Pagebuilder
- On the display rules, temporarily change it to "Post Type is equal to Page" (It's currently defined as "Page type is equal to Front Page", it may be related to the issue)
- Install the Duplicate Post Plugin (https://wordpress.org/plugins/duplicate-post/)
- Duplicate the home page
- Check if all custom fields are copied to this cloned page. If so, do a small modification and save.
- Translate the page to both languages, the fields should be displayed correctly on TE for both languages this time.
- Go to Settings > Reading and set this new page as the front page
- Delete the old page
- If you want, you can set the field group as "Page type is equal to Front Page" again

I tested in my copy of the site and it's working. Can you try you too and confirm?

August 9, 2019 at 9:54 am #4369255

erikS-26

Hi Laura,

I followed the steps and now I can indeed see all the correct fields. This brings up the following problem. When I access the front-page in English it all works well. When I visit the page in Dutch, the ACF-fields do not load. (hidden link (en) and hidden link (dutch)). While they use the same page-template (since they use front-page.php).

We're in a hurry, looking forward to your answer as soon as possible!

August 9, 2019 at 11:05 am #4369619

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The issue is happening as the repeater and flexible fields aren't set properly.

Suppose you have a repeater field (repeater) and it's has a "first name" field inside it, to translate the first name field, you should follow the below steps:

- Go to the page/post where it's added
- Go to Multilingual content setup metabox in the bottom
- Click on show system fields
- Now mark "repeater" field as copy and "firstname" field as translate
- Now mark the system fields _repeater and _repeater_firstname to as copy.

Here is a video showing the same thing: hidden link

- Use the same settings for flexible fields too and it's subfields and the translation will show properly.

Let me know if this helps.

Thanks