This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mihai Apetrei 8 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
February 18, 2019 at 12:58 pm

tauriT

I am trying to: Open the translation management page

Link to a page where the issue can be seen: hidden link

I expected to see: Translation management

Instead, I got: An empty page

February 18, 2019 at 2:14 pm #3212651

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. Make sure that the theme you are using and all the plugins are using the latest versions. If not, please update them to the last version, only after you create a full website backup.

3. If the issue still persists, we will need to check for a possible theme or plugin conflict.

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if following any of these steps solves your issue or bring any change.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

February 18, 2019 at 3:11 pm #3212994

tauriT

Hi,

I tried 1, 2 and 3 with the exception of switching to a default theme because the site is live with visitors on the website 24/7. I cannot simply shut it down unfortunately.

None of the above helped though. Any other ideas?

February 19, 2019 at 11:51 am #3216418

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for going through those steps.

This helped us make sure that the issue is not caused by another plugin.

I have also been informed by our developers that this is a known issue that is currently worked on.

Can you please follow the steps here and let me know if this solves the issue?
https://wpml.org/forums/topic/split-can-not-complete-translation-management-this-quick-setup/

Kind regards,
Mihai

February 19, 2019 at 5:07 pm #3218272

tauriT

Hi,

After downgrading i can see the translation management setup however i get this error under the section:

"WPML Update is Incomplete
You are running updated sitepress-multilingual-cms, wpml-media-translation and wpml-string-translation, but the following components are not updated:

wpml-translation-management

Your site will not work as it should in this configuration Please update all components which you are using. For WPML components you can receive updates from your WPML.org account or automatically, after you register WPML."

Also, i cannot see any translation service suggestions. Screenshot attached.

Still need help.

Thanks,
Tauri

February 20, 2019 at 12:12 pm #3221536

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

You are experiencing the same thing in this ticket here:
https://wpml.org/forums/topic/cannot-configure-translation-management/

Please follow the recommendation of my colleague, Laura and let me know if that solves the issue:
https://wpml.org/forums/topic/cannot-configure-translation-management/#post-3201847

Kind regards,
Mihai