This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 6 months ago.

Assigned support staff: Bigul.

Author Posts
April 25, 2019 at 10:26 am

miquelE

When updating all the wpml plugins yesterday my site stopped working when the Translation Management is active. we have been using WPML for a while now without any issues with our theme and other plugins.
I contacted my hosting provider and they say it is the wpml plugin that causes all php processes to be at 100% cpu when the plugin is activated.
I also checked the wpml plugin requirements and our server meets all of them.

April 25, 2019 at 6:10 pm #3684897

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Hope you were using WPML 4.2.5 version before upgrading to the latest version.

This may be happening because of the compatibility issues. I have a request to track it. Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug(Enable WPML Translation Management plugin) and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

Also please check you are getting any error in the server error log(Apache) when WPML Translation Management plugin is active.

--
Thanks!

Bigul

April 25, 2019 at 6:37 pm #3685109

miquelE

Hi Bigul,

This is the link to the debug log

https://pastebin.com/t0fesprE

thanks

April 26, 2019 at 8:11 am #3688767

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The *debug.log* file is not showing any error or warning related to WPML.

Therefore please check you are getting any error in the server error log(Apache) when WPML Translation Management plugin is active.

Just to make sure, when the Translation Management plugin is active you having the issues in the frontend of the site or the backend. Please share more details about this.

I have a request. Please deactivate WooCommerce Multilingual plugin for a moment for testing, then activate WPML Translation Management plugin and check the issues are existing or not.

--
Thanks!

Bigul

The topic ‘[Closed] Translation management plugin chrashes my website’ is closed to new replies.