This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Yvette 3 weeks, 6 days ago.

Assigned support staff: Yvette.

Author Posts
September 16, 2019 at 10:30 am #4578829

serged-3

I am trying to: let a translation service (Avanti) translate a page with the WPML plugin. We already have the page in 2 languages (Dutch and English) and want the translation service to translate either of the two to French.

I have exported the page two times to the translator: in Dutch and English. When I check the pages, the language settings seem fine. hidden link and hidden link.

However, Avanti says the language settings in their .xliff file are incorrect, so they can not translate it. I.e. the file with Dutch content has the English language setting.

I can not delete the job and they say they can not either. I also can not edit the French page, because I get the error "in progress".

Do you know what the issue might be or how we can solve this? Thanks!

September 16, 2019 at 6:15 pm #4583107

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´m checking with our Tranlsation Services team about the best way to handle this. In the meantime,

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

Thank you

September 17, 2019 at 8:34 am #4586477

serged-3

Dear Yvette,

Thank you for your reply. If it's possible I would prefer not to provide FTP access right away, because this a client of our agency (we built the website and do online marketing). We would have to ask them to make a backup first. Maybe the Translation Services team knows a solution?

Let me know if there's no other way, then I will arrange the access and backup.

Thank you!

September 17, 2019 at 11:05 am #4587887

serged-3

A question in addition to my last problem mentioned: when you send out a job to the Translation Service, you can not edit that page anymore (once it is in progress). Is there a way to cancel or remove a job? Or is only the translation agency able to do that (and if yes, how)? They say they can not cancel, but only archive a job. But this does not solve the problem..

September 17, 2019 at 4:21 pm #4590099

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Our Translation Proxy specialist checked the job you referenced.

He could see that the file contains the Dutch language instead of the English language, so I think this issue is more related to WPML not to the Translation proxy, Can you please try to send the same page to a "local translator" and extract the XLIFF file for the local job and see if the issue will be replicated or not?

If you need assistance to do this please provide system access information in the private area below.

Thanks

September 18, 2019 at 3:02 pm #4597799

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I tried sending to a local translator and the XLIFF file seems correct. Doing this seems to also have cleared out the "in progress" job.

Can you try sending to Avanti again for the translation of "About Fieldpower" from EN to FR?

Thanks

September 19, 2019 at 4:55 pm #4607489

serged-3

Thank you Yvette, this has solved the problem!

How did you manage to send it to a local translator?

September 23, 2019 at 2:15 pm #4624887

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I´m really glad this resolved the issue! Perhaps sending it through the Translation Management system reset some "invisible" settings.....?

To send a job to a local translator:

- first define a translator that is already a user in your system (WPML > TM > Roles)
- assign the required language pairs
- Use the Translation Manageent dashboard to select the page/post to translate
- It will then send the job to the "Translation Basket"·
- Go to the translation basket and send to translation ...selecting the translator name you setup.
- The assigned translator will then see it in their translation queue when they go to WPML > Translations

This is described here:
https://wpml.org/documentation/translating-your-contents/