This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.31 hours from now. Thank you for your understanding.

This topic contains 1 reply, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
October 4, 2018 at 1:18 pm #2787639

raphaelG-6

My client is translating its English website to Italian, Portuguese, and Spanish. The Spanish and Portuguese worked out fine as usual and the Italian worked also so far. But for one single page (examples page) in Italian the translation manager does not work correctly. If I click on the "edit in Italian" icon I come to the usual page but there is only one field for translating the title but nothing for the rest.
So we tried to translate it manually, which works, but as soon as We change something in another language on the same page the text changes on the Ita. page to English again ...
Can you please take a look.

October 5, 2018 at 6:45 pm #2791547

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @raphaelg-6, welcome to the WPML support Forum!

Are you using a page builder? Could you please send us a screenshot of the edit screen of the page (original language)?

Please enable WP_Debug on your website, it will display more details about the error: https://wpml.org/documentation/support/debugging-wpml/

I also checked the settings of your server through debug log and saw that some items need attention:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 128mb.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

PHP Version
Upgrade from PHP to version 7 or higher. This is a practice recommended by the WordPress.org website: https://wordpress.org/about/requirements/

MaxInputVars
Currently your server is configured with MaxInputVars = 3000. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

All the best,
Diego

The topic ‘[Closed] Translation Manager does NOT work for only one page in only one language’ is closed to new replies.