This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by bettinaS 2 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 25, 2019 at 10:59 am #4282071

bettinaS

I am trying to:
I have sent several pages to an agency, got them already but the translation of the Tables of the NinajTables Plugin are not translated. Instead there is a link on the translated page to translate the table text. But the agency doesn't work in the backend. So how can I get the text to the agency. Would I have to doublicate the table, export a CSV or JSON and import than the translated table? Or is there an easier way to do that?

And than I have a couple of pages with english text on the german site which I just duplicated because I need the same pages with the same text on the english site. But in the frontend there is also the Edit Table link underneath the tables - how can I get rid of that link? I don't get the link when I open the page in the backend

I have the same problem with text on images from LayerSlider WP Plugin. How can I get those to the translation agency?

On String-Translation I see the table - the status is "translation has to be updated" but I can only translate the table ID and not the text of the table.

Link to a page where the issue can be seen:
hidden link

I expected to see:

Instead, I got:

Best regards
Bettina

July 25, 2019 at 5:21 pm #4285361

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 29, 2019 at 6:10 pm #4302749

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Regarding your questions:

1 - "...the translation of the Tables of the NinajTables Plugin are not translated. Instead there is a link on the translated page to translate the table text..."

Usually you send text content of plugins using the WPML String Translation. In the case of Ninja Tables it doesn't seem to be compatible with WPML for now (see: https://wpml.org/documentation/plugins-compatibility/?wpv_view_count=119945&dev=0&wpv-plugin-functionality=0&wpv_post_search=Ninja+Tables&wpv_filter_submit=Search), so the only workaround for it should be:

1.1 - Create an english version of your requested table in your WordPress Dashboard > Ninja Forms along with your alerady created german version. In other words you would have to create two tables version, something like 'My Ninja Tables EN' and 'My Ninja Tables DE'.

1.2 - Manually edit your translated page using the default WordPress page/post editor and adjust the table shortcode to reflect the shortcode version you created in the step above.

See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

In the case of the 'Edit table' link it is only visible for logged in users and it is coming from the 'Ninja Table' plugin files, even so if you want you can translate this text link in your WordPress Dashboard > WPML > String Translation under the 'ninja-tables' text domain.

See: https://wpml.org/documentation/getting-started-guide/string-translation/

2 - "And than I have a couple of pages with english text on the german site which I just duplicated because I need the same pages with the same text on the english site"

Can you please, provide me with some more details of these pages? Where can I see them? It will help me to understand the cause of this issue.

"3 - I have the same problem with text on images from LayerSlider WP Plugin. How can I get those to the translation agency."

Please, follow our instructions at: https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-using-layerslider-and-wpml/ and once you have your slider created you can follow these instructions:

3.1 - In your WordPress Dashboard > WPML > String Translation locate the slider strings under the 'LayerSlider Sliders' text domain anc check all the fields you need to send for translation.

3.2 - Locate the 'Add to translation basket' blue button and click it in order to send your strings to the WPML Translation Management translation basket.

See: https://wpml.org/documentation/getting-started-guide/string-translation/#translating-strings

3.3 - Now in your WordPress Dashboard > WPML > Translation Management you are able to send the content of the translation basket to your translation service or local translators.

Please, let me know if you need any additional instructions and clarifications, have a nice day.

July 30, 2019 at 8:51 am #4305863

bettinaS

Hi,

could you find the problem why I get the "Edit table" in frontend of both languages?

Best regards
Bettina

July 30, 2019 at 1:23 pm #4307955

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Bettina,

Thank you for the updates. Regarding the 'Edit Table' link in the frontend of your website it is actually not a problem neither related to WPML usage, instead it is a link coming from your Ninja Tables plugin files only visible for logged in users with permissions to add content to your website, your regular users/visitors don't see this link.

In any case, as pointed above you either translate it in your WordPress Dashboard > WPML > String Translation or hide it with a custom css code you can paste in your WordPress Dashboard > Appearance > Customize > Additional CSS Here is the code you can try:

.ninja_table_wrapper .nt_edit_link {
	display: none;
}

Please, let me know if you need any additional clarifications, have a nice day.

July 30, 2019 at 2:48 pm #4308713

bettinaS

Thank you Marcos!

I'll try translating it in String Translation.
But there I have problems too.

I'm trying to translate the footer widget. Therefore I watched the video
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

On /String Translation /Widgets I get the Union Jack and when I click Translate I get a field with Deutsch above.
The widget title is there only once and I managed to translate that and it works.
But the widget body ist there twice, once named "widget body" and once named "widget body - text ici-2" and so on.
I pasted the german text into "widget body" - nothing changed,
than also into widget body - text ici-2" - nothing changed
still the english version on the german page

On /Design /Widgets I marked the text as Multilingual but have on both languages the title in english. As soon as a change the title on the german widget - I get the title on the english page in german.

I'm really confused - would you pls help me.

Best regards
Bettina

July 31, 2019 at 8:08 am #4312703

bettinaS

My issue is resolved now. Thank you!