This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 31 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 7, 2020 at 2:59 pm #5858573

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,

Could you provide a database dump file?

I have set your next answer private so you can provide a download link in a secure way.

Looking forward to your message.
Regards,
Carlos

April 8, 2020 at 1:53 pm #5866451

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,
The file provided only contains a .rtf file instead of a .sql file.

Could you contact your hosting providers and ask them to help you create a backup of the database?

Note: Once you have it you can edit your previous (private) message and change the download link.

Regards,
Carlos

April 8, 2020 at 2:03 pm #5866487

Nicolas

Hi Carlos,

The rtf file contains the download link to the SQL file. There was no other way to do it, as I couldn't reply without adding a ZIP file. In any case I'll try to add the link as well to the private message.

April 8, 2020 at 3:04 pm #5867259

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,

I'm sorry, I missed the download link in the rtf file 🙂

I'm downloading the SQL from WeTransfer and I will share it with our 2nd tier specialists. I will keep you updated.

Thank you very much!
Regards,
Carlos

April 10, 2020 at 1:13 pm #5884197

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,

Our 2n tier specialists found that there is a missing field on the database.

I would like to ask you to follow these steps:
- Create a full backup of the site.
- Run this query on the database:

ALTER TABLE `wp_4_icl_translate_job`
ADD `edit_timestamp` int unsigned NULL;

Could you tell me if the issue persists?

Regards,
Carlos

April 10, 2020 at 2:05 pm #5884445

Nicolas

Hi Carlos,

We've run the query, the field was added, but unfortunately the issue still remains.

We've also noticed that if we update the content of the original page (English) and proceed to the translation dashboard (by clicking on the circle to update the translation), the changes in the text do not appear there in the original language. On the front-end the changes are visible though.

Thanks,

Nicolas

April 10, 2020 at 2:21 pm #5884473

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,
Thank you very much for your message.

I have updated our 2nd tier specialists with this information.

Regards,
Carlos

April 10, 2020 at 3:32 pm #5884879

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,

Could you tell me if the problem of the modified content not appearing in the Translation Editor persists still persists if you create a new test page?

Regards,
Carlos

April 11, 2020 at 8:33 am #5888241

Nicolas

Hi Carlos,

I created a new page 'Test'. When clicking on the '+' to add a translation it straight away directs me to the translations queue. I don't even get to the translation dashboard anymore. I assigned the translation to myself and then tried to edit it via pages, but still sending me to the queue.

We're also noticing these issues now with other websites, so it seems a more general issue? Hopefully we can find the issue soon, as our clients are getting very impatient...

Thanks and regards,

Nicolas

April 13, 2020 at 1:06 pm #5896449

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,
Thank you for your reply.

I have informed our 2nd tier specialists about your message. I will get back to you as soon as I get an answer from them.

Thank you very much for your patience and understanding.
Regards,
Carlos

April 15, 2020 at 8:04 pm #5916867

Nicolas

Hi Carlos,

As I would like to offer a temporary solution to my clients (as they haven't been able to use the translation tool for 3 weeks now, and it's a rather crucial period to update communication), would it do any harm if they manually translate the pages? Or will all manual translations be lost if those pages are later updated again via translation manager?

Best,

Nicolas

April 16, 2020 at 10:48 am #5921613

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,

Our specialists weren't able to reproduce the issue in a local environment. So it is either cache or weird server configuration.

They recommend to try and disable cache and check if it helps. It is possible that WP Engine is not excluding the backend of the subsites from the cache - but it'snot possible to reproduce that without knowing the exact server configuration.

Regards,
Carlos

April 17, 2020 at 8:46 am #5930251

Nicolas

Hi Carlos,

I've double-checked with WP Engine, but there's no caching for the backend. We have another website on their servers and there WPML works fine, which would exclude a server configuration. Just in case relevant: their only remark is that they use both Nginx and apache and they wondered if there might be a rule that needs to be added tot Nginx?

Would it help if I also give access to the other site which works (and has same theme, Elementor, WPML translation management, and similar plugins) to understand if there's a difference somehow?

We triple checked all plugins for potential conflicts, compared all settings in WPML, we've tried and installed older versions of WPML (as it seems the issue started after an update of WPML), but it still does not work anymore. Until a few weeks ago it was all fine. Was there anything in one of the recent updates of WPML that could somehow have an impact on the translation editor process?

I very much appreciate WPML looking into this, as we exhausted any other potential solutions regarding external factors/conflicts with WPML.

Thank you

April 17, 2020 at 4:50 pm #5934779

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,

I updated our specialists with your last message. I will get back to you as soon as I get an answer from them.

Thank you for your patience.
Regards,
Carlos

April 20, 2020 at 7:56 am #5945987

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Nicolas,

Our developers found that the cause of the issue is that the cache function of WPML is not working correctly on your site, this is most likely caused by the caching settings on the server-side. However, they can't find the exact cause.

For this reason, they provided a workaround. Please follow these steps:
- Go to wp-content\plugins\sitepress-multilingual-cms\inc\translation-management\translation-management.class.php method: get_translation_job_info
- Change the last 'if' statement from:

if ( ! $found ) {

to

if ( true ) {

- Save the changes.

Could you confirm that his workaround solved the issue?

Regards,
Carlos

The topic ‘[Closed] Translation not save, forcing to select translator in Translation Management’ is closed to new replies.