This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Riffaz 2 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
July 22, 2019 at 9:44 pm #4261495

philipF-6

I finished translating all 46 pages however it indicates that only 42 are done. When I go back in to re-re-re-save (I've tried many times), it always marks the pages as not completed even though when you click to edit the translation it indicates 100% completed.

In addition, I noticed that when you are in the 'Translations' tab and click on 'View' (as opposed to 'Edit'), it opens what the end product should look like and it is completely messed up. I'm not sure what goes on there in the background but the text is full of mistakes, not coherent, not what I translated. It looks like an automatic Google translation, or something to that effect.

URL:
hidden link

Will provide a staged version of the website upon request.

July 23, 2019 at 9:49 am #4264705

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Please fix these and try: hidden link

your hosting allows you to use memory up to 768mb but your WordPress Memory limit is just 40.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '768M');

Then ask your hosting support to increase the MaxInputVars to 10000

Then check the issue.
If you still see the issue, please go to WPML > Support > Troubleshooting and perform all the steps there.
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Let me know how it goes.

Regards,
Riffaz.

July 30, 2019 at 4:06 am #4304677

philipF-6

Hi, I have made the server changes but the issue persists.

July 30, 2019 at 12:00 pm #4307483

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know your site login details to check this closely.
The next reply is private.

Regards,

August 4, 2019 at 2:30 pm #4336539

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I see some of your pages are not completely translated: hidden link and you are not able to complete these translations because you have only 'two words' in allocated quota for Advanced translation editor: hidden link

You have to buy more words to continue.
Please refer : https://wpml.org/2018/12/machine-translation-quotas-for-wpmls-advanced-translation-editor/

Then try to complete the translation.

Let me know if you need anything else regarding this.

Regards,

August 4, 2019 at 10:28 pm #4337033

philipF-6

Hi, I am confused. I am not using machine translation for these pages. I have input manual translations, hit save and nothing saves. Are you suggesting that even with manual translation I still have to pay to add words to my website via wpml? Please advise

August 5, 2019 at 6:22 am #4338101

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am not using machine translation for these pages.
- but when I visit to those pages I see ATE: hidden link
- how is that possible?
- are you using ATE in some pages and classic editor in some pages?

Are you suggesting that even with manual translation I still have to pay to add words to my website via wpml?
- no

Regards,

August 6, 2019 at 5:13 pm #4349703

philipF-6

Hi Riffaz,

I looked into the settings and can confirm that 1998 words have been auto-translated. I am not sure why this is happening. I have all the manual translations to input into the editor yet it still does not allow me to save my manual translations. Not sure why.
Is the advanced editor only for automatic translation? If so, that could be the issue as I have only used that editor to input my translations. If switching to classic is the fix, can I switch to classic and still keep my translations that have already been applied?
Thank you in advance

August 7, 2019 at 11:07 am #4354163

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Is the advanced editor only for automatic translation?
- yes, and if there is any mistakes in the translation you can correct them manually.
- please refer : https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

can I switch to classic and still keep my translations that have already been applied?
- yes, you can keep your old translations.
- I checked in my site
- you can always switch back if there is any issue.
- here : hidden link

Let me know how it goes.

Regards,