Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bigul 1 year, 8 months ago.

Assigned support staff: Bigul.

Author Posts
May 16, 2019 at 1:04 pm

tomasD-10

Related to: https://wpml.org/forums/topic/translation-is-not-showing-2/

Hello, I have one more question. I translated another string, try to resave everything. And tried this:

1 - In your WordPress Dashboard > WPML > Theme and plugins localization I chose the option 'Translate themes and plugins using WPML's String Translation and always load .mo files as backup' for your 'Localization options' settings.

But nothing happened.

You can see in the attachment.

If there will be problem with accessing page, enter: cms as the first username and password.

May 16, 2019 at 6:03 pm #3828685

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Clear all types of caches

2) Go to WPML>>Support page

3) Click on Troubleshooting link (blue link in the middle of the page)

4) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Recreate ST DB cache tables

--
Thanks!

Bigul

May 16, 2019 at 10:26 pm #3829591

tomasD-10

Hello Bigul,
I did all steps you wrote me, but it did not help.

What should I do now?

Thank you!

May 17, 2019 at 9:46 am #3832831

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Just to make sure, only this string from *GoPay* plugin is not showing translation, am I right?

Please switch to *Translate themes and plugins using WPML's String Translation only (don't load .mo files)* option of *WPML>>Theme and plugins localization>>Localization options>>How to translate strings in themes and plugins?* for a moment to test and check is there any difference in the result or not.

Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

May 20, 2019 at 3:13 pm #3848247

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please check my last reply and let me know your feedback. Take your time. We will wait for you.

--
Thanks!

Bigul

The topic ‘[Closed] Translation not showing’ is closed to new replies.