This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: He had a page builder block not enabled for translation in his page.

Solution: The block shortcode name had a typo issue at WordPress Dashboard > WPML > Settings > Custom XML Configuration. This is why the translation editor wasn't targeting the page builder shortcode properly. I suggested a fix for the typo and also a direct translation in the page using the default WordPress page editor instead the WPML Translation Editor.

Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/

This topic contains 5 replies, has 3 voices.

Last updated by Pedro Henriques 11 months, 4 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
October 16, 2018 at 10:08 am #2820481

Pedro Henriques

I am trying to: translate

Link to a page where the issue can be seen: hidden link

I expected to see: "Mais do que Electricidade" (hidden link)

Instead, I got: "Eletricidade e Mais" (it's from a previous translation, updated)

October 17, 2018 at 5:42 pm #2825549

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Regarding your issue, do you see any other translation updated in frontend after a backend editing, or does it only happen with this specific text? Also, can you please, make sure:

  • Your page is completely translated
  • You have the option 'Translate themes and plugins using WPML's String Translation only (don't load .mo files)' checked at your WPML > Theme and plugins localization settings

Please, let me know if any other additional details are needed. Have a nice day.

October 17, 2018 at 5:44 pm #2825551

Pedro Henriques

Hello,

1. The translation isn't done 100% because there is a field I can't complete (hidden link), there's nothing to translate and nothing to copy. That's also an issue, reported here: https://wpml.org/forums/topic/empty-entries/
2. Yes, checked (hidden link).

Suggestions to fix it?

Thanks

October 18, 2018 at 3:15 pm #2828467

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 19, 2018 at 6:30 pm #2832822

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for getting in touch. I took a closer look in your website and I could notice the following:

The us_iconbox shortcode is not properly being sent for translation when using the translation editor and it happens because in your WordPress Dashboard > WPML > Settings > Custom XML Configuration you have:

<shortcode>
<tag>iconbox</tag>
<attributes>
<attribute>title</attribute>
<attribute>link_text</attribute>
</attributes>
</shortcode>

It should be: (I have fixed it in the staging environment)

<shortcode>
<tag>us_iconbox</tag>
<attributes>
<attribute>title</attribute>
<attribute>link_text</attribute>
</attributes>
</shortcode>

Another option is to edit the page using the default WordPress page editor, instead of WPML Translation Editor right at your WordPress Dashboard > Pages. It is matter of editing the page builder block directly in the desired language, I've made just that and it works properly.

So whenever you receive your translations in case you are using the WPML's Translation Management feature, you can review the missing translations and make a direct edit right in the desired language, it is a simple approach and it will save you a bit of time.

You can see the result at: hidden link

Please, let me know if you need any additional clarifications. Have a nice day.

October 22, 2018 at 9:34 am #2837417

Pedro Henriques

My issue is resolved now. Thank you, Marcos!