This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Raja Mohammed 7 months, 4 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
February 14, 2019 at 3:16 pm

hendrikS-12

I am trying to: show the already translated content at the back end on the front end

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: the English translation still showing on the dutch page. I unfortunately am not very good using these kind of plugins and have no background whatsoever. We had outsourced this work to someone who said they were certified in wpml but clearly they were not as I have tried to fix the problem myself. I eventually got translation to show on back end but yet nothing on front end. followed troubleshooting but am simply not understanding some of the processes I need to follow to make it work.

February 15, 2019 at 6:50 am #3202937

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our Forum, I will be handling your ticket.

We have the issue addressed in the latest WPML 4.2.1 release, Kindly update your WPML plugins and add-ons to the latest version to see if the problem persists?

Remember that it is recommended to back up your site before updating your plugins.

Let me know the results,

Kind regards,
Raja

February 19, 2019 at 7:28 am #3215265

hendrikS-12

Txs Raja,

Please advise the process of updating WPML on a multisite installation.

Awaiting your soonest response

Edwin

February 19, 2019 at 7:47 am #3215297

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hey Edwin,

log in to the main site dashboard using a Super Admin login. Are you able to update there? If not, please go to Plugins -> Add New and click on the Commercial tab. You should see a "Check for Updates" button. Then, you can update the WPML plugins from this screen and it should update for all sites within the multisite.

Remember that it is recommended to back up your site before updating your plugins.

Kind regards
Raja

February 19, 2019 at 9:42 am #3215778

hendrikS-12

I do have access to the network admin, but non of the WPML plugins show they need to be updated, although they are not the last stable versions.

Please advise how to trigger the automated updates, or alternatively the process to follow for manual update.
I have attached the screenshot of the current WPML plugins (and related)

February 19, 2019 at 10:59 am #3216221

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Can you please confirm did you check in "Plugins -> Add New" and click on the Commercial tab. You should see the list of available WPML plugin that needs to be updated. Select the appropriate plugin and update it.

let me know if the option is available.

Kind regards
Raja

February 19, 2019 at 11:57 am #3216443

hendrikS-12

As said, this is a multisite network and i cannot find anything of what you are suggesting.

There is no commercial tab in >>> "Plugins -> Add New" and click on the Commercial tab.

And there is also no Add new (plugin) in the admin from the sub-site
Hence, i can not register the site, nor do i see the list of the WPML plugins that needs to be updated (when clicking the Commercial Tab.

Please advise

February 19, 2019 at 12:38 pm #3216545

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Sorry, My reply was not clear, Please check the below steps

- WPML active on the main site
- go to Network Admin -> Plugins -> Add new and commercial tab will be there

Check the screenshot on where to look for the plugins

let me know if you need any assistance

Kind regards.
Raja

February 19, 2019 at 5:00 pm #3218245

hendrikS-12

I'm sorry Raja, but I can not, no matter what I try, generate this commercial tab...
I must be missing something here?

February 20, 2019 at 4:28 am #3219897

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Please create a temporary super admin account and share it with us for a closer look. once the issue is resolved you can delete the temporary account. I have enabled private fields for you to securely share the details. The information you enter can only be seen by you and me alone.

Kind regards,
Raja

February 20, 2019 at 1:19 pm #3221924

hendrikS-12

Good day Raja,

Please note that since this is a multisite, i have given you access (both ftp and Wp installation) to the root folder.

Let me know if you would need any further information

Edwin

February 20, 2019 at 1:23 pm #3221951

hendrikS-12

Sorry Raja,

I think i made a mistake and now i can not re-generate the secure fields

Please resend the secure form please

Edwin

February 21, 2019 at 5:24 am #3224962

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hey Edvin

Private fields enabled again.

Thanks

February 23, 2019 at 9:21 am
February 25, 2019 at 9:05 am #3238543

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have just noticed WPML plugin is deactivated, Once I have activated the plugin I can see the commercial tab. Kindly register the key and you can see the list of plug-ins that need an update.

Let me know if you need any assistance.

Kind regards
Raja