This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Itamar 1 month, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
August 8, 2019 at 2:34 pm #4363861

lauraM-29

I'm using String translation to translate text.
The website is an ecommerce in italian (main language) and english.
I have translated some strings from english to italian, for example "Related products" and "Clear selection" but the translations are not showing up in the fronted.

The website is on a development server with the same domain of the real site.

August 8, 2019 at 3:05 pm #4364115

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

1. Please try to re-save the translation:

- Go to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

- Then again go to: String Translation >> Re-add your translated text >> and re-save. Make sure that "Translation is complete" checkbox is selected.

2. Please delete all sorts of caches on your site / server cache if any / plugin cache / CDN cache (if any), clear browser cache and then see if it resolves the issue afterwards.

3. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

August 11, 2019 at 4:56 pm #4377161

lauraM-29

Hi Norman,
I tried the three steps you suggest, but the issue remains.

August 12, 2019 at 6:13 pm #4383045

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Noman is not available today so I'll continue to handle this ticket. I hope that it is alright with you.

Can you please tell where I can see this issue on your site?
Also please let me have access to your site so I can continue to check things.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Regards,
Itamar.

August 19, 2019 at 11:24 am #4415535

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

When I add the info that you gave me to the host file on my machine, and I try to access your site, I get redirected to this URL: hidden link
And when I insert the access details that you gave me, I get this message.

ERRORE: nome utente non valido. Password dimenticata?

Can you please check this issue and let me know when it is fixed so I can continue helping you?
If needed, you can edit last private message with the new access details.

Regards,
Itamar.

August 22, 2019 at 12:20 pm #4439203

lauraM-29

Hi Itamar,
I checked the information I gave you, but they are correct.
The only difference is that the first record doesn't have http:// but start with www.
Can you check and retry?

Thank you,
Marco

August 24, 2019 at 7:32 pm #4452213

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Marco.

Please see the following private message.

August 25, 2019 at 7:24 am #4453351

lauraM-29

Hi Itamar,
I edited the private message so you can see the correct information.
You have to remove the http:// in the host file.

Thank you,
Marco

August 26, 2019 at 10:01 am #4457341

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Marco and thanks. Now I can access your site.

I can see the issue with 'Additional information' and 'Related products' strings on a product page. You also mentioned that there is a problem with the "Clear selection" selection strings, but I was not sure where I could see this string. Please let me know about it.

In String Translation, I could see that all the instances of 'Additional information' and 'Related products are translated, but there is something weird only when I search for the "RELATED PRODUCTS" string. Then I can see that there is an extra field for translation, but it has no language. Please see the attached screenshot no-lang-extra-field.jpg.

In any case, I'm not certain if those issues are related to the strings issue that you bring on this thread.
Can you please tell me what the source of those strings is?
Are they coming from a specific plugin or your theme?
Do you have a place in the theme or plugins options to change those strings?
If so, then please explain to me where it is possible to change those strings.

I've also noticed that the are problems with the Language URL format in WPML -> Languages. In this section, you have chosen "Directory con lingue diverse". And also you have chosen "Usa la directory per la lingua predefinita". In overall there seems to be a problem with activating the languages in folders option on your server. But sometimes this error shows and things do work as expected. And also there is a problem that you have not specified an HTML file for the root domain. Please see the attached screenshot html-file.jpg More about the above issues at the link to our documentation.
https://wpml.org/faq/server-setting-for-languages-in-directories/
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/
https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/
If you need help with the above issues, then please open new tickets about them, as in our forum we try to keep one issue per ticket. If you want you can assign the new tickets to me.

Thanks,
Itamar.

August 26, 2019 at 11:05 am #4457875

lauraM-29

Hi Itamar,
"Additional information", "Related products" and "Clear selection" are only examples of not-translated-strings. I think that the problem is generalized for many stings (for example also "Share" in the same page).
And I see that some strings have an extra field for translation with no language set, but I checked and I haven't found other place where we can modify the translations.

The problem with the Language URL depends on the staging server, and it will be resolved when the site will be online.

Thanks,
Marco

August 27, 2019 at 12:47 pm #4466763

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks, Marco.

By checking things on your site, I think that the strings that you cannot translate are strings from your theme, the Vitrine theme.
Can you please confirm that?

Since I could see in String Translation two instances of the RELATED PRODUCTS string (for example) with the 'vitrine' domain, I suspected that causes the issue. So I've deleted those strings and re-scanned the theme for strings in WPML -> Theme and plugins localization. Then I could see again that two instances of those strings are showing. But unfortunately translating them again didn't help.

We might be looking here at a compatibility issue with the Vitrine theme. I don't have this theme with me. Could you please proceed with the following so I can continue to check the issue and if needed, escalate it to our compatibility team?

I created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
Could you please install the Vitrine and see if the issue is replicable on a clean WordPress installation?
Please configures WPML as it is configured on your site.
Please also make sure that you are installing the latest version of the theme.

Thanks,
Itamar.

August 29, 2019 at 8:49 am #4478815

lauraM-29

Hi Itamar,
I installed the theme and configured the WPML plugin.
I tried to translate the "Related products" string, and it worked.

So, what can I do to solve my problem now?

Thank you,
Marco

August 29, 2019 at 8:52 pm #4483545

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying to replicate the issue on the sandbox site.

We are going to need to debug the issue on a copy of your site. Please see the instruction at the following private message.

Thanks,
Itamar.

The topic ‘[Closed] Translation Not Showing Up On Frontend’ is closed to new replies.